]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] 043 release
[thirdparty/systemd.git] / udev.spec
CommitLineData
0c675896
GKH
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
05230184
GKH
8# if we want to have logging support in or not.
9# 0 - no logging support
10# 1 - logging support
11# Note, it is not recommend if you use klibc to enable logging.
12%define log 0
13
0c675896
GKH
14# if we want to enable debugging support in udev. If it is enabled, lots of
15# stuff will get sent to the debug syslog.
16# 0 - debugging disabled
17# 1 - debugging enabled
18%define debug 0
19
ca8e992c
GKH
20# if we want to build the scsi_id "extra" package or not
21# 0 - do not build the package
22# 1 - build it
23%define scsi_id 1
24
1eae2f3f
GKH
25# if we want to build the volume_id "extra" package or not
26# 0 - do not build the package
27# 1 - build it
28%define volume_id 1
29
3660f0b8
PM
30Summary: A userspace implementation of devfs
31Name: udev
5ca6ff64 32Version: 043
3660f0b8
PM
33Release: 1
34License: GPL
35Group: Utilities/System
36Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
37ExclusiveOS: Linux
e0929206 38Vendor: Greg Kroah-Hartman <greg@kroah.com>
8fc34188 39URL : kernel.org/pub/linux/utils/kernel/hotplug/
4360a56d 40BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 41Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
42
43%description
44udev is a implementation of devfs in userspace using sysfs and
22120496 45/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
46
47%prep
bbab56ba 48%setup -q
3660f0b8
PM
49
50%build
0c675896
GKH
51make CC="gcc $RPM_OPT_FLAGS" \
52%if %{klibc}
53 USE_KLIBC=true \
54%endif
05230184
GKH
55%if %{log}
56 USE_LOG=true \
1659326d
GKH
57%else
58 USE_LOG=false \
05230184 59%endif
0c675896
GKH
60%if %{debug}
61 DEBUG=true \
1659326d
GKH
62%else
63 DEBUG=false \
0c675896 64%endif
ca8e992c
GKH
65 EXTRAS=" \
66%if %{scsi_id}
67 extras/scsi_id \
68%endif
1eae2f3f
GKH
69%if %{volume_id}
70 extras/volume_id \
71%endif
ca8e992c 72"
d83a9b89 73
3660f0b8 74%install
3c60abb5 75rm -rf $RPM_BUILD_ROOT
5bfabc59 76make DESTDIR=$RPM_BUILD_ROOT install \
ca8e992c
GKH
77 EXTRAS=" \
78%if %{scsi_id}
79 extras/scsi_id \
80%endif
1eae2f3f
GKH
81%if %{volume_id}
82 extras/volume_id \
83%endif
ca8e992c 84"
e68582be 85
316c5150 86%post
87/sbin/chkconfig --add udev
88
600ee7f7 89%postun
90if [ $1 = 0 ]; then
91 /sbin/chkconfig --del udev
92fi
93
3660f0b8 94%clean
bbab56ba 95rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
96
97%files
ee156981 98%defattr(-,root,root)
824e6011 99%doc COPYING README TODO ChangeLog HOWTO* docs/*
100%doc etc/udev/udev.rules.{examples,gentoo,redhat}
101%doc etc/udev/udev.permissions.{gentoo,redhat}
bbab56ba 102%attr(755,root,root) /sbin/udev
0d1956de 103%attr(755,root,root) /usr/bin/udevinfo
d83a9b89
GKH
104%attr(755,root,root) /sbin/udevsend
105%attr(755,root,root) /sbin/udevd
d0dede8f 106%attr(755,root,root) /usr/bin/udevtest
1f63fbdd 107%attr(755,root,root) /sbin/udevstart
e68582be
GKH
108%attr(755,root,root) %dir /udev/
109%attr(755,root,root) %dir /etc/udev/
1b1dbc47 110%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
3c60abb5
AB
111%attr(755,root,root) %dir /etc/udev/rules.d/
112%attr(755,root,root) %dir /etc/udev/permissions.d/
113%config(noreplace) %attr(0644,root,root) /etc/udev/rules.d/50-udev.rules
114%config(noreplace) %attr(0644,root,root) /etc/udev/permissions.d/50-udev.permissions
8634e6d1 115%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 116%attr(755,root,root) /etc/init.d/udev
567f6d14 117%attr(0644,root,root) %{_mandir}/man8/udev*.8*
3c60abb5
AB
118%attr(755,root,root) %dir /etc/dev.d/
119%attr(755,root,root) %dir /etc/dev.d/net/
120%attr(0755,root,root) /etc/dev.d/net/hotplug.dev
3660f0b8 121
ca8e992c
GKH
122%if %{scsi_id}
123 %attr(755,root,root) /sbin/scsi_id
124 %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
125 %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
126%endif
1eae2f3f
GKH
127%if %{volume_id}
128 %attr(755,root,root) /sbin/udev_volume_id
129%endif
ca8e992c 130
3660f0b8 131%changelog
1eae2f3f
GKH
132* Fri May 14 2004 Greg Kroah-Hartman <greg@kroah.com>
133- remove dbus and selinux stuff from here
134- added volume_id option
135
6fb7313b 136* Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
b658bc09 137- change the way dbus and selinux support is built (now an extra)
6fb7313b 138
1f63fbdd
GKH
139* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
140- added udevstart to the list of files installed
0d1956de 141- udevinfo is now in /usr/bin not /sbin
1f63fbdd 142
7eb136ad
GKH
143* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
144- added ability to build with SELinux support
145
ca8e992c
GKH
146* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
147- add some more files to the documentation directory
148- add ability to build scsi_id and make it the default
149
e68582be
GKH
150* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
151- fix up udevd build, as it's no longer needed to be build seperatly
152- add udevtest to list of files
153- more Red Hat sync ups.
154
1659326d
GKH
155* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
156- add some changes from the latest Fedora udev release.
157
d83a9b89
GKH
158* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
159- add udevsend, and udevd to the files
160- add ability to build udevd with glibc after the rest is build with klibc
161
da1cc7cc 162* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
567f6d14 163- added udevinfo to rpm
8fc34188 164- added URL to spec file
567f6d14 165- added udevinfo's man page
da1cc7cc 166
e64280b8 167* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
168- add defines to choose the init script (Redhat or LSB)
169
316c5150 170* Tue Dec 16 2003 Robert Love <rml@ximian.com>
171- install the initscript and run chkconfig on it
172
e8baccca
GKH
173* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
174- changes due to config file name changes
175
bbab56ba
RL
176* Fri Oct 17 2003 Robert Love <rml@tech9.net>
177- Make work without a build root
178- Correctly install the right files
179- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
180- Put some prereqs in
8634e6d1 181- Install the hotplug symlink to udev
bbab56ba 182
3660f0b8
PM
183* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
184- Initial spec file for udev-0.2.