]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] v012 release
[thirdparty/systemd.git] / udev.spec
CommitLineData
0c675896
GKH
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
8# if we want to build DBUS support in or not.
9# 0 - no DBUS support
10# 1 - DBUS support
11%define dbus 0
12
13# if we want to enable debugging support in udev. If it is enabled, lots of
14# stuff will get sent to the debug syslog.
15# 0 - debugging disabled
16# 1 - debugging enabled
17%define debug 0
18
3660f0b8
PM
19Summary: A userspace implementation of devfs
20Name: udev
8c55357f 21Version: 012
3660f0b8
PM
22Release: 1
23License: GPL
24Group: Utilities/System
25Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
26ExclusiveOS: Linux
e0929206 27Vendor: Greg Kroah-Hartman <greg@kroah.com>
4360a56d 28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 29Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
30
31%description
32udev is a implementation of devfs in userspace using sysfs and
22120496 33/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
34
35%prep
bbab56ba 36%setup -q
3660f0b8
PM
37
38%build
0c675896
GKH
39make CC="gcc $RPM_OPT_FLAGS" \
40%if %{klibc}
41 USE_KLIBC=true \
42%endif
43%if %{dbus}
44 USE_DBUS=true \
45%endif
46%if %{debug}
47 DEBUG=true \
48%endif
3660f0b8
PM
49
50%install
5bfabc59 51make DESTDIR=$RPM_BUILD_ROOT install \
52%if %{dbus}
53 USE_DBUS=true
54%endif
3660f0b8 55
316c5150 56%post
57/sbin/chkconfig --add udev
58
600ee7f7 59%postun
60if [ $1 = 0 ]; then
61 /sbin/chkconfig --del udev
62fi
63
3660f0b8 64%clean
bbab56ba 65rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
66
67%files
ee156981 68%defattr(-,root,root)
bbab56ba
RL
69%doc COPYING README TODO ChangeLog
70%attr(755,root,root) /sbin/udev
71%attr(755,root,root) /udev/
72%attr(755,root,root) /etc/udev/
1b1dbc47 73%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
74%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
75%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
5bfabc59 76%if %{dbus}
77 %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
78%endif
8634e6d1 79%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 80%attr(755,root,root) /etc/init.d/udev
bbab56ba 81%attr(0644,root,root) %{_mandir}/man8/udev.8*
3660f0b8
PM
82
83%changelog
316c5150 84* Tue Dec 16 2003 Robert Love <rml@ximian.com>
85- install the initscript and run chkconfig on it
86
e8baccca
GKH
87* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
88- changes due to config file name changes
89
bbab56ba
RL
90* Fri Oct 17 2003 Robert Love <rml@tech9.net>
91- Make work without a build root
92- Correctly install the right files
93- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
94- Put some prereqs in
8634e6d1 95- Install the hotplug symlink to udev
bbab56ba 96
3660f0b8
PM
97* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
98- Initial spec file for udev-0.2.
99