]> git.ipfire.org Git - thirdparty/systemd.git/blame_incremental - udev.spec
[PATCH] v011 release
[thirdparty/systemd.git] / udev.spec
... / ...
CommitLineData
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
8# if we want to build DBUS support in or not.
9# 0 - no DBUS support
10# 1 - DBUS support
11%define dbus 0
12
13# if we want to enable debugging support in udev. If it is enabled, lots of
14# stuff will get sent to the debug syslog.
15# 0 - debugging disabled
16# 1 - debugging enabled
17%define debug 0
18
19Summary: A userspace implementation of devfs
20Name: udev
21Version: 011
22Release: 1
23License: GPL
24Group: Utilities/System
25Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
26ExclusiveOS: Linux
27Vendor: Greg Kroah-Hartman <greg@kroah.com>
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29Prereq: /bin/sh, fileutils, hotplug
30
31%description
32udev is a implementation of devfs in userspace using sysfs and
33/sbin/hotplug. It requires a 2.6 kernel to run properly.
34
35%prep
36%setup -q
37
38%build
39make CC="gcc $RPM_OPT_FLAGS" \
40%if %{klibc}
41 USE_KLIBC=true \
42%endif
43%if %{dbus}
44 USE_DBUS=true \
45%endif
46%if %{debug}
47 DEBUG=true \
48%endif
49
50%install
51make DESTDIR=$RPM_BUILD_ROOT install
52
53%post
54/sbin/chkconfig --add udev
55
56%postun
57if [ $1 = 0 ]; then
58 /sbin/chkconfig --del udev
59fi
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(-,root,root)
66%doc COPYING README TODO ChangeLog
67%attr(755,root,root) /sbin/udev
68%attr(755,root,root) /udev/
69%attr(755,root,root) /etc/udev/
70%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
71%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
72%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
73%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
74%attr(755,root,root) /etc/init.d/udev
75%attr(0644,root,root) %{_mandir}/man8/udev.8*
76
77%changelog
78* Tue Dec 16 2003 Robert Love <rml@ximian.com>
79- install the initscript and run chkconfig on it
80
81* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
82- changes due to config file name changes
83
84* Fri Oct 17 2003 Robert Love <rml@tech9.net>
85- Make work without a build root
86- Correctly install the right files
87- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
88- Put some prereqs in
89- Install the hotplug symlink to udev
90
91* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
92- Initial spec file for udev-0.2.
93