]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - hwdb/meson.build
build-sys: use #if Y instead of #ifdef Y everywhere
[thirdparty/systemd.git] / hwdb / meson.build
index b9fc5ab5942cefa7910d498a7aa5e057e997af20..a5175039cd97173abca6109bdc80e995e9032487 100644 (file)
@@ -12,12 +12,13 @@ hwdb_files = files('''
         60-evdev.hwdb
         60-keyboard.hwdb
         60-sensor.hwdb
+        70-joystick.hwdb
         70-mouse.hwdb
         70-pointingstick.hwdb
         70-touchpad.hwdb
 '''.split())
 
-if conf.get('ENABLE_HWDB', 0) == 1
+if conf.get('ENABLE_HWDB') == 1
         install_data(hwdb_files,
                      install_dir : udevhwdbdir)
 
@@ -31,7 +32,13 @@ endif
 
 ############################################################
 
-custom_target(
-        'update',
-        output : 'update',
+parse_hwdb_py = find_program('parse_hwdb.py')
+test('parse-hwdb',
+     parse_hwdb_py,
+     timeout : 90)
+
+############################################################
+
+run_target(
+        'hwdb-update',
         command : [hwdb_update_sh, meson.current_source_dir()])