]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - man/meson.build
build-sys: use #if Y instead of #ifdef Y everywhere
[thirdparty/systemd.git] / man / meson.build
index a93693c43cc0b0d9f1adbb76b1676e05000b6d7a..7d28e6ba1ad577adff4799a52a121f9f3a1dc2a9 100644 (file)
@@ -11,6 +11,7 @@ want_html = want_html != 'false' and xsltproc.found()
 xsltproc_flags = [
         '--nonet',
         '--xinclude',
+        '--maxdepth', '9000',
         '--stringparam', 'man.output.quietly', '1',
         '--stringparam', 'funcsynopsis.style', 'ansi',
         '--stringparam', 'man.authors.section.enabled', '0',
@@ -50,7 +51,7 @@ foreach tuple : manpages
 
         mandirn = join_paths(get_option('mandir'), 'man' + section)
 
-        if condition == '' or conf.get(condition, false)
+        if condition == '' or conf.get(condition) == 1
                 p1 = custom_target(
                         man,
                         input : xml,
@@ -170,10 +171,10 @@ man = custom_target(
         depends : man_pages,
         command : ['echo'])
 
-html = run_target(
+html = custom_target(
         'html',
-        depends : html_pages,
         output : 'html',
+        depends : html_pages,
         command : ['echo'])
 
 run_target(
@@ -191,8 +192,9 @@ run_target(
 ############################################################
 
 if git.found()
-        run_target(
+        custom_target(
                 'update-man-rules',
+                output : 'update-man-rules',
                 # slightly strange syntax because of
                 # https://github.com/mesonbuild/meson/issues/1643
                 # and https://github.com/mesonbuild/meson/issues/1512