]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - rules/meson.build
Merge pull request #12351 from keszybz/sd-bus-add-symbol
[thirdparty/systemd.git] / rules / meson.build
index 56a270712a4874441c3f2c6d0c0677b82905ba66..b6a32ba77e23aee6763182da060caee56af5fb7a 100644 (file)
@@ -1,19 +1,4 @@
 # SPDX-License-Identifier: LGPL-2.1+
-#
-# Copyright 2017 Zbigniew JÄ™drzejewski-Szmek
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-#
-# systemd is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public License
-# along with systemd; If not, see <http://www.gnu.org/licenses/>.
 
 rules = files('''
         60-block.rules
@@ -41,6 +26,8 @@ rules = files('''
 install_data(rules,
              install_dir : udevrulesdir)
 
+all_rules = rules
+
 rules_in = '''
         50-udev-default.rules
         64-btrfs.rules
@@ -54,4 +41,5 @@ foreach file : rules_in
                 configuration : substs)
         install_data(gen,
                      install_dir : udevrulesdir)
+        all_rules += gen
 endforeach