]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - src/boot/efi/meson.build
build-sys: use #if Y instead of #ifdef Y everywhere
[thirdparty/systemd.git] / src / boot / efi / meson.build
index 6241cb1c19c1d09843aeffb7df060bd6b7645905..eb0be02977c21d3a99266ce4bc98560346109fc9 100644 (file)
@@ -4,22 +4,24 @@ efi_headers = files('''
         graphics.h
         linux.h
         measure.h
-        pefile.h
+        pe.h
         splash.h
         util.h
+        shim.h
 '''.split())
 
 common_sources = '''
         disk.c
         graphics.c
         measure.c
-        pefile.c
+        pe.c
         util.c
 '''.split()
 
 systemd_boot_sources = '''
         boot.c
         console.c
+        shim.c
 '''.split()
 
 stub_sources = '''
@@ -28,7 +30,7 @@ stub_sources = '''
         stub.c
 '''.split()
 
-if conf.get('ENABLE_EFI', 0) == 1 and get_option('gnu-efi') != 'false'
+if conf.get('ENABLE_EFI') == 1 and get_option('gnu-efi') != 'false'
         efi_cc = get_option('efi-cc')
         efi_ld = get_option('efi-ld')
 
@@ -62,7 +64,7 @@ if have_gnu_efi
         efi_conf = configuration_data()
         efi_conf.set_quoted('PACKAGE_VERSION', meson.project_version())
         efi_conf.set_quoted('EFI_MACHINE_TYPE_NAME', EFI_MACHINE_TYPE_NAME)
-        efi_conf.set('SD_BOOT_LOG_TPM', get_option('tpm'))
+        efi_conf.set10('ENABLE_TPM', get_option('tpm'))
         efi_conf.set('SD_TPM_PCR', get_option('tpm-pcrindex'))
 
         efi_config_h = configure_file(