]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - src/resolve/meson.build
tree-wide: beautify remaining copyright statements
[thirdparty/systemd.git] / src / resolve / meson.build
index 15752d24ffdf3158a390d0fd857970bc4c3b4182..aae5faf5cd7104e3cae20c52c10028ce0aa5fe45 100644 (file)
@@ -1,19 +1,6 @@
 # SPDX-License-Identifier: LGPL-2.1+
 #
-# Copyright 2017 Zbigniew Jędrzejewski-Szmek
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-#
-# systemd is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public License
-# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+# Copyright © 2017 Zbigniew Jędrzejewski-Szmek
 
 basic_dns_sources = files('''
         resolved-dns-dnssec.c
@@ -80,7 +67,12 @@ systemd_resolved_sources = files('''
         resolved-etc-hosts.c
 '''.split())
 
-systemd_resolve_sources = files('resolve-tool.c')
+resolvectl_sources = files('''
+         resolvconf-compat.c
+         resolvconf-compat.h
+         resolvectl.c
+         resolvectl.h
+'''.split())
 
 ############################################################
 
@@ -154,6 +146,8 @@ if conf.get('ENABLE_RESOLVE') == 1
                      install_dir : dbuspolicydir)
         install_data('org.freedesktop.resolve1.service',
                      install_dir : dbussystemservicedir)
+        install_data('org.freedesktop.resolve1.policy',
+                     install_dir : polkitpolicydir)
 
         resolved_conf = configure_file(
                 input : 'resolved.conf.in',
@@ -164,15 +158,6 @@ if conf.get('ENABLE_RESOLVE') == 1
 
         install_data('resolv.conf',
                      install_dir : rootlibexecdir)
-
-        i18n.merge_file(
-                'org.freedesktop.resolve1.policy',
-                input : 'org.freedesktop.resolve1.policy.in',
-                output : 'org.freedesktop.resolve1.policy',
-                po_dir : po_dir,
-                data_dirs : po_dir,
-                install : install_polkit,
-                install_dir : polkitpolicydir)
 endif
 
 tests += [