]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - src/shared/meson.build
build-sys: use #if Y instead of #ifdef Y everywhere
[thirdparty/systemd.git] / src / shared / meson.build
index ce84d007d1651aa3b3743d0e7621e97a0375e1a5..bb9720a94a97217947335f821a397d8fee578e3b 100644 (file)
@@ -104,19 +104,19 @@ shared_sources = '''
 test_tables_h = files('test-tables.h')
 shared_sources += [test_tables_h]
 
-if conf.get('HAVE_ACL', false)
+if conf.get('HAVE_ACL') == 1
         shared_sources += ['acl-util.c']
 endif
 
-if conf.get('HAVE_UTMP', false)
+if conf.get('HAVE_UTMP') == 1
         shared_sources += ['utmp-wtmp.c']
 endif
 
-if conf.get('HAVE_SECCOMP', false)
+if conf.get('HAVE_SECCOMP') == 1
         shared_sources += ['seccomp-util.c']
 endif
 
-if conf.get('HAVE_LIBIPTC', false)
+if conf.get('HAVE_LIBIPTC') == 1
         shared_sources += ['firewall-util.c']
 endif