]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - src/shared/meson.build
Merge pull request #12252 from keszybz/libmount-dont-unescape
[thirdparty/systemd.git] / src / shared / meson.build
index f7f63a54042cae6561e193d4b03aabbb86862b3b..e05fbce30f3b8c108b98ac57ce516b10968942d4 100644 (file)
@@ -21,10 +21,14 @@ shared_sources = files('''
         bootspec.h
         bpf-program.c
         bpf-program.h
+        bus-unit-procs.c
+        bus-unit-procs.h
         bus-unit-util.c
         bus-unit-util.h
         bus-util.c
         bus-util.h
+        bus-wait-for-jobs.c
+        bus-wait-for-jobs.h
         calendarspec.c
         calendarspec.h
         cgroup-show.c
@@ -41,6 +45,7 @@ shared_sources = files('''
         cpu-set-util.h
         crypt-util.c
         crypt-util.h
+        daemon-util.h
         dev-setup.c
         dev-setup.h
         dissect-image.c
@@ -52,6 +57,8 @@ shared_sources = files('''
         efivars.c
         efivars.h
         enable-mempool.c
+        env-file-label.c
+        env-file-label.h
         exec-util.c
         exec-util.h
         exit-status.c
@@ -79,6 +86,8 @@ shared_sources = files('''
         install-printf.h
         install.c
         install.h
+        ip-protocol-list.c
+        ip-protocol-list.h
         journal-importer.c
         journal-importer.h
         journal-util.c
@@ -86,8 +95,10 @@ shared_sources = files('''
         json-internal.h
         json.c
         json.h
+        libmount-util.h
         lockfile-util.c
         lockfile-util.h
+        log-link.h
         logs-show.c
         logs-show.h
         loop-util.c
@@ -96,23 +107,31 @@ shared_sources = files('''
         machine-image.h
         machine-pool.c
         machine-pool.h
+        main-func.h
         module-util.h
+        mount-util.c
+        mount-util.h
+        nscd-flush.c
+        nscd-flush.h
         nsflags.c
         nsflags.h
         os-util.c
         os-util.h
         output-mode.c
         output-mode.h
+        pager.c
+        pager.h
         path-lookup.c
         path-lookup.h
+        pe-header.h
+        pretty-print.c
+        pretty-print.h
         ptyfwd.c
         ptyfwd.h
         reboot-util.c
         reboot-util.h
         resolve-util.c
         resolve-util.h
-        rlimit-util.c
-        rlimit-util.h
         seccomp-util.h
         securebits-util.c
         securebits-util.h
@@ -120,8 +139,6 @@ shared_sources = files('''
         serialize.h
         sleep-config.c
         sleep-config.h
-        socket-protocol-list.c
-        socket-protocol-list.h
         spawn-ask-password-agent.c
         spawn-ask-password-agent.h
         spawn-polkit-agent.c
@@ -132,6 +149,8 @@ shared_sources = files('''
         switch-root.h
         sysctl-util.c
         sysctl-util.h
+        tmpfile-util-label.c
+        tmpfile-util-label.h
         tomoyo-util.c
         tomoyo-util.h
         udev-util.c
@@ -181,6 +200,46 @@ if conf.get('HAVE_KMOD') == 1
         shared_sources += files('module-util.c')
 endif
 
+generate_ip_protocol_list = find_program('generate-ip-protocol-list.sh')
+ip_protocol_list_txt = custom_target(
+        'ip-protocol-list.txt',
+        output : 'ip-protocol-list.txt',
+        command : [generate_ip_protocol_list, cpp],
+        capture : true)
+
+fname = 'ip-protocol-from-name.gperf'
+gperf_file = custom_target(
+        fname,
+        input : ip_protocol_list_txt,
+        output : fname,
+        command : [generate_gperfs, 'ip_protocol', 'IPPROTO_', '@INPUT@'],
+        capture : true)
+
+fname = 'ip-protocol-from-name.h'
+target1 = custom_target(
+        fname,
+        input : gperf_file,
+        output : fname,
+        command : [gperf,
+                   '-L', 'ANSI-C', '-t', '--ignore-case',
+                   '-N', 'lookup_ip_protocol',
+                   '-H', 'hash_ip_protocol_name',
+                   '-p', '-C',
+                   '@INPUT@'],
+        capture : true)
+
+fname = 'ip-protocol-to-name.h'
+awkscript = 'ip-protocol-to-name.awk'
+target2 = custom_target(
+        fname,
+        input : [awkscript, ip_protocol_list_txt],
+        output : fname,
+        command : [awk, '-f', '@INPUT0@', '@INPUT1@'],
+        capture : true)
+
+shared_generated_gperf_headers = [target1, target2]
+shared_sources += shared_generated_gperf_headers
+
 libshared_name = 'systemd-shared-@0@'.format(meson.project_version())
 
 libshared_deps = [threads,
@@ -191,6 +250,7 @@ libshared_deps = [threads,
                   libgcrypt,
                   libiptc,
                   libkmod,
+                  libmount,
                   libseccomp,
                   libselinux,
                   libidn,