]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - sysusers.d/meson.build
build-sys: use #if Y instead of #ifdef Y everywhere
[thirdparty/systemd.git] / sysusers.d / meson.build
index b7c02cf8828614e8f39f29902acde925ab24da56..2f3f3ebd998b58f6206921dc388686f1e9111b33 100644 (file)
@@ -1,6 +1,6 @@
 in_files = ['basic.conf']
 
-enable_sysusers = conf.get('ENABLE_SYSUSERS', false)
+enable_sysusers = conf.get('ENABLE_SYSUSERS') == 1
 
 foreach file : in_files
         gen = configure_file(
@@ -15,7 +15,7 @@ endforeach
 
 m4_files = ['systemd.conf']
 
-if conf.get('ENABLE_REMOTE', false) and conf.get('HAVE_MICROHTTPD', false)
+if conf.get('ENABLE_REMOTE') == 1 and conf.get('HAVE_MICROHTTPD') == 1
         m4_files += ['systemd-remote.conf']
 endif