]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - test/meson.build
test-execute: rename tests for AmbientCapabilities=
[thirdparty/systemd.git] / test / meson.build
index 8f0c6ab9095f47e5ca78181205facc384abb3e0d..f86cf388e07b559aeae002f171c577314c4ed5f9 100644 (file)
@@ -45,24 +45,33 @@ test_data_files = '''
         sockets.target
         son.service
         sysinit.target
-        test-execute/exec-bind-paths.service
-        test-execute/exec-capabilityambientset-merge-nfsnobody.service
-        test-execute/exec-capabilityambientset-merge.service
-        test-execute/exec-capabilityambientset-nfsnobody.service
-        test-execute/exec-capabilityambientset.service
+        test-execute/exec-ambientcapabilities-merge-nfsnobody.service
+        test-execute/exec-ambientcapabilities-merge-nobody.service
+        test-execute/exec-ambientcapabilities-merge.service
+        test-execute/exec-ambientcapabilities-nfsnobody.service
+        test-execute/exec-ambientcapabilities-nobody.service
+        test-execute/exec-ambientcapabilities.service
+        test-execute/exec-bindpaths.service
         test-execute/exec-capabilityboundingset-invert.service
         test-execute/exec-capabilityboundingset-merge.service
         test-execute/exec-capabilityboundingset-reset.service
         test-execute/exec-capabilityboundingset-simple.service
+        test-execute/exec-cpuaffinity1.service
+        test-execute/exec-cpuaffinity2.service
+        test-execute/exec-cpuaffinity3.service
         test-execute/exec-dynamicuser-fixeduser-one-supplementarygroup.service
         test-execute/exec-dynamicuser-fixeduser.service
-        test-execute/exec-dynamicuser-state-dir.service
+        test-execute/exec-dynamicuser-statedir-migrate-step1.service
+        test-execute/exec-dynamicuser-statedir-migrate-step2.service
+        test-execute/exec-dynamicuser-statedir.service
         test-execute/exec-dynamicuser-supplementarygroups.service
         test-execute/exec-environment-empty.service
         test-execute/exec-environment-multiple.service
         test-execute/exec-environment.service
         test-execute/exec-environmentfile.service
         test-execute/exec-group-nfsnobody.service
+        test-execute/exec-group-nobody.service
+        test-execute/exec-group-nogroup.service
         test-execute/exec-group.service
         test-execute/exec-ignoresigpipe-no.service
         test-execute/exec-ignoresigpipe-yes.service
@@ -96,24 +105,26 @@ test_data_files = '''
         test-execute/exec-protectkernelmodules-no-capabilities.service
         test-execute/exec-protectkernelmodules-yes-capabilities.service
         test-execute/exec-protectkernelmodules-yes-mount-propagation.service
-        test-execute/exec-read-only-path-succeed.service
         test-execute/exec-readonlypaths-mount-propagation.service
+        test-execute/exec-readonlypaths-simple.service
         test-execute/exec-readonlypaths-with-bindpaths.service
         test-execute/exec-readonlypaths.service
         test-execute/exec-readwritepaths-mount-propagation.service
-        test-execute/exec-restrict-namespaces-mnt-blacklist.service
-        test-execute/exec-restrict-namespaces-mnt.service
-        test-execute/exec-restrict-namespaces-no.service
-        test-execute/exec-restrict-namespaces-yes.service
+        test-execute/exec-restrictnamespaces-mnt-blacklist.service
+        test-execute/exec-restrictnamespaces-mnt.service
+        test-execute/exec-restrictnamespaces-no.service
+        test-execute/exec-restrictnamespaces-yes.service
         test-execute/exec-runtimedirectory-mode.service
         test-execute/exec-runtimedirectory-owner-nfsnobody.service
+        test-execute/exec-runtimedirectory-owner-nobody.service
+        test-execute/exec-runtimedirectory-owner-nogroup.service
         test-execute/exec-runtimedirectory-owner.service
         test-execute/exec-runtimedirectory.service
-        test-execute/exec-spec-interpolation.service
+        test-execute/exec-specifier-interpolation.service
         test-execute/exec-specifier.service
         test-execute/exec-specifier@.service
-        test-execute/exec-stdin-data.service
-        test-execute/exec-stdio-file.service
+        test-execute/exec-standardinput-data.service
+        test-execute/exec-standardinput-file.service
         test-execute/exec-supplementarygroups-multiple-groups-default-group-user.service
         test-execute/exec-supplementarygroups-multiple-groups-withgid.service
         test-execute/exec-supplementarygroups-multiple-groups-withuid.service
@@ -127,13 +138,19 @@ test_data_files = '''
         test-execute/exec-systemcallfilter-not-failing.service
         test-execute/exec-systemcallfilter-not-failing2.service
         test-execute/exec-systemcallfilter-system-user-nfsnobody.service
+        test-execute/exec-systemcallfilter-system-user-nobody.service
         test-execute/exec-systemcallfilter-system-user.service
         test-execute/exec-systemcallfilter-with-errno-name.service
         test-execute/exec-systemcallfilter-with-errno-number.service
+        test-execute/exec-temporaryfilesystem-options.service
+        test-execute/exec-temporaryfilesystem-ro.service
+        test-execute/exec-temporaryfilesystem-rw.service
+        test-execute/exec-temporaryfilesystem-usr.service
         test-execute/exec-umask-0177.service
         test-execute/exec-umask-default.service
-        test-execute/exec-unset-environment.service
+        test-execute/exec-unsetenvironment.service
         test-execute/exec-user-nfsnobody.service
+        test-execute/exec-user-nobody.service
         test-execute/exec-user.service
         test-execute/exec-workingdirectory.service
         test-path/basic.target
@@ -219,5 +236,8 @@ test('udev-test',
 if conf.get('ENABLE_HWDB') == 1
         hwdb_test_sh = find_program('hwdb-test.sh')
         test('hwdb-test',
-             hwdb_test_sh)
+             hwdb_test_sh,
+             timeout : 90)
 endif
+
+subdir('fuzz-regressions')