]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - tmpfiles.d/meson.build
build-sys: use #if Y instead of #ifdef Y everywhere
[thirdparty/systemd.git] / tmpfiles.d / meson.build
index 29efe21f9d91199c2d9e3b7536eb05a7c49b7677..9a594a289a4817231aa4a454b7f48594f954c0cf 100644 (file)
@@ -1,4 +1,4 @@
-enable_tmpfiles = conf.get('ENABLE_TMPFILES', false)
+enable_tmpfiles = conf.get('ENABLE_TMPFILES') == 1
 
 tmpfiles = [['home.conf',            ''],
             ['journal-nocow.conf',   ''],
@@ -12,7 +12,7 @@ tmpfiles = [['home.conf',            ''],
 foreach pair : tmpfiles
         if not enable_tmpfiles
                 # do nothing
-        elif pair[1] == '' or conf.get(pair[1], false)
+        elif pair[1] == '' or conf.get(pair[1]) == 1
                 install_data(pair[0], install_dir : tmpfilesdir)
         else
                 message('Not installing tmpfiles.d/@0@ because @1@ is @2@'
@@ -22,14 +22,13 @@ endforeach
 
 m4_files = [['etc.conf',             ''],
             ['systemd.conf',         ''],
-            ['systemd-remote.conf',  'ENABLE_REMOTE'],
             ['var.conf',             ''],
            ]
 
 foreach pair : m4_files
         if not enable_tmpfiles
                 # do nothing
-        elif pair[1] == '' or conf.get(pair[1], false)
+        elif pair[1] == '' or conf.get(pair[1]) == 1
                 custom_target(
                         'tmpfiles.d_' + pair[0],
                          input : pair[0] + '.m4',