]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - tmpfiles.d/meson.build
build-sys: use #if Y instead of #ifdef Y everywhere
[thirdparty/systemd.git] / tmpfiles.d / meson.build
index dfbe04a976d0f99b2f5053abb1a086b49df24c18..9a594a289a4817231aa4a454b7f48594f954c0cf 100644 (file)
@@ -1,12 +1,10 @@
-enable_tmpfiles = conf.get('ENABLE_TMPFILES', 0) == 1
+enable_tmpfiles = conf.get('ENABLE_TMPFILES') == 1
 
 tmpfiles = [['home.conf',            ''],
             ['journal-nocow.conf',   ''],
             ['systemd-nologin.conf', ''],
             ['systemd-nspawn.conf',  ''],
-            ['systemd-remote.conf',  'ENABLE_REMOTE'],
             ['tmp.conf',             ''],
-            ['var.conf',             ''],
             ['x11.conf',             ''],
             ['legacy.conf',          'HAVE_SYSV_COMPAT'],
            ]
@@ -14,7 +12,7 @@ tmpfiles = [['home.conf',            ''],
 foreach pair : tmpfiles
         if not enable_tmpfiles
                 # do nothing
-        elif pair[1] == '' or conf.get(pair[1], 0) == 1
+        elif pair[1] == '' or conf.get(pair[1]) == 1
                 install_data(pair[0], install_dir : tmpfilesdir)
         else
                 message('Not installing tmpfiles.d/@0@ because @1@ is @2@'
@@ -22,18 +20,27 @@ foreach pair : tmpfiles
         endif
 endforeach
 
-m4_files = ['etc.conf',
-            'systemd.conf']
+m4_files = [['etc.conf',             ''],
+            ['systemd.conf',         ''],
+            ['var.conf',             ''],
+           ]
 
-foreach file : m4_files
-        custom_target(
-                'tmpfiles.d/' + file,
-                input : file + '.m4',
-                output: file,
-                command : [m4, '-P'] + m4_defines + ['@INPUT@'],
-                capture : true,
-                install : enable_tmpfiles,
-                install_dir : tmpfilesdir)
+foreach pair : m4_files
+        if not enable_tmpfiles
+                # do nothing
+        elif pair[1] == '' or conf.get(pair[1]) == 1
+                custom_target(
+                        'tmpfiles.d_' + pair[0],
+                         input : pair[0] + '.m4',
+                         output: pair[0],
+                         command : [m4, '-P'] + m4_defines + ['@INPUT@'],
+                         capture : true,
+                         install : true,
+                         install_dir : tmpfilesdir)
+        else
+                message('Not installing tmpfiles.d/@0@.m4 because @1@ is @2@'
+                        .format(pair[0], pair[1], conf.get(pair[1], 0)))
+        endif
 endforeach
 
 if enable_tmpfiles