]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - tmpfiles.d/meson.build
install-file: make fs_make_very_read_only() static
[thirdparty/systemd.git] / tmpfiles.d / meson.build
index d5d4bbc9ea4e59471c58861a2f397603d7e3f44e..bec24ac7b4db119a5db9eee6eb2aca55bd641b96 100644 (file)
@@ -5,14 +5,17 @@ enable_tmpfiles = conf.get('ENABLE_TMPFILES') == 1
 files = [['README',               ''],
          ['home.conf',            ''],
          ['journal-nocow.conf',   ''],
+         ['portables.conf',       'ENABLE_PORTABLED'],
+         ['systemd-network.conf', 'ENABLE_NETWORKD'],
          ['systemd-nologin.conf', 'HAVE_PAM'],
          ['systemd-nspawn.conf',  'ENABLE_MACHINED'],
-         ['systemd-tmp.conf',     ''],
-         ['portables.conf',       'ENABLE_PORTABLED'],
          ['systemd-pstore.conf',  'ENABLE_PSTORE'],
+         ['systemd-resolve.conf', 'ENABLE_RESOLVE'],
+         ['systemd-tmp.conf',     ''],
          ['tmp.conf',             ''],
          ['x11.conf',             ''],
-         ['legacy.conf',          'HAVE_SYSV_COMPAT'],
+         ['provision.conf',       ''],
+         ['credstore.conf',       ''],
         ]
 
 foreach pair : files
@@ -26,38 +29,32 @@ foreach pair : files
         endif
 endforeach
 
-in_files = ['static-nodes-permissions.conf']
-
-foreach file : in_files
-        gen = configure_file(
-                input : file + '.in',
-                output : file,
-                configuration : substs)
-        if enable_tmpfiles
-                install_data(gen,
-                             install_dir : tmpfilesdir)
-        endif
-endforeach
-
-m4_files = ['etc.conf',
-            'systemd.conf',
-            'var.conf']
+in_files = [['etc.conf',                      ''],
+            ['legacy.conf',                   'HAVE_SYSV_COMPAT'],
+            ['static-nodes-permissions.conf', ''],
+            ['systemd.conf',                  ''],
+            ['var.conf',                      ''],
+            ['20-systemd-userdb.conf',        'ENABLE_SSH_USERDB_CONFIG'],
+            ['20-systemd-ssh-generator.conf', 'ENABLE_SSH_PROXY_CONFIG'],
+           ]
 
-foreach file : m4_files
-        if enable_tmpfiles
+foreach pair : in_files
+        if not enable_tmpfiles
+                # do nothing
+        elif pair[1] == '' or conf.get(pair[1]) == 1
                 custom_target(
-                        'tmpfiles.d_' + file,
-                         input : file + '.m4',
-                         output: file,
-                         command : [meson_apply_m4, config_h, '@INPUT@'],
-                         capture : true,
-                         install : true,
-                         install_dir : tmpfilesdir)
+                        pair[0],
+                        input : pair[0] + '.in',
+                        output: pair[0],
+                        command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+                        install : enable_tmpfiles,
+                        install_dir : tmpfilesdir)
+        else
+                message('Not installing tmpfiles.d/@0@ because @1@ is @2@'
+                        .format(pair[0], pair[1], conf.get(pair[1], 0)))
         endif
 endforeach
 
 if enable_tmpfiles and install_sysconfdir
-        meson.add_install_script(
-                'sh', '-c',
-                mkdir_p.format(join_paths(sysconfdir, 'tmpfiles.d')))
+        install_emptydir(sysconfdir / 'tmpfiles.d')
 endif