]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - tmpfiles.d/meson.build
Merge pull request #12390 from poettering/string-file-mkdir
[thirdparty/systemd.git] / tmpfiles.d / meson.build
index 29efe21f9d91199c2d9e3b7536eb05a7c49b7677..f14b4fc6dffc6e2291a8b5b42709304eef50055a 100644 (file)
@@ -1,9 +1,13 @@
-enable_tmpfiles = conf.get('ENABLE_TMPFILES', false)
+# SPDX-License-Identifier: LGPL-2.1+
+
+enable_tmpfiles = conf.get('ENABLE_TMPFILES') == 1
 
 tmpfiles = [['home.conf',            ''],
             ['journal-nocow.conf',   ''],
-            ['systemd-nologin.conf', ''],
-            ['systemd-nspawn.conf',  ''],
+            ['systemd-nologin.conf', 'HAVE_PAM'],
+            ['systemd-nspawn.conf',  'ENABLE_MACHINED'],
+            ['systemd-tmp.conf',     ''],
+            ['portables.conf',       'ENABLE_PORTABLED'],
             ['tmp.conf',             ''],
             ['x11.conf',             ''],
             ['legacy.conf',          'HAVE_SYSV_COMPAT'],
@@ -12,7 +16,7 @@ tmpfiles = [['home.conf',            ''],
 foreach pair : tmpfiles
         if not enable_tmpfiles
                 # do nothing
-        elif pair[1] == '' or conf.get(pair[1], false)
+        elif pair[1] == '' or conf.get(pair[1]) == 1
                 install_data(pair[0], install_dir : tmpfilesdir)
         else
                 message('Not installing tmpfiles.d/@0@ because @1@ is @2@'
@@ -22,19 +26,18 @@ endforeach
 
 m4_files = [['etc.conf',             ''],
             ['systemd.conf',         ''],
-            ['systemd-remote.conf',  'ENABLE_REMOTE'],
             ['var.conf',             ''],
            ]
 
 foreach pair : m4_files
         if not enable_tmpfiles
                 # do nothing
-        elif pair[1] == '' or conf.get(pair[1], false)
+        elif pair[1] == '' or conf.get(pair[1]) == 1
                 custom_target(
                         'tmpfiles.d_' + pair[0],
                          input : pair[0] + '.m4',
                          output: pair[0],
-                         command : [m4, '-P'] + m4_defines + ['@INPUT@'],
+                         command : [meson_apply_m4, config_h, '@INPUT@'],
                          capture : true,
                          install : true,
                          install_dir : tmpfilesdir)