]> git.ipfire.org Git - thirdparty/dracut.git/blame - dracut.spec
version 0.8
[thirdparty/dracut.git] / dracut.spec
CommitLineData
0aaa523c
HH
1%if 0%{?fedora} < 12
2%define with_switch_root 1
3%else
b61ca282 4%define with_switch_root 0
0aaa523c
HH
5%endif
6
710322ec 7%if %{defined gittag}
0aaa523c 8%define rdist 1.git%{gittag}%{?dist}
710322ec
HH
9%define dashgittag -%{gittag}
10%else
0aaa523c 11%define rdist %{?dist}
710322ec 12%endif
0aaa523c 13
0aaa523c 14Name: dracut
1def132d 15Version: 0.8
0aaa523c 16Release: 1%{?rdist}
38672ee8
JK
17Summary: Initramfs generator using udev
18Group: System Environment/Base
0286b3b4 19License: GPLv2+
c4d25b18 20URL: http://apps.sourceforge.net/trac/dracut/wiki
710322ec 21Source0: dracut-%{version}%{?dashgittag}.tar.bz2
38672ee8
JK
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
23Requires: udev
78cd7629 24Requires: util-linux-ng
c6ca79eb 25Requires: module-init-tools >= 3.7-9
38672ee8 26Requires: cpio
38672ee8
JK
27Requires: coreutils
28Requires: findutils
f601799e 29Requires: binutils
38672ee8 30Requires: grep
b61ca282 31Requires: which
80aa303c 32Requires: mktemp >= 1.5-5
38672ee8 33Requires: mount
38672ee8 34Requires: bash
0286b3b4 35Requires: /bin/sh
80aa303c 36Requires: fileutils, gzip, tar
0286b3b4
HH
37Requires: lvm2 >= 2.02.33-9, dhclient
38Requires: filesystem >= 2.1.0, cpio, device-mapper, initscripts >= 8.63-1
39Requires: e2fsprogs >= 1.38-12, libselinux, libsepol, coreutils
40Requires: mdadm, elfutils-libelf, plymouth >= 0.7.0
41Requires: cryptsetup-luks
21007cb6 42Requires: bridge-utils
0c39f9f6 43Requires: file
69288348 44Requires: bzip2
0286b3b4
HH
45%ifnarch s390 s390x
46Requires: dmraid
47Requires: kbd
48%endif
78cd7629 49
686aeaa2 50%if ! 0%{?with_switch_root}
5b6e76c0 51Requires: /sbin/switch_root
686aeaa2
HH
52BuildArch: noarch
53%endif
38672ee8
JK
54
55%description
c4d25b18 56dracut is a new, event-driven initramfs infrastructure based around udev.
38672ee8 57
78cd7629 58%package generic
21007cb6 59Summary: Metapackage to build a generic initramfs with dracut
78cd7629 60Requires: %{name} = %{version}-%{release}
78cd7629 61Requires: rpcbind nfs-utils
78cd7629
HH
62Requires: iscsi-initiator-utils
63Requires: nbd
78cd7629 64Requires: net-tools iproute
33ee031c
HH
65Requires: plymouth-system-theme plymouth-theme-charge plymouth-theme-solar
66
67%description generic
68This package requires everything which is needed to build a generic
21007cb6 69all purpose initramfs with dracut.
33ee031c
HH
70
71%package kernel
21007cb6 72Summary: Metapackage to build generic initramfs with dracut with only kernel modules
33ee031c 73Requires: %{name} = %{version}-%{release}
3b51f4f3
HH
74Requires: ql2100-firmware
75Requires: ql2200-firmware
76Requires: ql23xx-firmware
77Requires: ql2400-firmware
78Requires: ql2500-firmware
78cd7629 79
33ee031c
HH
80%description kernel
81This package requires everything which is needed to build a initramfs with all
82kernel modules and firmware files needed by dracut modules.
78cd7629 83
21007cb6
HH
84%package tools
85Summary: dracut tools to build the local initramfs
e3052553
HH
86Requires: coreutils cryptsetup-luks device-mapper
87Requires: diffutils dmraid findutils gawk grep lvm2
88Requires: module-init-tools sed
89Requires: cpio gzip
21007cb6
HH
90
91%description tools
92This package contains tools to assemble the local initrd and host configuration.
93
38672ee8 94%prep
710322ec 95%setup -q -n %{name}-%{version}%{?dashgittag}
38672ee8
JK
96
97%build
98make
99
100
101%install
102rm -rf $RPM_BUILD_ROOT
00f0a6e7 103make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin sysconfdir=/etc mandir=%{_mandir}
38672ee8 104
686aeaa2
HH
105%if ! 0%{?with_switch_root}
106rm -f $RPM_BUILD_ROOT/sbin/switch_root
107%endif
108
21007cb6
HH
109mkdir -p $RPM_BUILD_ROOT/boot/dracut
110mkdir -p $RPM_BUILD_ROOT/var/lib/dracut/overlay
111
38672ee8
JK
112%clean
113rm -rf $RPM_BUILD_ROOT
114
38672ee8 115%files
78cd7629 116%defattr(-,root,root,0755)
9794cf83 117%doc README HACKING TODO COPYING AUTHORS
38672ee8 118/sbin/dracut
686aeaa2 119%if 0%{?with_switch_root}
68ea18cf 120/sbin/switch_root
686aeaa2 121%endif
78cd7629
HH
122%dir %{_datadir}/dracut
123%{_datadir}/dracut/dracut-functions
124%{_datadir}/dracut/modules.d
4579f5a8 125%config(noreplace) /etc/dracut.conf
00f0a6e7 126%{_mandir}/man8/dracut.8*
38672ee8 127
78cd7629
HH
128%files generic
129%defattr(-,root,root,0755)
130%doc README.generic
131
33ee031c
HH
132%files kernel
133%defattr(-,root,root,0755)
134%doc README.kernel
135
21007cb6
HH
136%files tools
137%defattr(-,root,root,0755)
138%doc COPYING
139/sbin/dracut-gencmdline
140/sbin/dracut-catimages
141%dir /boot/dracut
142%dir /var/lib/dracut
143%dir /var/lib/dracut/overlay
144
38672ee8 145%changelog
1def132d
HH
146* Thu Aug 06 2009 Harald Hoyer <harald@redhat.com> 0.8-1
147- version 0.8
148- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut;a=blob_plain;f=NEWS
149
21007cb6
HH
150* Fri Jul 24 2009 Harald Hoyer <harald@redhat.com> 0.7-1
151- version 0.7
1def132d 152- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut;a=blob_plain;f=NEWS
21007cb6
HH
153
154* Wed Jul 22 2009 Harald Hoyer <harald@redhat.com> 0.6-1
a8b15b36 155- version 0.6
1def132d 156- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut;a=blob_plain;f=NEWS
a8b15b36 157
acff0cc1
HH
158* Fri Jul 17 2009 Harald Hoyer <harald@redhat.com> 0.5-1
159- version 0.5
1def132d 160- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut;a=blob_plain;f=NEWS
acff0cc1 161
616f1557
HH
162* Sat Jul 04 2009 Harald Hoyer <harald@redhat.com> 0.4-1
163- version 0.4
1def132d 164- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut;a=blob_plain;f=NEWS
616f1557 165
df328b6c
HH
166* Thu Jul 02 2009 Harald Hoyer <harald@redhat.com> 0.3-1
167- version 0.3
1def132d 168- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut;a=blob_plain;f=NEWS
df328b6c 169
22a27a50
HH
170* Wed Jul 01 2009 Harald Hoyer <harald@redhat.com> 0.2-1
171- version 0.2
172
78cd7629
HH
173* Fri Jun 19 2009 Harald Hoyer <harald@redhat.com> 0.1-1
174- first release
175
176* Thu Dec 18 2008 Jeremy Katz <katzj@redhat.com> - 0.0-1
38672ee8
JK
177- Initial build
178