]> git.ipfire.org Git - thirdparty/dracut.git/blame - dracut.spec
dracut.spec: install fedora.conf.example
[thirdparty/dracut.git] / dracut.spec
CommitLineData
dc5bb506 1# Variables must be defined
3592d868
HH
2%define with_switch_root 1
3%define with_nbd 1
641eae0f 4
dc5bb506
WT
5# switchroot provided by util-linux-ng in F-12+
6%if 0%{?fedora} > 11 || 0%{?rhel} >= 6
641eae0f
HH
7%define with_switch_root 0
8%endif
dc5bb506
WT
9# nbd in Fedora only
10%if 0%{?rhel} >= 6
11%define with_nbd 0
0aaa523c
HH
12%endif
13
710322ec 14%if %{defined gittag}
c10d53bf 15%define rdist .git%{gittag}%{?dist}
710322ec
HH
16%define dashgittag -%{gittag}
17%else
0aaa523c 18%define rdist %{?dist}
710322ec 19%endif
0aaa523c 20
0aaa523c 21Name: dracut
dd2c34a8
HH
22Version: 007
23Release: 0.1%{?rdist}
38672ee8 24Summary: Initramfs generator using udev
3592d868
HH
25Group: System Environment/Base
26License: GPLv2+
c4d25b18 27URL: http://apps.sourceforge.net/trac/dracut/wiki
f4f45af7
HH
28# Source can be generated by
29# http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=snapshot;h=%{?dashgittag};sf=tgz
710322ec 30Source0: dracut-%{version}%{?dashgittag}.tar.bz2
38672ee8 31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
5c554bd2 32
1b3bdcc1 33%if 0%{?fedora} > 12 || 0%{?rhel} >= 6
0bc4ef1c
HH
34# no "provides", because dracut does not offer
35# all functionality of the obsoleted packages
5c554bd2
HH
36Obsoletes: mkinitrd <= 6.0.93
37Obsoletes: mkinitrd-devel <= 6.0.93
38Obsoletes: nash <= 6.0.93
0bc4ef1c 39Obsoletes: libbdevid-python <= 6.0.93
1b3bdcc1 40%endif
8ef5ade7
HH
41Obsoletes: dracut-kernel < 005
42Provides: dracut-kernel = %{version}-%{release}
5c554bd2 43
7e33fa5b
HH
44Requires: bash
45Requires: bzip2
38672ee8 46Requires: coreutils
7e33fa5b
HH
47Requires: cpio
48Requires: dash
49Requires: filesystem >= 2.1.0
38672ee8
JK
50Requires: findutils
51Requires: grep
7e33fa5b
HH
52Requires: gzip
53Requires: initscripts >= 8.63-1
7d86d90d 54Requires: kbd
80aa303c 55Requires: mktemp >= 1.5-5
7e33fa5b 56Requires: module-init-tools >= 3.7-9
38672ee8 57Requires: mount
7d86d90d 58Requires: plymouth >= 0.8.0-0.2009.29.09.19.1
7e33fa5b
HH
59Requires: sed
60Requires: tar
61Requires: udev
62Requires: util-linux-ng >= 2.16
63Requires: which
78cd7629 64
686aeaa2
HH
65%if ! 0%{?with_switch_root}
66BuildArch: noarch
67%endif
38672ee8
JK
68
69%description
c55b2080
HH
70Dracut contains tools to create a bootable initramfs for 2.6 Linux kernels.
71Unlike existing implementations, dracut does hard-code as little as possible
72into the initramfs. Dracut contains various modules which are driven by the
73event-based udev. Having root on MD, DM, LVM2, LUKS is supported as well as
74NFS, iSCSI, NBD, FCoE with the dracut-network package.
38672ee8 75
ec74fa87 76%package network
8ec6bfcb 77Summary: Dracut modules to build a dracut initramfs with network support
78cd7629 78Requires: %{name} = %{version}-%{release}
78cd7629 79Requires: rpcbind nfs-utils
78cd7629 80Requires: iscsi-initiator-utils
7e33fa5b 81Requires: dhclient
dc5bb506 82%if %{with_nbd}
78cd7629 83Requires: nbd
dc5bb506 84%endif
78cd7629 85Requires: net-tools iproute
ec74fa87 86Requires: bridge-utils
78cd3b98 87Requires: vconfig
ec74fa87
HH
88
89%description network
90This package requires everything which is needed to build a generic
91all purpose initramfs with network support with dracut.
92
4d1661d3 93%package fips
c55b2080 94Summary: Dracut modules to build a dracut initramfs with an integrity check
4d1661d3
HH
95Requires: %{name} = %{version}-%{release}
96Requires: hmaccalc
97%if 0%{?rhel} > 5
98# For Alpha 3, we want nss instead of nss-softokn
99Requires: nss
100%else
101Requires: nss-softokn
102%endif
103Requires: nss-softokn-freebl
104
105%description fips
106This package requires everything which is needed to build an
107all purpose initramfs with dracut, which does an integrity check.
108
ec74fa87
HH
109%package generic
110Summary: Metapackage to build a generic initramfs with dracut
111Requires: %{name} = %{version}-%{release}
112Requires: %{name}-network = %{version}-%{release}
33ee031c
HH
113
114%description generic
115This package requires everything which is needed to build a generic
21007cb6 116all purpose initramfs with dracut.
33ee031c 117
21007cb6 118%package tools
8ec6bfcb 119Summary: Dracut tools to build the local initramfs
e3052553 120Requires: coreutils cryptsetup-luks device-mapper
7e33fa5b 121Requires: diffutils dmraid findutils grep lvm2 gawk
e3052553
HH
122Requires: module-init-tools sed
123Requires: cpio gzip
a0af4fa5 124Requires: %{name} = %{version}-%{release}
21007cb6
HH
125
126%description tools
127This package contains tools to assemble the local initrd and host configuration.
128
38672ee8 129%prep
710322ec 130%setup -q -n %{name}-%{version}%{?dashgittag}
38672ee8
JK
131
132%build
4d1661d3 133make WITH_SWITCH_ROOT=0%{?with_switch_root}
38672ee8 134
38672ee8
JK
135%install
136rm -rf $RPM_BUILD_ROOT
ec74fa87 137make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin \
4d1661d3 138 sysconfdir=/etc mandir=%{_mandir} WITH_SWITCH_ROOT=0%{?with_switch_root}
38672ee8 139
95cf0a88 140echo %{name}-%{version}-%{release} > $RPM_BUILD_ROOT/%{_datadir}/dracut/modules.d/10rpmversion/dracut-version
8e939709 141rm $RPM_BUILD_ROOT/%{_datadir}/dracut/modules.d/01fips/check
95cf0a88 142
21007cb6
HH
143mkdir -p $RPM_BUILD_ROOT/boot/dracut
144mkdir -p $RPM_BUILD_ROOT/var/lib/dracut/overlay
837a5a60
HH
145mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log
146touch $RPM_BUILD_ROOT%{_localstatedir}/log/dracut.log
41bad60c 147install -m 0644 dracut.conf.d/fedora.conf.example $RPM_BUILD_ROOT/etc/dracut.conf.d/fedora.conf
21007cb6 148
1b3bdcc1
HH
149%if 0%{?fedora} <= 12 && 0%{?rhel} < 6
150rm $RPM_BUILD_ROOT/sbin/mkinitrd
151rm $RPM_BUILD_ROOT/sbin/lsinitrd
152%endif
153
38672ee8
JK
154%clean
155rm -rf $RPM_BUILD_ROOT
156
38672ee8 157%files
78cd7629 158%defattr(-,root,root,0755)
ded38dbf 159%doc README HACKING TODO COPYING AUTHORS NEWS
38672ee8 160/sbin/dracut
686aeaa2 161%if 0%{?with_switch_root}
68ea18cf 162/sbin/switch_root
686aeaa2 163%endif
1b3bdcc1 164%if 0%{?fedora} > 12 || 0%{?rhel} >= 6
63d8d27b
HH
165/sbin/mkinitrd
166/sbin/lsinitrd
1b3bdcc1 167%endif
78cd7629
HH
168%dir %{_datadir}/dracut
169%{_datadir}/dracut/dracut-functions
4579f5a8 170%config(noreplace) /etc/dracut.conf
ddd109bd 171%config(noreplace) /etc/dracut.conf.d/fedora.conf
2c2c4580 172%dir /etc/dracut.conf.d
00f0a6e7 173%{_mandir}/man8/dracut.8*
6cc96b35 174%{_mandir}/man5/dracut.conf.5*
d2a53585 175%{_datadir}/dracut/modules.d/00bootchartd
ec74fa87 176%{_datadir}/dracut/modules.d/00dash
1246703b 177%{_datadir}/dracut/modules.d/10i18n
ec74fa87
HH
178%{_datadir}/dracut/modules.d/10rpmversion
179%{_datadir}/dracut/modules.d/50plymouth
9799e0ad 180%{_datadir}/dracut/modules.d/60xen
fede5bbc 181%{_datadir}/dracut/modules.d/90btrfs
ec74fa87 182%{_datadir}/dracut/modules.d/90crypt
07db0def 183%{_datadir}/dracut/modules.d/90dm
ec74fa87
HH
184%{_datadir}/dracut/modules.d/90dmraid
185%{_datadir}/dracut/modules.d/90dmsquash-live
186%{_datadir}/dracut/modules.d/90kernel-modules
187%{_datadir}/dracut/modules.d/90lvm
188%{_datadir}/dracut/modules.d/90mdraid
8ec6bfcb 189%{_datadir}/dracut/modules.d/90multipath
ec74fa87
HH
190%{_datadir}/dracut/modules.d/95debug
191%{_datadir}/dracut/modules.d/95resume
192%{_datadir}/dracut/modules.d/95rootfs-block
837a5a60 193%{_datadir}/dracut/modules.d/95dasd
5bde13f9 194%{_datadir}/dracut/modules.d/95dasd_mod
07db0def 195%{_datadir}/dracut/modules.d/95zfcp
ec74fa87
HH
196%{_datadir}/dracut/modules.d/95terminfo
197%{_datadir}/dracut/modules.d/95udev-rules
5c7821b6 198%{_datadir}/dracut/modules.d/95uswsusp
7d86d90d 199%{_datadir}/dracut/modules.d/98selinux
ec74fa87
HH
200%{_datadir}/dracut/modules.d/98syslog
201%{_datadir}/dracut/modules.d/99base
3592d868
HH
202# logfile needs no logrotate, because it gets overwritten
203# for every dracut run
837a5a60 204%attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/log/dracut.log
ec74fa87
HH
205
206%files network
78cd7629 207%defattr(-,root,root,0755)
ec74fa87
HH
208%{_datadir}/dracut/modules.d/40network
209%{_datadir}/dracut/modules.d/95fcoe
210%{_datadir}/dracut/modules.d/95iscsi
211%{_datadir}/dracut/modules.d/95nbd
212%{_datadir}/dracut/modules.d/95nfs
837a5a60 213%{_datadir}/dracut/modules.d/45ifcfg
532b8c7a 214%{_datadir}/dracut/modules.d/95znet
78cd7629 215
4d1661d3
HH
216%files fips
217%defattr(-,root,root,0755)
4d1661d3
HH
218%{_datadir}/dracut/modules.d/01fips
219
ec74fa87
HH
220%files generic
221%defattr(-,root,root,0755)
222%doc README.generic
223
21007cb6
HH
224%files tools
225%defattr(-,root,root,0755)
66e45737
HH
226%{_mandir}/man8/dracut-gencmdline.8*
227%{_mandir}/man8/dracut-catimages.8*
21007cb6
HH
228/sbin/dracut-gencmdline
229/sbin/dracut-catimages
230%dir /boot/dracut
231%dir /var/lib/dracut
232%dir /var/lib/dracut/overlay
233
38672ee8 234%changelog
7d86d90d
HH
235* Thu Jun 17 2010 Harald Hoyer <harald@redhat.com> 006-1
236- version 006
237
238* Fri Jun 11 2010 Harald Hoyer <harald@redhat.com>
239- Remove requirements, which are not really needed
240Resolves: rhbz#598509
241- fixed copy of network config to /dev/.initramfs/ (patch 146)
242Resolves: rhbz#594649
243- more password beauty (patch 142)
244Resolves: rhbz#561092
245- support multiple iSCSI disks (patch 143)
246Resolves: rbhz#580190
247- fixed selinux=0 (patch 130)
248Resolves: rhbz#593080
249- add support for booting LVM snapshot root volume (patch 145)
250Resolves: rbhz#602723
251- remove hardware field from BOOTIF= (patch 148)
252Resolves: rhbz#599593
253- add aes kernel modules and fix crypt handling (patch 137, patch 140 and patch 147)
254Resolves: rhbz#600170
255
256* Thu May 27 2010 Harald Hoyer <harald@redhat.com>
257- fixed Requirements
258- fixed autoip6
259Resolves: rhbz#538388
260- fixed multipath
261Resolves: rhbz#595719
262
263* Thu May 06 2010 Harald Hoyer <harald@redhat.com>
264- only display short password messages
265Resolves: rhbz#561092
266
267* Thu May 06 2010 Harald Hoyer <harald@redhat.com>
268- fixed dracut manpages
269Resolves: rhbz#589109
270- use ccw-init and ccw rules from s390utils
271Resolves: rhbz#533494
272- fixed fcoe
273Resolves: rhbz#486244
274- various other bugfixes seen in Fedora
275
276* Tue Apr 20 2010 Harald Hoyer <harald@redhat.com>
277- fixed network with multiple nics
278- fixed nfsidmap paths
279- do not run blkid on non active container raids
280- fixed cdrom polling mechanism
281- update to latest git
282
283* Thu Apr 15 2010 Harald Hoyer <harald@redhat.com>
284- fixed dracut manpages
285- dmraid parse different error messages
286- add cdrom polling mechanism for slow cdroms
287- add module btrfs
288- teach dmsquash live-root to use rootflags
289- trigger udev with action=add
290- fixed add_drivers handling
291- add sr_mod
292- use pigz instead of gzip, if available
293
294* Thu Mar 25 2010 Harald Hoyer <harald@redhat.com>
295- removed firmware requirements (rhbz#572634)
296- add /etc/dracut.conf.d
297- Resolves: rhbz#572634
298
299* Fri Mar 19 2010 Harald Hoyer <harald@redhat.com>
300- version 005
301
302* Fri Mar 19 2010 Harald Hoyer <harald@redhat.com>
303- fixed rpmlint errors (rhbz#570547)
304- removed firmware package from dracut-kernel (rhbz#572634)
305- add dcb support to dracut's FCoE support (rhbz#563794)
306- force install some modules in hostonly mode (rhbz#573094)
307- various other bugfixes
308- Resolves: rhbz#570547, rhbz#572634, rhbz#563794, rhbz#573094
309
310* Thu Feb 18 2010 Harald Hoyer <harald@redhat.com> 004-15
311- fixed "selinux=0" booting (rhbz#566376)
312- fixed internal IFS handling
313- Resolves: rhbz#566376
314
315* Fri Jan 29 2010 Harald Hoyer <harald@redhat.com> 004-5
316- fixed firmware.sh bug (#559975 #559597)
317
318* Tue Jan 26 2010 Harald Hoyer <harald@redhat.com> 004-4
319- add multipath check
320
321* Tue Jan 26 2010 Harald Hoyer <harald@redhat.com> 004-3
322- fix selinux handling if .autorelabel is present
323- Resolves: rhbz#557744
324
325* Wed Jan 20 2010 Harald Hoyer <harald@redhat.com> 004-2
326- fix emergency_shell argument parsing
327- Related: rhbz#543948
328
3ee26913
HH
329* Fri Jan 15 2010 Harald Hoyer <harald@redhat.com> 004-1
330- version 004
331- Resolves: rhbz#529339 rhbz#533494 rhbz#548550
332- Resolves: rhbz#548555 rhbz#553195
333
dc5bb506 334* Wed Jan 13 2010 Harald Hoyer <harald@redhat.com> 003-3
5c554bd2
HH
335- add Obsoletes of mkinitrd/nash/libbdevid-python
336- Related: rhbz#543948
337
dc5bb506
WT
338* Wed Jan 13 2010 Warren Togami <wtogami@redhat.com> 003-2
339- nbd is Fedora only
340
5c554bd2
HH
341* Fri Nov 27 2009 Harald Hoyer <harald@redhat.com> 003-1
342- version 003
343
4d1661d3
HH
344* Mon Nov 23 2009 Harald Hoyer <harald@redhat.com> 002-26
345- add WITH_SWITCH_ROOT make flag
346- add fips requirement conditional
347- add more device mapper modules (bug #539656)
348
349* Fri Nov 20 2009 Dennis Gregorovic <dgregor@redhat.com> - 002-25.1
350- nss changes for Alpha 3
351
352* Thu Nov 19 2009 Harald Hoyer <harald@redhat.com> 002-25
353- add more requirements for dracut-fips (bug #539257)
354
355* Tue Nov 17 2009 Harald Hoyer <harald@redhat.com> 002-24
356- put fips module in a subpackage (bug #537619)
357
44a6a0d9
HH
358* Tue Nov 17 2009 Harald Hoyer <harald@redhat.com> 002-23
359- install xdr utils for multipath (bug #463458)
360
8ec6bfcb
HH
361* Thu Nov 12 2009 Harald Hoyer <harald@redhat.com> 002-22
362- add module 90multipath
363- add module 01fips
364- renamed module 95ccw to 95znet (bug #533833)
365- crypt: ignore devices in /etc/crypttab (root is not in there)
366- dasd: only install /etc/dasd.conf in hostonly mode (bug #533833)
367- zfcp: only install /etc/zfcp.conf in hostonly mode (bug #533833)
368- kernel-modules: add scsi_dh scsi_dh_rdac scsi_dh_emc (bug #527750)
369- dasd: use dasdconf.sh from s390utils (bug #533833)
370
3b6c1c66
HH
371* Fri Nov 06 2009 Harald Hoyer <harald@redhat.com> 002-21
372- fix rd_DASD argument handling (bug #531720)
373- Resolves: rhbz#531720
374
8686bd55
HH
375* Wed Nov 04 2009 Harald Hoyer <harald@redhat.com> 002-20
376- fix rd_DASD argument handling (bug #531720)
377- Resolves: rhbz#531720
378
5bde13f9
HH
379* Tue Nov 03 2009 Harald Hoyer <harald@redhat.com> 002-19
380- changed rd_DASD to rd_DASD_MOD (bug #531720)
381- Resolves: rhbz#531720
382
dd854ea9
HH
383* Tue Oct 27 2009 Harald Hoyer <harald@redhat.com> 002-18
384- renamed lvm/device-mapper udev rules according to upstream changes
385- fixed dracut search path issue
386
07db0def
HH
387* Mon Oct 26 2009 Harald Hoyer <harald@redhat.com> 002-17
388- load dm_mod module (bug #530540)
389
390* Fri Oct 09 2009 Jesse Keating <jkeating@redhat.com> - 002-16
391- Upgrade plymouth to Requires(pre) to make it show up before kernel
392
393* Thu Oct 08 2009 Harald Hoyer <harald@redhat.com> 002-15
394- s390 ccw: s/layer1/layer2/g
395
396* Thu Oct 08 2009 Harald Hoyer <harald@redhat.com> 002-14
397- add multinic support
398- add s390 zfcp support
399- add s390 network support
400
401* Wed Oct 07 2009 Harald Hoyer <harald@redhat.com> 002-13
402- fixed init=<command> handling
403- kill loginit if "rdinitdebug" specified
404- run dmsquash-live-root after udev has settled (bug #527514)
405
837a5a60
HH
406* Tue Oct 06 2009 Harald Hoyer <harald@redhat.com> 002-12
407- add missing loginit helper
408- corrected dracut manpage
409
410* Thu Oct 01 2009 Harald Hoyer <harald@redhat.com> 002-11
411- fixed dracut-gencmdline for root=UUID or LABEL
412
413* Thu Oct 01 2009 Harald Hoyer <harald@redhat.com> 002-10
414- do not destroy assembled raid arrays if mdadm.conf present
415- mount /dev/shm
416- let udevd not resolve group and user names
417- preserve timestamps of tools on initramfs generation
418- generate symlinks for binaries correctly
419- moved network from udev to initqueue
420- mount nfs3 with nfsvers=3 option and retry with nfsvers=2
421- fixed nbd initqueue-finished
422- improved debug output: specifying "rdinitdebug" now logs
423 to dmesg, console and /init.log
424- stop udev before killing it
425- add ghost /var/log/dracut.log
426- dmsquash: use info() and die() rather than echo
427- strip kernel modules which have no x bit set
428- redirect stdin, stdout, stderr all RW to /dev/console
429 so the user can use "less" to view /init.log and dmesg
430
431* Tue Sep 29 2009 Harald Hoyer <harald@redhat.com> 002-9
432- make install of new dm/lvm udev rules optionally
433- correct dasd module typo
434
435* Fri Sep 25 2009 Warren Togami <wtogami@redhat.com> 002-8
436- revert back to dracut-002-5 tarball 845dd502
437 lvm2 was reverted to pre-udev
438
439* Wed Sep 23 2009 Harald Hoyer <harald@redhat.com> 002-7
440- build with the correct tarball
441
442* Wed Sep 23 2009 Harald Hoyer <harald@redhat.com> 002-6
678b3605
HH
443- add new device mapper udev rules and dmeventd
444 bug 525319, 525015
445
446* Wed Sep 23 2009 Warren Togami <wtogami@redaht.com> 002-5
447- Revert back to -3, Add umount back to initrd
448 This makes no functional difference to LiveCD. See Bug #525319
449
450* Mon Sep 21 2009 Warren Togami <wtogami@redhat.com> 002-4
451- Fix LiveCD boot regression
452
453* Mon Sep 21 2009 Harald Hoyer <harald@redhat.com> 002-3
454- bail out if selinux policy could not be loaded and
455 selinux=0 not specified on kernel command line
456 (bug #524113)
457- set finished criteria for dmsquash live images
458
7a34efa5
HH
459* Fri Sep 18 2009 Harald Hoyer <harald@redhat.com> 002-2
460- do not cleanup dmraids
461- copy over lvm.conf
462
9a99c974
HH
463* Thu Sep 17 2009 Harald Hoyer <harald@redhat.com> 002-1
464- version 002
465- set correct PATH
466- workaround for broken mdmon implementation
467
041b0d76
HH
468* Wed Sep 16 2009 Harald Hoyer <harald@redhat.com> 001-12
469- removed lvm/mdraid/dmraid lock files
470- add missing ifname= files
471
472* Wed Sep 16 2009 Harald Hoyer <harald@redhat.com> 001-11
473- generate dracut-version during rpm build time
474
475* Tue Sep 15 2009 Harald Hoyer <harald@redhat.com> 001-10
4d924752
HH
476- add ifname= argument for persistent netdev names
477- new /initqueue-finished to check if the main loop can be left
478- copy mdadm.conf if --mdadmconf set or mdadmconf in dracut.conf
479
041b0d76
HH
480* Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-9
481- added Requires: plymouth-scripts
482
4d924752
HH
483* Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-8
484- plymouth: use plymouth-populate-initrd
485- add add_drivers for dracut and dracut.conf
486- do not mount /proc and /selinux manually in selinux-load-policy
487
488* Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-7
489- add scsi_wait_scan to be sure everything was scanned
490
491* Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-6
492- fixed several problems with md raid containers
493- fixed selinux policy loading
494
495* Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-5
496- patch does not honor file modes, fixed them manually
497
498* Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-4
499- fixed mdraid for IMSM
500
501* Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-3
502- fixed bug, which prevents installing 61-persistent-storage.rules (bug #520109)
503
504* Thu Sep 03 2009 Harald Hoyer <harald@redhat.com> 001-2
505- fixed missing grep for md
506- reorder cleanup
507
d889c019
HH
508* Wed Sep 02 2009 Harald Hoyer <harald@redhat.com> 001-1
509- version 001
510- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
511
5d12f1a4
HH
512* Fri Aug 14 2009 Harald Hoyer <harald@redhat.com> 0.9-1
513- version 0.9
5d12f1a4 514
1def132d
HH
515* Thu Aug 06 2009 Harald Hoyer <harald@redhat.com> 0.8-1
516- version 0.8
d889c019 517- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
1def132d 518
21007cb6
HH
519* Fri Jul 24 2009 Harald Hoyer <harald@redhat.com> 0.7-1
520- version 0.7
d889c019 521- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
21007cb6
HH
522
523* Wed Jul 22 2009 Harald Hoyer <harald@redhat.com> 0.6-1
a8b15b36 524- version 0.6
d889c019 525- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
a8b15b36 526
acff0cc1
HH
527* Fri Jul 17 2009 Harald Hoyer <harald@redhat.com> 0.5-1
528- version 0.5
d889c019 529- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
acff0cc1 530
616f1557
HH
531* Sat Jul 04 2009 Harald Hoyer <harald@redhat.com> 0.4-1
532- version 0.4
d889c019 533- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
616f1557 534
df328b6c
HH
535* Thu Jul 02 2009 Harald Hoyer <harald@redhat.com> 0.3-1
536- version 0.3
d889c019 537- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
df328b6c 538
22a27a50
HH
539* Wed Jul 01 2009 Harald Hoyer <harald@redhat.com> 0.2-1
540- version 0.2
541
78cd7629
HH
542* Fri Jun 19 2009 Harald Hoyer <harald@redhat.com> 0.1-1
543- first release
544
545* Thu Dec 18 2008 Jeremy Katz <katzj@redhat.com> - 0.0-1
38672ee8
JK
546- Initial build
547