]> git.ipfire.org Git - thirdparty/dracut.git/blame - dracut.spec
90dm: install more device mapper kernel modules
[thirdparty/dracut.git] / dracut.spec
CommitLineData
0aaa523c 1%define with_switch_root 1
641eae0f
HH
2
3%if 0%{?fedora} > 11
4%define with_switch_root 0
5%endif
6
7%if 0%{?rhel} > 5
b61ca282 8%define with_switch_root 0
0aaa523c
HH
9%endif
10
710322ec 11%if %{defined gittag}
c10d53bf 12%define rdist .git%{gittag}%{?dist}
710322ec
HH
13%define dashgittag -%{gittag}
14%else
0aaa523c 15%define rdist %{?dist}
710322ec 16%endif
0aaa523c 17
0aaa523c 18Name: dracut
9a99c974 19Version: 002
44a6a0d9 20Release: 23%{?rdist}
38672ee8
JK
21Summary: Initramfs generator using udev
22Group: System Environment/Base
0286b3b4 23License: GPLv2+
c4d25b18 24URL: http://apps.sourceforge.net/trac/dracut/wiki
710322ec 25Source0: dracut-%{version}%{?dashgittag}.tar.bz2
38672ee8
JK
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
27Requires: udev
78cd7629 28Requires: util-linux-ng
c6ca79eb 29Requires: module-init-tools >= 3.7-9
38672ee8 30Requires: cpio
38672ee8
JK
31Requires: coreutils
32Requires: findutils
f601799e 33Requires: binutils
38672ee8 34Requires: grep
b61ca282 35Requires: which
80aa303c 36Requires: mktemp >= 1.5-5
38672ee8 37Requires: mount
38672ee8 38Requires: bash
0ad78ae8 39Requires: dash
0286b3b4 40Requires: /bin/sh
80aa303c 41Requires: fileutils, gzip, tar
0286b3b4
HH
42Requires: lvm2 >= 2.02.33-9, dhclient
43Requires: filesystem >= 2.1.0, cpio, device-mapper, initscripts >= 8.63-1
44Requires: e2fsprogs >= 1.38-12, libselinux, libsepol, coreutils
07db0def
HH
45Requires: mdadm, elfutils-libelf
46Requires(pre): plymouth >= 0.7.0
47Requires: plymouth >= 0.7.0
0286b3b4 48Requires: cryptsetup-luks
0c39f9f6 49Requires: file
69288348 50Requires: bzip2
0286b3b4
HH
51Requires: dmraid
52Requires: kbd
236852c1 53Requires: plymouth-scripts
78cd7629 54
686aeaa2 55%if ! 0%{?with_switch_root}
be9ca6c8 56Requires: util-linux-ng >= 2.16
686aeaa2
HH
57BuildArch: noarch
58%endif
38672ee8
JK
59
60%description
c4d25b18 61dracut is a new, event-driven initramfs infrastructure based around udev.
38672ee8 62
ec74fa87 63%package network
8ec6bfcb 64Summary: Dracut modules to build a dracut initramfs with network support
78cd7629 65Requires: %{name} = %{version}-%{release}
78cd7629 66Requires: rpcbind nfs-utils
78cd7629
HH
67Requires: iscsi-initiator-utils
68Requires: nbd
78cd7629 69Requires: net-tools iproute
ec74fa87
HH
70Requires: bridge-utils
71
72%description network
73This package requires everything which is needed to build a generic
74all purpose initramfs with network support with dracut.
75
76%package generic
77Summary: Metapackage to build a generic initramfs with dracut
78Requires: %{name} = %{version}-%{release}
79Requires: %{name}-network = %{version}-%{release}
33ee031c
HH
80
81%description generic
82This package requires everything which is needed to build a generic
21007cb6 83all purpose initramfs with dracut.
33ee031c 84
ec74fa87 85
33ee031c 86%package kernel
21007cb6 87Summary: Metapackage to build generic initramfs with dracut with only kernel modules
33ee031c 88Requires: %{name} = %{version}-%{release}
3b51f4f3
HH
89Requires: ql2100-firmware
90Requires: ql2200-firmware
91Requires: ql23xx-firmware
92Requires: ql2400-firmware
93Requires: ql2500-firmware
78cd7629 94
33ee031c
HH
95%description kernel
96This package requires everything which is needed to build a initramfs with all
97kernel modules and firmware files needed by dracut modules.
78cd7629 98
21007cb6 99%package tools
8ec6bfcb 100Summary: Dracut tools to build the local initramfs
e3052553
HH
101Requires: coreutils cryptsetup-luks device-mapper
102Requires: diffutils dmraid findutils gawk grep lvm2
103Requires: module-init-tools sed
104Requires: cpio gzip
21007cb6
HH
105
106%description tools
107This package contains tools to assemble the local initrd and host configuration.
108
38672ee8 109%prep
710322ec 110%setup -q -n %{name}-%{version}%{?dashgittag}
38672ee8
JK
111
112%build
113make
114
38672ee8
JK
115%install
116rm -rf $RPM_BUILD_ROOT
ec74fa87
HH
117make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin \
118 sysconfdir=/etc mandir=%{_mandir}
38672ee8 119
95cf0a88
HH
120echo %{name}-%{version}-%{release} > $RPM_BUILD_ROOT/%{_datadir}/dracut/modules.d/10rpmversion/dracut-version
121
686aeaa2
HH
122%if ! 0%{?with_switch_root}
123rm -f $RPM_BUILD_ROOT/sbin/switch_root
124%endif
125
21007cb6
HH
126mkdir -p $RPM_BUILD_ROOT/boot/dracut
127mkdir -p $RPM_BUILD_ROOT/var/lib/dracut/overlay
837a5a60
HH
128mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log
129touch $RPM_BUILD_ROOT%{_localstatedir}/log/dracut.log
21007cb6 130
38672ee8
JK
131%clean
132rm -rf $RPM_BUILD_ROOT
133
38672ee8 134%files
78cd7629 135%defattr(-,root,root,0755)
ded38dbf 136%doc README HACKING TODO COPYING AUTHORS NEWS
38672ee8 137/sbin/dracut
686aeaa2 138%if 0%{?with_switch_root}
68ea18cf 139/sbin/switch_root
686aeaa2 140%endif
78cd7629
HH
141%dir %{_datadir}/dracut
142%{_datadir}/dracut/dracut-functions
4579f5a8 143%config(noreplace) /etc/dracut.conf
00f0a6e7 144%{_mandir}/man8/dracut.8*
ec74fa87 145%{_datadir}/dracut/modules.d/00dash
8ec6bfcb 146%{_datadir}/dracut/modules.d/01fips
ec74fa87
HH
147%{_datadir}/dracut/modules.d/10redhat-i18n
148%{_datadir}/dracut/modules.d/10rpmversion
149%{_datadir}/dracut/modules.d/50plymouth
150%{_datadir}/dracut/modules.d/90crypt
07db0def 151%{_datadir}/dracut/modules.d/90dm
ec74fa87
HH
152%{_datadir}/dracut/modules.d/90dmraid
153%{_datadir}/dracut/modules.d/90dmsquash-live
154%{_datadir}/dracut/modules.d/90kernel-modules
155%{_datadir}/dracut/modules.d/90lvm
156%{_datadir}/dracut/modules.d/90mdraid
8ec6bfcb 157%{_datadir}/dracut/modules.d/90multipath
ec74fa87
HH
158%{_datadir}/dracut/modules.d/95debug
159%{_datadir}/dracut/modules.d/95resume
160%{_datadir}/dracut/modules.d/95rootfs-block
837a5a60 161%{_datadir}/dracut/modules.d/95dasd
5bde13f9 162%{_datadir}/dracut/modules.d/95dasd_mod
07db0def 163%{_datadir}/dracut/modules.d/95zfcp
8ec6bfcb 164%{_datadir}/dracut/modules.d/95znet
ec74fa87
HH
165%{_datadir}/dracut/modules.d/95terminfo
166%{_datadir}/dracut/modules.d/95udev-rules
167%{_datadir}/dracut/modules.d/95udev-rules.ub810
168%{_datadir}/dracut/modules.d/98syslog
169%{_datadir}/dracut/modules.d/99base
837a5a60 170%attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/log/dracut.log
ec74fa87
HH
171
172%files network
8ec6bfcb 173%doc README HACKING TODO COPYING AUTHORS NEWS
78cd7629 174%defattr(-,root,root,0755)
ec74fa87
HH
175%{_datadir}/dracut/modules.d/40network
176%{_datadir}/dracut/modules.d/95fcoe
177%{_datadir}/dracut/modules.d/95iscsi
178%{_datadir}/dracut/modules.d/95nbd
179%{_datadir}/dracut/modules.d/95nfs
837a5a60 180%{_datadir}/dracut/modules.d/45ifcfg
78cd7629 181
33ee031c
HH
182%files kernel
183%defattr(-,root,root,0755)
184%doc README.kernel
185
ec74fa87
HH
186%files generic
187%defattr(-,root,root,0755)
188%doc README.generic
189
21007cb6
HH
190%files tools
191%defattr(-,root,root,0755)
ded38dbf 192%doc COPYING NEWS
21007cb6
HH
193/sbin/dracut-gencmdline
194/sbin/dracut-catimages
195%dir /boot/dracut
196%dir /var/lib/dracut
197%dir /var/lib/dracut/overlay
198
38672ee8 199%changelog
44a6a0d9
HH
200* Tue Nov 17 2009 Harald Hoyer <harald@redhat.com> 002-23
201- install xdr utils for multipath (bug #463458)
202
8ec6bfcb
HH
203* Thu Nov 12 2009 Harald Hoyer <harald@redhat.com> 002-22
204- add module 90multipath
205- add module 01fips
206- renamed module 95ccw to 95znet (bug #533833)
207- crypt: ignore devices in /etc/crypttab (root is not in there)
208- dasd: only install /etc/dasd.conf in hostonly mode (bug #533833)
209- zfcp: only install /etc/zfcp.conf in hostonly mode (bug #533833)
210- kernel-modules: add scsi_dh scsi_dh_rdac scsi_dh_emc (bug #527750)
211- dasd: use dasdconf.sh from s390utils (bug #533833)
212
3b6c1c66
HH
213* Fri Nov 06 2009 Harald Hoyer <harald@redhat.com> 002-21
214- fix rd_DASD argument handling (bug #531720)
215- Resolves: rhbz#531720
216
8686bd55
HH
217* Wed Nov 04 2009 Harald Hoyer <harald@redhat.com> 002-20
218- fix rd_DASD argument handling (bug #531720)
219- Resolves: rhbz#531720
220
5bde13f9
HH
221* Tue Nov 03 2009 Harald Hoyer <harald@redhat.com> 002-19
222- changed rd_DASD to rd_DASD_MOD (bug #531720)
223- Resolves: rhbz#531720
224
dd854ea9
HH
225* Tue Oct 27 2009 Harald Hoyer <harald@redhat.com> 002-18
226- renamed lvm/device-mapper udev rules according to upstream changes
227- fixed dracut search path issue
228
07db0def
HH
229* Mon Oct 26 2009 Harald Hoyer <harald@redhat.com> 002-17
230- load dm_mod module (bug #530540)
231
232* Fri Oct 09 2009 Jesse Keating <jkeating@redhat.com> - 002-16
233- Upgrade plymouth to Requires(pre) to make it show up before kernel
234
235* Thu Oct 08 2009 Harald Hoyer <harald@redhat.com> 002-15
236- s390 ccw: s/layer1/layer2/g
237
238* Thu Oct 08 2009 Harald Hoyer <harald@redhat.com> 002-14
239- add multinic support
240- add s390 zfcp support
241- add s390 network support
242
243* Wed Oct 07 2009 Harald Hoyer <harald@redhat.com> 002-13
244- fixed init=<command> handling
245- kill loginit if "rdinitdebug" specified
246- run dmsquash-live-root after udev has settled (bug #527514)
247
837a5a60
HH
248* Tue Oct 06 2009 Harald Hoyer <harald@redhat.com> 002-12
249- add missing loginit helper
250- corrected dracut manpage
251
252* Thu Oct 01 2009 Harald Hoyer <harald@redhat.com> 002-11
253- fixed dracut-gencmdline for root=UUID or LABEL
254
255* Thu Oct 01 2009 Harald Hoyer <harald@redhat.com> 002-10
256- do not destroy assembled raid arrays if mdadm.conf present
257- mount /dev/shm
258- let udevd not resolve group and user names
259- preserve timestamps of tools on initramfs generation
260- generate symlinks for binaries correctly
261- moved network from udev to initqueue
262- mount nfs3 with nfsvers=3 option and retry with nfsvers=2
263- fixed nbd initqueue-finished
264- improved debug output: specifying "rdinitdebug" now logs
265 to dmesg, console and /init.log
266- stop udev before killing it
267- add ghost /var/log/dracut.log
268- dmsquash: use info() and die() rather than echo
269- strip kernel modules which have no x bit set
270- redirect stdin, stdout, stderr all RW to /dev/console
271 so the user can use "less" to view /init.log and dmesg
272
273* Tue Sep 29 2009 Harald Hoyer <harald@redhat.com> 002-9
274- make install of new dm/lvm udev rules optionally
275- correct dasd module typo
276
277* Fri Sep 25 2009 Warren Togami <wtogami@redhat.com> 002-8
278- revert back to dracut-002-5 tarball 845dd502
279 lvm2 was reverted to pre-udev
280
281* Wed Sep 23 2009 Harald Hoyer <harald@redhat.com> 002-7
282- build with the correct tarball
283
284* Wed Sep 23 2009 Harald Hoyer <harald@redhat.com> 002-6
678b3605
HH
285- add new device mapper udev rules and dmeventd
286 bug 525319, 525015
287
288* Wed Sep 23 2009 Warren Togami <wtogami@redaht.com> 002-5
289- Revert back to -3, Add umount back to initrd
290 This makes no functional difference to LiveCD. See Bug #525319
291
292* Mon Sep 21 2009 Warren Togami <wtogami@redhat.com> 002-4
293- Fix LiveCD boot regression
294
295* Mon Sep 21 2009 Harald Hoyer <harald@redhat.com> 002-3
296- bail out if selinux policy could not be loaded and
297 selinux=0 not specified on kernel command line
298 (bug #524113)
299- set finished criteria for dmsquash live images
300
7a34efa5
HH
301* Fri Sep 18 2009 Harald Hoyer <harald@redhat.com> 002-2
302- do not cleanup dmraids
303- copy over lvm.conf
304
9a99c974
HH
305* Thu Sep 17 2009 Harald Hoyer <harald@redhat.com> 002-1
306- version 002
307- set correct PATH
308- workaround for broken mdmon implementation
309
041b0d76
HH
310* Wed Sep 16 2009 Harald Hoyer <harald@redhat.com> 001-12
311- removed lvm/mdraid/dmraid lock files
312- add missing ifname= files
313
314* Wed Sep 16 2009 Harald Hoyer <harald@redhat.com> 001-11
315- generate dracut-version during rpm build time
316
317* Tue Sep 15 2009 Harald Hoyer <harald@redhat.com> 001-10
4d924752
HH
318- add ifname= argument for persistent netdev names
319- new /initqueue-finished to check if the main loop can be left
320- copy mdadm.conf if --mdadmconf set or mdadmconf in dracut.conf
321
041b0d76
HH
322* Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-9
323- added Requires: plymouth-scripts
324
4d924752
HH
325* Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-8
326- plymouth: use plymouth-populate-initrd
327- add add_drivers for dracut and dracut.conf
328- do not mount /proc and /selinux manually in selinux-load-policy
329
330* Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-7
331- add scsi_wait_scan to be sure everything was scanned
332
333* Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-6
334- fixed several problems with md raid containers
335- fixed selinux policy loading
336
337* Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-5
338- patch does not honor file modes, fixed them manually
339
340* Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-4
341- fixed mdraid for IMSM
342
343* Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-3
344- fixed bug, which prevents installing 61-persistent-storage.rules (bug #520109)
345
346* Thu Sep 03 2009 Harald Hoyer <harald@redhat.com> 001-2
347- fixed missing grep for md
348- reorder cleanup
349
d889c019
HH
350* Wed Sep 02 2009 Harald Hoyer <harald@redhat.com> 001-1
351- version 001
352- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
353
5d12f1a4
HH
354* Fri Aug 14 2009 Harald Hoyer <harald@redhat.com> 0.9-1
355- version 0.9
5d12f1a4 356
1def132d
HH
357* Thu Aug 06 2009 Harald Hoyer <harald@redhat.com> 0.8-1
358- version 0.8
d889c019 359- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
1def132d 360
21007cb6
HH
361* Fri Jul 24 2009 Harald Hoyer <harald@redhat.com> 0.7-1
362- version 0.7
d889c019 363- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
21007cb6
HH
364
365* Wed Jul 22 2009 Harald Hoyer <harald@redhat.com> 0.6-1
a8b15b36 366- version 0.6
d889c019 367- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
a8b15b36 368
acff0cc1
HH
369* Fri Jul 17 2009 Harald Hoyer <harald@redhat.com> 0.5-1
370- version 0.5
d889c019 371- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
acff0cc1 372
616f1557
HH
373* Sat Jul 04 2009 Harald Hoyer <harald@redhat.com> 0.4-1
374- version 0.4
d889c019 375- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
616f1557 376
df328b6c
HH
377* Thu Jul 02 2009 Harald Hoyer <harald@redhat.com> 0.3-1
378- version 0.3
d889c019 379- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
df328b6c 380
22a27a50
HH
381* Wed Jul 01 2009 Harald Hoyer <harald@redhat.com> 0.2-1
382- version 0.2
383
78cd7629
HH
384* Fri Jun 19 2009 Harald Hoyer <harald@redhat.com> 0.1-1
385- first release
386
387* Thu Dec 18 2008 Jeremy Katz <katzj@redhat.com> - 0.0-1
38672ee8
JK
388- Initial build
389