]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] udev - Makefile error
[thirdparty/systemd.git] / udev.spec
CommitLineData
0c675896
GKH
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
8# if we want to build DBUS support in or not.
9# 0 - no DBUS support
10# 1 - DBUS support
11%define dbus 0
12
13# if we want to enable debugging support in udev. If it is enabled, lots of
14# stuff will get sent to the debug syslog.
15# 0 - debugging disabled
16# 1 - debugging enabled
17%define debug 0
18
e64280b8 19# if we want to use the LSB version of the init script or the Redhat one
20# 0 - use Redhat version: etc/init.d/udev
21# 1 - use LSB version: etc/init.d/udev.init.LSB
22%define lsb 0
23
3660f0b8
PM
24Summary: A userspace implementation of devfs
25Name: udev
e9a8c2e4 26Version: 012_bk
3660f0b8
PM
27Release: 1
28License: GPL
29Group: Utilities/System
30Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
31ExclusiveOS: Linux
e0929206 32Vendor: Greg Kroah-Hartman <greg@kroah.com>
4360a56d 33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 34Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
35
36%description
37udev is a implementation of devfs in userspace using sysfs and
22120496 38/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
39
40%prep
bbab56ba 41%setup -q
3660f0b8
PM
42
43%build
0c675896
GKH
44make CC="gcc $RPM_OPT_FLAGS" \
45%if %{klibc}
46 USE_KLIBC=true \
47%endif
48%if %{dbus}
49 USE_DBUS=true \
50%endif
51%if %{debug}
52 DEBUG=true \
53%endif
3660f0b8
PM
54
55%install
5bfabc59 56make DESTDIR=$RPM_BUILD_ROOT install \
57%if %{dbus}
58 USE_DBUS=true
59%endif
e64280b8 60%if %{lsb}
61 USE_LSB=true
62%endif
3660f0b8 63
316c5150 64%post
65/sbin/chkconfig --add udev
66
600ee7f7 67%postun
68if [ $1 = 0 ]; then
69 /sbin/chkconfig --del udev
70fi
71
3660f0b8 72%clean
bbab56ba 73rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
74
75%files
ee156981 76%defattr(-,root,root)
bbab56ba
RL
77%doc COPYING README TODO ChangeLog
78%attr(755,root,root) /sbin/udev
79%attr(755,root,root) /udev/
80%attr(755,root,root) /etc/udev/
1b1dbc47 81%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
82%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
83%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
5bfabc59 84%if %{dbus}
85 %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
86%endif
8634e6d1 87%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 88%attr(755,root,root) /etc/init.d/udev
bbab56ba 89%attr(0644,root,root) %{_mandir}/man8/udev.8*
3660f0b8
PM
90
91%changelog
e64280b8 92* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
93- add defines to choose the init script (Redhat or LSB)
94
316c5150 95* Tue Dec 16 2003 Robert Love <rml@ximian.com>
96- install the initscript and run chkconfig on it
97
e8baccca
GKH
98* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
99- changes due to config file name changes
100
bbab56ba
RL
101* Fri Oct 17 2003 Robert Love <rml@tech9.net>
102- Make work without a build root
103- Correctly install the right files
104- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
105- Put some prereqs in
8634e6d1 106- Install the hotplug symlink to udev
bbab56ba 107
3660f0b8
PM
108* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
109- Initial spec file for udev-0.2.