]> git.ipfire.org Git - thirdparty/lldpd.git/blob - redhat/lldpd.spec
packaging: update to 0.7.6
[thirdparty/lldpd.git] / redhat / lldpd.spec
1 # configure options
2
3 # Define with/without/bcond_without macros (needed for RHEL4)
4 %define with() %{expand:%%{?with_%{1}:1}%%{!?with_%{1}:0}}
5 %define bcond_without() %{expand:%%{!?_without_%{1}:%%global with_%{1} 1}}
6 %define bcond_with() %{expand:%%{?_with_%{1}:%%global with_%{1} 1}}
7
8 # Conditional build options, disable with "--without xxx"
9 %bcond_without xml
10 %bcond_without cdp
11 %bcond_without edp
12 %bcond_without sonmp
13 %bcond_without fdp
14 %bcond_without lldpmed
15 %bcond_without dot1
16 %bcond_without dot3
17
18 # On RHEL < 5, disable SNMP, Net-SNMP installation seems broken. CentOS 5 too.
19 %if 0%{?rhel_version} > 0 && 0%{?rhel_version} < 600 || 0%{?centos_version} > 0 && 0%{?centos_version} < 600
20 %bcond_with snmp
21 %else
22 %bcond_without snmp
23 %endif
24
25 %define lldpd_user _lldpd
26 %define lldpd_group _lldpd
27 %define lldpd_chroot /var/run/lldpd
28
29 Summary: Implementation of IEEE 802.1ab (LLDP)
30 Name: lldpd
31 Version: 0.7.6
32 Release: 1%{?dist}
33 License: MIT
34 Group: System Environment/Daemons
35 URL: http://vincentbernat.github.com/lldpd/
36 Source0: http://media.luffy.cx/files/lldpd/%{name}-%{version}.tar.gz
37 Source1: lldpd.init%{?suse_version:.suse}
38 Source2: lldpd.sysconfig
39
40 BuildRequires: pkgconfig
41 BuildRequires: readline-devel
42 %if %{with snmp}
43 BuildRequires: net-snmp-devel
44 BuildRequires: openssl-devel
45 %{!?suse_version:BuildRequires: lm_sensors-devel}
46 %endif
47 %if %{with xml}
48 BuildRequires: libxml2-devel
49 %endif
50 %if 0%{?suse_version}
51 PreReq: %fillup_prereq %insserv_prereq pwdutils
52 %else
53 PreReq: /usr/sbin/groupadd /usr/sbin/useradd
54 Requires(post): chkconfig
55 Requires(preun): chkconfig
56 Requires(preun): initscripts
57 Requires(postun): initscripts
58 %endif
59
60 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
61
62 %description
63 This implementation provides LLDP sending and reception, supports VLAN
64 and includes an SNMP subagent that can interface to an SNMP agent
65 through AgentX protocol.
66
67 LLDP is an industry standard protocol designed to supplant proprietary
68 Link-Layer protocols such as Extreme EDP (Extreme Discovery Protocol)
69 and CDP (Cisco Discovery Protocol). The goal of LLDP is to provide an
70 inter-vendor compatible mechanism to deliver Link-Layer notifications
71 to adjacent network devices.
72
73 This daemon is also able to deal with CDP, FDP, SONMP and EDP
74 protocol. It also handles LLDP-MED extension.
75
76 %package devel
77 Summary: Implementation of IEEE 802.1ab - Tools and header files for developers
78 Group: Development/Libraries
79 Requires: lldpd = %{version}-%{release}
80
81 %description devel
82 This package is required to develop alternate clients for lldpd.
83
84 %prep
85 %setup -q
86 %build
87 %configure \
88 %if %{with snmp}
89 --with-snmp \
90 %endif
91 %if %{with xml}
92 --with-xml \
93 %endif
94 %if %{with cdp}
95 --enable-cdp \
96 %else
97 --disable-cdp \
98 %endif
99 %if %{with edp}
100 --enable-edp \
101 %else
102 --disable-edp \
103 %endif
104 %if %{with sonmp}
105 --enable-sonmp \
106 %else
107 --disable-sonmp \
108 %endif
109 %if %{with fdp}
110 --enable-fdp \
111 %else
112 --disable-fdp \
113 %endif
114 %if %{with lldpmed}
115 --enable-lldpmed \
116 %else
117 --disable-lldpmed \
118 %endif
119 %if %{with dot1}
120 --enable-dot1 \
121 %else
122 --disable-dot1 \
123 %endif
124 %if %{with dot3}
125 --enable-dot3 \
126 %else
127 --disable-dot3 \
128 %endif
129 --with-privsep-user=%lldpd_user \
130 --with-privsep-group=%lldpd_group \
131 --with-privsep-chroot=%lldpd_chroot \
132 --prefix=/usr --localstatedir=%lldpd_chroot --sysconfdir=/etc --libdir=%{_libdir} \
133 --docdir=%{_docdir}/lldpd
134
135 [ -f /usr/include/net-snmp/agent/struct.h ] || touch src/struct.h
136 make %{?_smp_mflags}
137
138 %install
139 make install DESTDIR=$RPM_BUILD_ROOT
140 install -d -m770 $RPM_BUILD_ROOT/%lldpd_chroot
141 install -d $RPM_BUILD_ROOT/%{_initrddir}
142 install -m755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/lldpd
143 %if 0%{?suse_version}
144 mkdir -p ${RPM_BUILD_ROOT}/var/adm/fillup-templates
145 install -m700 %{SOURCE2} ${RPM_BUILD_ROOT}/var/adm/fillup-templates/sysconfig.lldpd
146 %else
147 install -d $RPM_BUILD_ROOT/etc/sysconfig
148 install -m644 %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lldpd
149 %endif
150
151 %pre
152 # Create lldpd user/group
153 if getent group %lldpd_group >/dev/null 2>&1 ; then : ; else \
154 %{_sbindir}/groupadd -r %lldpd_group > /dev/null 2>&1 || exit 1 ; fi
155 if getent passwd %lldpd_user >/dev/null 2>&1 ; then : ; else \
156 %{_sbindir}/useradd -g %lldpd_group -M -r -s /bin/false \
157 -c "LLDP daemon" -d %lldpd_chroot %lldpd_user 2> /dev/null \
158 || exit 1 ; fi
159
160 %if 0%{?suse_version}
161 # Service management for SuSE
162
163 %post
164 /sbin/ldconfig
165 %{fillup_and_insserv lldpd}
166 %postun
167 /sbin/ldconfig
168 %restart_on_update lldpd
169 %insserv_cleanup
170 %preun
171 %stop_on_removal lldpd
172
173 %else
174 # Service management for Redhat/Centos
175
176 %post
177 /sbin/ldconfig
178 /sbin/chkconfig --add lldpd
179 %postun
180 /sbin/ldconfig
181 if [ "$1" -ge "1" ]; then
182 /sbin/service lldpd condrestart >/dev/null 2>&1 || :
183 fi
184 %preun
185 if [ "$1" = "0" ]; then
186 /sbin/service lldpd stop > /dev/null 2>&1
187 /sbin/chkconfig --del lldpd
188 fi
189
190 %endif
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %files
196 %defattr(-,root,root,-)
197 %dir %{_docdir}/lldpd
198 %doc %{_docdir}/lldpd/NEWS
199 %doc %{_docdir}/lldpd/ChangeLog
200 %doc %{_docdir}/lldpd/README.md
201 %doc %{_docdir}/lldpd/CONTRIBUTE.md
202 %{_sbindir}/lldpd
203 %{_sbindir}/lldpctl
204 %{_sbindir}/lldpcli
205 %{_libdir}/liblldpctl.so.*
206 %doc %{_mandir}/man8/lldp*
207 %dir %attr(750,root,root) %lldpd_chroot
208 %config %attr(755,root,root) %{_initrddir}/lldpd
209 %if 0%{?suse_version}
210 %attr(644,root,root) /var/adm/fillup-templates/sysconfig.lldpd
211 %else
212 %config(noreplace) /etc/sysconfig/lldpd
213 %endif
214
215 %files devel
216 %defattr(-,root,root)
217 %{_libdir}/liblldpctl.so
218 %{_libdir}/liblldpctl.a
219 %{_libdir}/liblldpctl.la
220 %{_libdir}/pkgconfig/lldpctl.pc
221 %{_includedir}/lldpctl.h
222 %{_includedir}/lldp-const.h
223
224 %changelog
225 * Fri Jul 12 2013 Vincent Bernat <bernat@luffy.cx> - 0.7.6-1
226 - New upstream version.
227
228 * Sat Jun 22 2013 Vincent Bernat <bernat@luffy.cx> - 0.7.5-1
229 - New upstream version.
230
231 * Sun May 12 2013 Vincent Bernat <bernat@luffy.cx> - 0.7.3-1
232 - New upstream version.
233
234 * Fri Apr 19 2013 Vincent Bernat <bernat@luffy.cx> - 0.7.2-1
235 - New upstream version.
236
237 * Sat Jan 12 2013 Vincent Bernat <bernat@luffy.cx> - 0.7.1-1
238 - New upstream version.
239
240 * Sun Jan 06 2013 Vincent Bernat <bernat@luffy.cx> - 0.7.0-1
241 - New upstream version.
242 - Requires readline-devel.
243 - Ships lldpcli.
244
245 * Wed Sep 27 2012 Vincent Bernat <bernat@luffy.cx> - 0.6.1-1
246 - New upstream version
247 - Do not require libevent, use embedded copy.
248 - Provide a -devel package.
249
250 * Fri Jun 11 2010 Vincent Bernat <bernat@luffy.cx> - 0.5.1-1
251 - New upstream version
252 - Define bcond_without and with macros if not defined to be compatible
253 with RHEL
254 - Requires useradd and groupadd
255 - Adapt to make it work with SuSE
256 - Provide an init script targetted at SuSE
257 - Build require lm_sensors-devel on RHEL
258
259 * Fri Mar 12 2010 Vincent Bernat <bernat@luffy.cx> - 0.5.0-1
260 - New upstream version
261 - Add XML support
262
263 * Tue May 19 2009 Vincent Bernat <bernat@luffy.cx> - 0.4.0-1
264 - Add variables
265 - Enable SNMP support
266 - Add _lldpd user creation
267 - Add initscript
268 - New upstream version
269
270 * Mon May 18 2009 Dean Hamstead <dean.hamstead@optusnet.com.au> - 0.3.3-1
271 - Initial attempt