]> git.ipfire.org Git - ipfire-2.x.git/blobdiff - src/installer/configure.ac
installer: Rework downloading ISO and allow using a custom URL
[ipfire-2.x.git] / src / installer / configure.ac
index da968f637f009085b390a63cf8f952efbb2224c0..e93e0afe415b99e6a6158b81f234aac1d93a37ef 100644 (file)
@@ -84,6 +84,11 @@ AC_ARG_WITH([config-root],
        AC_DEFINE_UNQUOTED([CONFIG_ROOT], "$withval", [The config-root]),
        AC_MSG_ERROR([*** you need to set CONFIG_ROOT with --with-config-root=]))
 
+AC_ARG_WITH([download-url],
+       AS_HELP_STRING([--with-download-url] [The default download URL]),
+       AC_DEFINE_UNQUOTED([DOWNLOAD_URL], "$withval", [The default download URL]),
+       AC_MSG_ERROR([*** you need to set DOWNLOAD_URL with --with-download-url=]))
+
 AC_CONFIG_FILES([
        Makefile
        po/Makefile.in