]> git.ipfire.org Git - people/pmueller/ipfire-2.x.git/blobdiff - src/installer/configure.ac
python3-msgpack: Fix build on i586
[people/pmueller/ipfire-2.x.git] / src / installer / configure.ac
index e93e0afe415b99e6a6158b81f234aac1d93a37ef..fb4858cba8bba6c2b1a62b7f9c42d7a6b619c54a 100644 (file)
@@ -39,6 +39,16 @@ AC_PROG_CC
 AC_PROG_CC_C99
 AC_PROG_CC_C_O
 
+CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
+       "-Wformat=2 -Wformat-security -Wformat-nonliteral" \
+       -Werror=overflow \
+       -fno-strict-aliasing \
+       -fstack-protector \
+       -fstack-protector-strong \
+       -fPIE \
+       --param=ssp-buffer-size=4])
+AC_SUBST([OUR_CFLAGS], "$with_cflags")
+
 AC_PATH_PROG([M4], [m4])
 
 # Gettext
@@ -66,17 +76,22 @@ PKG_CHECK_MODULES(UDEV, [libudev])
 
 AC_ARG_WITH([distro-name],
        AS_HELP_STRING([--with-distro-name] [The name of the distribution]),
-       AC_DEFINE_UNQUOTED([NAME], "$withval", [The name of the distribution]),
+       AC_DEFINE_UNQUOTED([DISTRO_NAME], "$withval", [The name of the distribution]),
        AC_MSG_ERROR([*** you need to set the name with --with-distro-name=]))
 
 AC_ARG_WITH([distro-sname],
        AS_HELP_STRING([--with-distro-sname] [The short name of the distribution]),
-       AC_DEFINE_UNQUOTED([SNAME], "$withval", [The sname of the distribution]),
+       AC_DEFINE_UNQUOTED([DISTRO_SNAME], "$withval", [The sname of the distribution]),
        AC_MSG_ERROR([*** you need to set the sname with --with-distro-sname=]))
 
+AC_ARG_WITH([distro-version],
+       AS_HELP_STRING([--with-distro-sname] [The version of the distribution]),
+       AC_DEFINE_UNQUOTED([DISTRO_VERSION], "$withval", [The version of the distribution]),
+       AC_MSG_ERROR([*** you need to set the version with --with-distro-version=]))
+
 AC_ARG_WITH([distro-slogan],
        AS_HELP_STRING([--with-distro-slogan] [The slogan of the distribution]),
-       AC_DEFINE_UNQUOTED([SLOGAN], "$withval", [The slogan of the distribution]),
+       AC_DEFINE_UNQUOTED([DISTRO_SLOGAN], "$withval", [The slogan of the distribution]),
        AC_MSG_ERROR([*** you need to set the slogan with --with-distro-slogan=]))
 
 AC_ARG_WITH([config-root],
@@ -101,4 +116,9 @@ AC_MSG_RESULT([
        CFLAGS:                 ${OUR_CFLAGS} ${CFLAGS}
        CPPFLAGS:               ${OUR_CPPFLAGS} ${CPPFLAGS}
        LDFLAGS:                ${OUR_LDFLAGS} ${LDFLAGS}
+
+       Distribution:           ${DISTRO_NAME} (${DISTRO_SNAME})
+       Version:                ${DISTRO_VERSION}
+       Slogan:                 ${DISTRO_SLOGAN}
+       Config Root:            ${CONFIG_ROOT}
 ])