]> git.ipfire.org Git - thirdparty/cups.git/blob - packaging/cups.spec
eb933e228f68e515dee23a480d36dc5d1ea43836
[thirdparty/cups.git] / packaging / cups.spec
1 #
2 # "$Id: cups.spec.in 11897 2014-05-27 15:02:42Z msweet $"
3 #
4 # RPM "spec" file for CUPS.
5 #
6 # Original version by Jason McMullan <jmcc@ontv.com>.
7 #
8 # Copyright 2007-2014 by Apple Inc.
9 # Copyright 1999-2007 by Easy Software Products, all rights reserved.
10 #
11 # These coded instructions, statements, and computer programs are the
12 # property of Apple Inc. and are protected by Federal copyright
13 # law. Distribution and use rights are outlined in the file "LICENSE.txt"
14 # which should have been included with this file. If this file is
15 # file is missing or damaged, see the license at "http://www.cups.org/".
16 #
17
18 # Conditional build options (--with name/--without name):
19 #
20 # dbus - Enable/disable DBUS support (default = enable)
21 # dnssd - Enable/disable DNS-SD support (default = enable)
22 # libusb1 - Enable/disable LIBUSB 1.0 support (default = enable)
23 # static - Enable/disable static libraries (default = enable)
24
25 %{!?_with_dbus: %{!?_without_dbus: %define _with_dbus --with-dbus}}
26 %{?_with_dbus: %define _dbus --enable-dbus}
27 %{!?_with_dbus: %define _dbus --disable-dbus}
28
29 %{!?_with_dnssd: %{!?_without_dnssd: %define _with_dnssd --with-dnssd}}
30 %{?_with_dnssd: %define _dnssd --enable-dnssd}
31 %{!?_with_dnssd: %define _dnssd --disable-dnssd}
32
33 %{!?_with_libusb1: %{!?_without_libusb1: %define _with_libusb1 --with-libusb1}}
34 %{?_with_libusb1: %define _libusb1 --enable-libusb}
35 %{!?_with_libusb1: %define _libusb1 --disable-libusb}
36
37 %{!?_with_static: %{!?_without_static: %define _without_static --without-static}}
38 %{?_with_static: %define _static --enable-static}
39 %{!?_with_static: %define _static --disable-static}
40
41 Summary: CUPS
42 Name: cups
43 Version: 1.7.3
44 Release: 1
45 Epoch: 1
46 License: GPL
47 Group: System Environment/Daemons
48 Source: http://www.cups.org/software/1.7.3/cups-1.7.3-source.tar.bz2
49 Url: http://www.cups.org
50 Packager: Anonymous <anonymous@foo.com>
51 Vendor: Apple Inc.
52
53 # Package names are as defined for Red Hat (and clone) distributions
54 BuildRequires: gnutls-devel, pam-devel
55
56 %if %{?_with_dbus:1}%{!?_with_dbus:0}
57 BuildRequires: dbus-devel
58 %endif
59
60 %if %{?_with_dnssd:1}%{!?_with_dnssd:0}
61 BuildRequires: avahi-devel
62 %endif
63
64 %if %{?_with_libusb1:1}%{!?_with_libusb1:0}
65 BuildRequires: libusb-devel >= 1.0
66 %endif
67
68 # Use buildroot so as not to disturb the version already installed
69 BuildRoot: /tmp/%{name}-root
70
71 # Dependencies...
72 Requires: %{name}-libs = %{epoch}:%{version}
73 Obsoletes: lpd, lpr, LPRng
74 Provides: lpd, lpr, LPRng
75 Obsoletes: cups-da, cups-de, cups-es, cups-et, cups-fi, cups-fr, cups-he
76 Obsoletes: cups-id, cups-it, cups-ja, cups-ko, cups-nl, cups-no, cups-pl
77 Obsoletes: cups-pt, cups-ru, cups-sv, cups-zh
78
79 %package devel
80 Summary: CUPS - development environment
81 Group: Development/Libraries
82 Requires: %{name}-libs = %{epoch}:%{version}
83
84 %package libs
85 Summary: CUPS - shared libraries
86 Group: System Environment/Libraries
87 Provides: libcups1
88
89 %package lpd
90 Summary: CUPS - LPD support
91 Group: System Environment/Daemons
92 Requires: %{name} = %{epoch}:%{version} xinetd
93
94 %description
95 CUPS is the standards-based, open source printing system developed by
96 Apple Inc. for OS X and other UNIX®-like operating systems.
97
98 %description devel
99 This package provides the CUPS headers and development environment.
100
101 %description libs
102 This package provides the CUPS shared libraries.
103
104 %description lpd
105 This package provides LPD client support.
106
107 %prep
108 %setup
109
110 %build
111 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_OPT_FLAGS" \
112 ./configure %{_dbus} %{_dnssd} %{_libusb1} %{_static}
113 # If we got this far, all prerequisite libraries must be here.
114 make
115
116 %install
117 # Make sure the RPM_BUILD_ROOT directory exists.
118 rm -rf $RPM_BUILD_ROOT
119
120 make BUILDROOT=$RPM_BUILD_ROOT install
121
122 %post
123 /sbin/chkconfig --add cups
124 /sbin/chkconfig cups on
125
126 # Restart cupsd if we are upgrading...
127 if test $1 -gt 1; then
128 /sbin/service cups stop
129 /sbin/service cups start
130 fi
131
132 %post libs
133 /sbin/ldconfig
134
135 %preun
136 if test $1 = 0; then
137 /sbin/service cups stop
138 /sbin/chkconfig --del cups
139 fi
140
141 %postun
142 if test $1 -ge 1; then
143 /sbin/service cups stop
144 /sbin/service cups start
145 fi
146
147 %postun libs
148 /sbin/ldconfig
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %docdir /usr/share/doc/cups
155 %defattr(-,root,root)
156 %dir /etc/cups
157 %config(noreplace) /etc/cups/*.conf
158 /etc/cups/cupsd.conf.default
159 %dir /etc/cups/interfaces
160 %dir /etc/cups/ppd
161 %attr(0700,root,root) %dir /etc/cups/ssl
162
163 %if %{?_with_dbus:1}%{!?_with_dbus:0}
164 # DBUS
165 /etc/dbus-1/system.d/*
166 %endif
167
168 # PAM
169 %dir /etc/pam.d
170 /etc/pam.d/*
171
172 # RC dirs are a pain under Linux... Uncomment the appropriate ones if you
173 # don't use Red Hat or Mandrake...
174
175 /etc/init.d/*
176 /etc/rc0.d/*
177 /etc/rc2.d/*
178 /etc/rc3.d/*
179 /etc/rc5.d/*
180
181 # OLD RedHat/Mandrake
182 #/etc/rc.d/init.d/*
183 #/etc/rc.d/rc0.d/*
184 #/etc/rc.d/rc2.d/*
185 #/etc/rc.d/rc3.d/*
186 #/etc/rc.d/rc5.d/*
187
188 #/sbin/rc.d/*
189 #/sbin/rc.d/rc0.d/*
190 #/sbin/rc.d/rc2.d/*
191 #/sbin/rc.d/rc3.d/*
192 #/sbin/rc.d/rc5.d/*
193
194 /usr/bin/cancel
195 /usr/bin/cupstestdsc
196 /usr/bin/cupstestppd
197 /usr/bin/ippfind
198 /usr/bin/ipptool
199 /usr/bin/lp*
200 %dir /usr/lib/cups
201 %dir /usr/lib/cups/backend
202 %if %{?_with_dnssd:1}%{!?_with_dnssd:0}
203 # DNS-SD
204 /usr/lib/cups/backend/dnssd
205 %endif
206 /usr/lib/cups/backend/http
207 /usr/lib/cups/backend/https
208 %attr(0700,root,root) /usr/lib/cups/backend/ipp
209 /usr/lib/cups/backend/ipps
210 %attr(0700,root,root) /usr/lib/cups/backend/lpd
211 /usr/lib/cups/backend/snmp
212 /usr/lib/cups/backend/socket
213 /usr/lib/cups/backend/usb
214 %dir /usr/lib/cups/cgi-bin
215 /usr/lib/cups/cgi-bin/*
216 %dir /usr/lib/cups/daemon
217 /usr/lib/cups/daemon/cups-deviced
218 /usr/lib/cups/daemon/cups-driverd
219 /usr/lib/cups/daemon/cups-exec
220 %dir /usr/lib/cups/driver
221 %dir /usr/lib/cups/filter
222 /usr/lib/cups/filter/*
223 %dir /usr/lib/cups/monitor
224 /usr/lib/cups/monitor/*
225 %dir /usr/lib/cups/notifier
226 /usr/lib/cups/notifier/*
227
228 /usr/sbin/*
229 %dir /usr/share/cups
230 %dir /usr/share/cups/banners
231 /usr/share/cups/banners/*
232 %dir /usr/share/cups/data
233 /usr/share/cups/data/*
234 %dir /usr/share/cups/drv
235 /usr/share/cups/drv/*
236 %dir /usr/share/cups/ipptool
237 /usr/share/cups/ipptool/*
238 %dir /usr/share/cups/mime
239 /usr/share/cups/mime/*
240 %dir /usr/share/cups/model
241 %dir /usr/share/cups/ppdc
242 /usr/share/cups/ppdc/*
243 %dir /usr/share/cups/templates
244 /usr/share/cups/templates/*
245 %if %{?_with_libusb1:1}%{!?_with_libusb1:0}
246 # LIBUSB quirks files
247 %dir /usr/share/cups/usb
248 /usr/share/cups/usb/*
249 %endif
250
251 %dir /usr/share/doc/cups
252 /usr/share/doc/cups/*.*
253 %dir /usr/share/doc/cups/help
254 /usr/share/doc/cups/help/accounting.html
255 /usr/share/doc/cups/help/cgi.html
256 /usr/share/doc/cups/help/glossary.html
257 /usr/share/doc/cups/help/kerberos.html
258 /usr/share/doc/cups/help/license.html
259 /usr/share/doc/cups/help/man-*.html
260 /usr/share/doc/cups/help/network.html
261 /usr/share/doc/cups/help/options.html
262 /usr/share/doc/cups/help/overview.html
263 /usr/share/doc/cups/help/policies.html
264 /usr/share/doc/cups/help/ref-*.html
265 /usr/share/doc/cups/help/security.html
266 /usr/share/doc/cups/help/sharing.html
267 /usr/share/doc/cups/help/translation.html
268 /usr/share/doc/cups/help/whatsnew.html
269 %dir /usr/share/doc/cups/images
270 /usr/share/doc/cups/images/*
271
272 %dir /usr/share/doc/cups/ca
273 /usr/share/doc/cups/ca/*
274 %dir /usr/share/doc/cups/cs
275 /usr/share/doc/cups/cs/*
276 %dir /usr/share/doc/cups/de
277 /usr/share/doc/cups/de/*
278 %dir /usr/share/doc/cups/es
279 /usr/share/doc/cups/es/*
280 %dir /usr/share/doc/cups/fr
281 /usr/share/doc/cups/fr/*
282 %dir /usr/share/doc/cups/it
283 /usr/share/doc/cups/it/*
284 %dir /usr/share/doc/cups/ja
285 /usr/share/doc/cups/ja/*
286 %dir /usr/share/doc/cups/ru
287 /usr/share/doc/cups/ru/*
288
289 %dir /usr/share/locale/ca
290 /usr/share/locale/ca/cups_ca.po
291 %dir /usr/share/locale/cs
292 /usr/share/locale/cs/cups_cs.po
293 %dir /usr/share/locale/de
294 /usr/share/locale/de/cups_de.po
295 %dir /usr/share/locale/es
296 /usr/share/locale/es/cups_es.po
297 %dir /usr/share/locale/fr
298 /usr/share/locale/fr/cups_fr.po
299 %dir /usr/share/locale/it
300 /usr/share/locale/it/cups_it.po
301 %dir /usr/share/locale/ja
302 /usr/share/locale/ja/cups_ja.po
303 %dir /usr/share/locale/ru
304 /usr/share/locale/ru/cups_ru.po
305
306 %dir /usr/share/man/man1
307 /usr/share/man/man1/cancel.1.gz
308 /usr/share/man/man1/cupstestdsc.1.gz
309 /usr/share/man/man1/cupstestppd.1.gz
310 /usr/share/man/man1/ippfind.1.gz
311 /usr/share/man/man1/ipptool.1.gz
312 /usr/share/man/man1/lp.1.gz
313 /usr/share/man/man1/lpoptions.1.gz
314 /usr/share/man/man1/lppasswd.1.gz
315 /usr/share/man/man1/lpq.1.gz
316 /usr/share/man/man1/lpr.1.gz
317 /usr/share/man/man1/lprm.1.gz
318 /usr/share/man/man1/lpstat.1.gz
319 %dir /usr/share/man/man5
320 /usr/share/man/man5/*.conf.5.gz
321 /usr/share/man/man5/ipptoolfile.5.gz
322 /usr/share/man/man5/mime.*.5.gz
323 %dir /usr/share/man/man8
324 /usr/share/man/man8/accept.8.gz
325 /usr/share/man/man8/cupsaddsmb.8.gz
326 /usr/share/man/man8/cupsaccept.8.gz
327 /usr/share/man/man8/cupsctl.8.gz
328 /usr/share/man/man8/cupsfilter.8.gz
329 /usr/share/man/man8/cupsd.8.gz
330 /usr/share/man/man8/cupsdisable.8.gz
331 /usr/share/man/man8/cupsenable.8.gz
332 /usr/share/man/man8/cupsreject.8.gz
333 /usr/share/man/man8/cups-deviced.8.gz
334 /usr/share/man/man8/cups-driverd.8.gz
335 /usr/share/man/man8/cups-snmp.8.gz
336 /usr/share/man/man8/lpadmin.8.gz
337 /usr/share/man/man8/lpc.8.gz
338 /usr/share/man/man8/lpinfo.8.gz
339 /usr/share/man/man8/lpmove.8.gz
340 /usr/share/man/man8/reject.8.gz
341
342 %dir /var/cache/cups
343 %attr(0775,root,sys) %dir /var/cache/cups/rss
344 %dir /var/log/cups
345 %dir /var/run/cups
346 %attr(0711,lp,sys) %dir /var/run/cups/certs
347 %attr(0710,lp,sys) %dir /var/spool/cups
348 %attr(1770,lp,sys) %dir /var/spool/cups/tmp
349
350 # Desktop files
351 /usr/share/applications/*
352 /usr/share/icons/*
353
354 %files devel
355 %defattr(-,root,root)
356 %dir /usr/share/cups/examples
357 /usr/share/cups/examples/*
358 %dir /usr/share/man/man1
359 /usr/share/man/man1/cups-config.1.gz
360 /usr/share/man/man1/ppd*.1.gz
361 %dir /usr/share/man/man5
362 /usr/share/man/man5/ppdcfile.5.gz
363 /usr/share/man/man7/backend.7.gz
364 /usr/share/man/man7/filter.7.gz
365 /usr/share/man/man7/notifier.7.gz
366
367 /usr/bin/cups-config
368 /usr/bin/ppd*
369 %dir /usr/include/cups
370 /usr/include/cups/*
371 /usr/lib*/*.so
372
373 %if %{?_with_static:1}%{!?_with_static:0}
374 /usr/lib*/*.a
375 %endif
376
377 %dir /usr/share/doc/cups/help
378 /usr/share/doc/cups/help/api*.html
379 /usr/share/doc/cups/help/postscript-driver.html
380 /usr/share/doc/cups/help/ppd-compiler.html
381 /usr/share/doc/cups/help/raster-driver.html
382 /usr/share/doc/cups/help/spec*.html
383
384 %files libs
385 %defattr(-,root,root)
386 /usr/lib*/*.so.*
387
388 %files lpd
389 %defattr(-,root,root)
390 /etc/xinetd.d/cups-lpd
391 %dir /usr/lib/cups
392 %dir /usr/lib/cups/daemon
393 /usr/lib/cups/daemon/cups-lpd
394 %dir /usr/share/man/man8
395 /usr/share/man/man8/cups-lpd.8.gz
396
397
398 #
399 # End of "$Id: cups.spec.in 11897 2014-05-27 15:02:42Z msweet $".
400 #