]> git.ipfire.org Git - thirdparty/freeswitch.git/blob - freeswitch-sounds-en-us-allison.spec
Merge pull request #2449 from signalwire/fix_scan_build_mod_amrwb
[thirdparty/freeswitch.git] / freeswitch-sounds-en-us-allison.spec
1 ##############################################################################
2 # Copyright and license
3 ##############################################################################
4 #
5 # Spec file for package freeswitch-sounds-en-us-allison (version 1.0.1-1)
6 #
7 # Copyright (c) 2009 Patrick Laimbock
8 # Some fixes and additions (c) 2011 Michal Bielicki
9 # This file and all modifications and additions to the pristine
10 # package are under the same license as the package itself.
11 #
12
13 ##############################################################################
14 # Determine distribution
15 ##############################################################################
16
17 # %define is_rhel5 %(test -f /etc/redhat-release && egrep -q 'release 5' /etc/redhat-release && echo 1 || echo 0)
18
19 ##############################################################################
20 # Set variables
21 ##############################################################################
22
23 %define version 1.0.1
24 %define release 1
25
26 %define fsname freeswitch
27 # you could add a version number to be more strict
28
29 %define PREFIX %{_prefix}
30 %define EXECPREFIX %{_exec_prefix}
31 %define BINDIR %{_bindir}
32 %define SBINDIR %{_sbindir}
33 %define LIBEXECDIR %{_libexecdir}/%{fsname}
34 %define SYSCONFDIR %{_sysconfdir}/%{fsname}
35 %define SHARESTATEDIR %{_sharedstatedir}/%{fsname}
36 %define LOCALSTATEDIR %{_localstatedir}/lib/%{fsname}
37 %define LIBDIR %{_libdir}
38 %define INCLUDEDIR %{_includedir}
39 %define _datarootdir %{_prefix}/share
40 %define DATAROOTDIR %{_datarootdir}
41 %define DATADIR %{_datadir}
42 %define INFODIR %{_infodir}
43 %define LOCALEDIR %{_datarootdir}/locale
44 %define MANDIR %{_mandir}
45 %define DOCDIR %{_defaultdocdir}/%{fsname}
46 %define HTMLDIR %{_defaultdocdir}/%{fsname}/html
47 %define DVIDIR %{_defaultdocdir}/%{fsname}/dvi
48 %define PDFDIR %{_defaultdocdir}/%{fsname}/pdf
49 %define PSDIR %{_defaultdocdir}/%{fsname}/ps
50 %define LOGFILEDIR /var/log/%{fsname}
51 %define MODINSTDIR %{_libdir}/%{fsname}/mod
52 %define RUNDIR %{_localstatedir}/run/%{fsname}
53 %define DBDIR %{LOCALSTATEDIR}/db
54 %define HTDOCSDIR %{_datarootdir}/%{fsname}/htdocs
55 %define SOUNDSDIR %{_datarootdir}/%{fsname}/sounds
56 %define GRAMMARDIR %{_datarootdir}/%{fsname}/grammar
57 %define SCRIPTDIR %{_datarootdir}/%{fsname}/scripts
58 %define RECORDINGSDIR %{LOCALSTATEDIR}/recordings
59 %define PKGCONFIGDIR %{_datarootdir}/%{fsname}/pkgconfig
60 %define HOMEDIR %{LOCALSTATEDIR}
61
62
63 ##############################################################################
64 # General
65 ##############################################################################
66
67 Summary: FreeSWITCH en-us Allison prompts
68 Name: freeswitch-sounds-en-us-allison
69 Version: %{version}
70 Release: %{release}%{?dist}
71 License: MPL
72 Group: Applications/Communications
73 Packager: Patrick Laimbock <vc-rpms@voipconsulting.nl>
74 URL: http://www.freeswitch.org
75 Source0:http://files.freeswitch.org/releases/sounds/%{name}-48000-%{version}.tar.gz
76 Source1:http://files.freeswitch.org/releases/sounds/%{name}-32000-%{version}.tar.gz
77 Source2:http://files.freeswitch.org/releases/sounds/%{name}-16000-%{version}.tar.gz
78 Source3:http://files.freeswitch.org/releases/sounds/%{name}-8000-%{version}.tar.gz
79 BuildArch: noarch
80 BuildRequires: sox
81 Requires: freeswitch
82 Requires: freeswitch-sounds-en-us-allison-48000
83 Requires: sox
84 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
85
86 %description
87 FreeSWITCH 48kHz en-us Allison prompts plus, during the installation,
88 it will also install locally generated 8KHz, 16KHz and 32KHz prompts
89
90 %package -n freeswitch-sounds-en-us-allison-8000
91 Summary: FreeSWITCH 8kHz en-us Allison prompts
92 Group: Applications/Communications
93 BuildArch: noarch
94 Requires: %{fsname}
95
96 %description -n freeswitch-sounds-en-us-allison-8000
97 FreeSWITCH 8kHz en-us Allison prompts
98
99 %package -n freeswitch-sounds-en-us-allison-16000
100 Summary: FreeSWITCH 16kHz en-us Allison prompts
101 Group: Applications/Communications
102 BuildArch: noarch
103 Requires: %{fsname}
104
105 %description -n freeswitch-sounds-en-us-allison-16000
106 FreeSWITCH 16kHz en-us Allison prompts
107
108 %package -n freeswitch-sounds-en-us-allison-32000
109 Summary: FreeSWITCH 32kHz en-us Allison prompts
110 Group: Applications/Communications
111 BuildArch: noarch
112 Requires: %{fsname}
113
114 %description -n freeswitch-sounds-en-us-allison-32000
115 FreeSWITCH 32kHz en-us Allison prompts
116
117 %package -n freeswitch-sounds-en-us-allison-48000
118 Summary: FreeSWITCH 48kHz en-us Allison prompts
119 Group: Applications/Communications
120 BuildArch: noarch
121 Requires: %{fsname}
122
123 %description -n freeswitch-sounds-en-us-allison-48000
124 FreeSWITCH 48kHz en-us Allison prompts
125
126 %package -n freeswitch-sounds-en-us-allison-all
127 Summary: FreeSWITCH en-us Allison prompts
128 Group: Applications/Communications
129 BuildArch: noarch
130 Requires: %{fsname}
131 Requires: freeswitch-sounds-en-us-allison-8000 = %{version}
132 Requires: freeswitch-sounds-en-us-allison-16000 = %{version}
133 Requires: freeswitch-sounds-en-us-allison-32000 = %{version}
134 Requires: freeswitch-sounds-en-us-allison-48000 = %{version}
135
136 %description -n freeswitch-sounds-en-us-allison-all
137 FreeSWITCH Allison prompts package that pulls in the 8KHz, 16KHz,
138 32KHz and 48KHz RPMs
139
140 ##############################################################################
141 # Prep
142 ##############################################################################
143
144 %prep
145 %setup -n en
146 %setup -T -D -b 0 -n en
147 %setup -T -D -b 1 -n en
148 %setup -T -D -b 2 -n en
149 %setup -T -D -b 3 -n en
150
151 ##############################################################################
152 # Build
153 ##############################################################################
154
155 %build
156 # nothing to do here
157
158 ##############################################################################
159 # Install
160 ##############################################################################
161
162 %install
163 [ "%{buildroot}" != '/' ] && rm -rf %{buildroot}
164
165 # create the sounds directories
166 %{__install} -d -m 0750 %{buildroot}%{SOUNDSDIR}/en/us/allison
167
168 pushd us/allison
169 # first install the 48KHz sounds
170 %{__cp} -prv ./* %{buildroot}%{SOUNDSDIR}/en/us/allison
171 # now resample the 48KHz ones to 8KHz, 16KHz and 32KHz
172 popd
173
174 ##############################################################################
175 # Clean
176 ##############################################################################
177
178 %clean
179 [ "%{buildroot}" != '/' ] && rm -rf %{buildroot}
180
181 ##############################################################################
182 # Post
183 ##############################################################################
184
185 %post
186 # generate the 8KHz, 16KHz and 32KHz prompts from the 48KHz ones
187
188 ##############################################################################
189 # Postun
190 ##############################################################################
191
192 %postun
193 # you could check if there are sound files in 8000/ or
194 # 16000/ or 32000/ and remove them *only* if the files
195 # do not belong to an rpm
196
197 ##############################################################################
198 # Files
199 ##############################################################################
200
201 %files
202 %defattr(-,root,root)
203
204 %files -n freeswitch-sounds-en-us-allison-8000
205 %defattr(-,root,root,-)
206 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/alt/8000
207 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/ascii/8000
208 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/base256/8000
209 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/conference/8000
210 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/currency/8000
211 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/digits/8000
212 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/directory/8000
213 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/ivr/8000
214 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/misc/8000
215 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/time/8000
216 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/voicemail/8000
217 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/zrtp/8000
218 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/alt/8000/*.wav
219 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/ascii/8000/*.wav
220 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/base256/8000/*.wav
221 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/conference/8000/*.wav
222 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/currency/8000/*.wav
223 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/digits/8000/*.wav
224 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/directory/8000/*.wav
225 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/ivr/8000/*.wav
226 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/misc/8000/*.wav
227 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/time/8000/*.wav
228 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/voicemail/8000/*.wav
229 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/zrtp/8000/*.wav
230
231 %files -n freeswitch-sounds-en-us-allison-16000
232 %defattr(-,root,root,-)
233 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/alt/16000
234 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/ascii/16000
235 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/base256/16000
236 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/conference/16000
237 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/currency/16000
238 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/digits/16000
239 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/directory/16000
240 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/ivr/16000
241 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/misc/16000
242 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/time/16000
243 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/voicemail/16000
244 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/zrtp/16000
245 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/alt/16000/*.wav
246 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/ascii/16000/*.wav
247 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/base256/16000/*.wav
248 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/conference/16000/*.wav
249 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/currency/16000/*.wav
250 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/digits/16000/*.wav
251 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/directory/16000/*.wav
252 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/ivr/16000/*.wav
253 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/misc/16000/*.wav
254 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/time/16000/*.wav
255 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/voicemail/16000/*.wav
256 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/zrtp/16000/*.wav
257
258 %files -n freeswitch-sounds-en-us-allison-32000
259 %defattr(-,root,root,-)
260 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/alt/32000
261 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/ascii/32000
262 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/base256/32000
263 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/conference/32000
264 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/currency/32000
265 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/digits/32000
266 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/directory/32000
267 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/ivr/32000
268 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/misc/32000
269 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/time/32000
270 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/voicemail/32000
271 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/zrtp/32000
272 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/alt/32000/*.wav
273 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/ascii/32000/*.wav
274 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/base256/32000/*.wav
275 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/conference/32000/*.wav
276 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/currency/32000/*.wav
277 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/digits/32000/*.wav
278 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/directory/32000/*.wav
279 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/ivr/32000/*.wav
280 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/misc/32000/*.wav
281 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/time/32000/*.wav
282 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/voicemail/32000/*.wav
283 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/zrtp/32000/*.wav
284
285 %files -n freeswitch-sounds-en-us-allison-48000
286 %defattr(-,root,root,-)
287 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/alt/48000
288 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/ascii/48000
289 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/base256/48000
290 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/conference/48000
291 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/currency/48000
292 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/digits/48000
293 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/directory/48000
294 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/ivr/48000
295 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/misc/48000
296 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/time/48000
297 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/voicemail/48000
298 %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/allison/zrtp/48000
299 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/alt/48000/*.wav
300 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/ascii/48000/*.wav
301 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/base256/48000/*.wav
302 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/conference/48000/*.wav
303 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/currency/48000/*.wav
304 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/digits/48000/*.wav
305 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/directory/48000/*.wav
306 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/ivr/48000/*.wav
307 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/misc/48000/*.wav
308 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/time/48000/*.wav
309 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/voicemail/48000/*.wav
310 %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/allison/zrtp/48000/*.wav
311
312 %files -n freeswitch-sounds-en-us-allison-all
313
314 ##############################################################################
315 # Changelog
316 ##############################################################################
317
318 %changelog
319 * Fri Apr 19 2019 Andrey Volk <andrey@signalwire.com> - 1.0.1-1
320 - add missing alt folder and remove non-existing items
321 - bump up version
322 * Tue Jul 25 2017 Mike Jerris <mike@freeswitch.org> - 1.0.0-1
323 - update to FHS Layout for FreeSWITCH
324 - bump up version
325