]> git.ipfire.org Git - thirdparty/freeswitch.git/blob - freeswitch-sounds-music.spec
[Core, mod_cidlookup, mod_curl, mod_httapi, mod_http_cache, mod_kazoo, mod_shout...
[thirdparty/freeswitch.git] / freeswitch-sounds-music.spec
1 %define fsname freeswitch
2 %define PREFIX %{_prefix}
3 %define EXECPREFIX %{_exec_prefix}
4 %define BINDIR %{_bindir}
5 %define SBINDIR %{_sbindir}
6 %define LIBEXECDIR %{_libexecdir}/%{fsname}
7 %define SYSCONFDIR %{_sysconfdir}/%{fsname}
8 %define SHARESTATEDIR %{_sharedstatedir}/%{fsname}
9 %define LOCALSTATEDIR %{_localstatedir}/lib/%{fsname}
10 %define LIBDIR %{_libdir}
11 %define INCLUDEDIR %{_includedir}
12 %define _datarootdir %{_prefix}/share
13 %define DATAROOTDIR %{_datarootdir}
14 %define DATADIR %{_datadir}
15 %define INFODIR %{_infodir}
16 %define LOCALEDIR %{_datarootdir}/locale
17 %define MANDIR %{_mandir}
18 %define DOCDIR %{_defaultdocdir}/%{fsname}
19 %define HTMLDIR %{_defaultdocdir}/%{fsname}/html
20 %define DVIDIR %{_defaultdocdir}/%{fsname}/dvi
21 %define PDFDIR %{_defaultdocdir}/%{fsname}/pdf
22 %define PSDIR %{_defaultdocdir}/%{fsname}/ps
23 %define LOGFILEDIR /var/log/%{fsname}
24 %define MODINSTDIR %{_libdir}/%{fsname}/mod
25 %define RUNDIR %{_localstatedir}/run/%{fsname}
26 %define DBDIR %{LOCALSTATEDIR}/db
27 %define HTDOCSDIR %{_datarootdir}/%{fsname}/htdocs
28 %define SOUNDSDIR %{_datarootdir}/%{fsname}/sounds
29 %define GRAMMARDIR %{_datarootdir}/%{fsname}/grammar
30 %define SCRIPTDIR %{_datarootdir}/%{fsname}/scripts
31 %define RECORDINGSDIR %{LOCALSTATEDIR}/recordings
32 %define PKGCONFIGDIR %{_datarootdir}/%{fsname}/pkgconfig
33 %define HOMEDIR %{LOCALSTATEDIR}
34
35
36 Summary: FreeSWITCH Music on Hold soundfiles
37 Name: freeswitch-sounds-music
38 Version: 1.0.52
39 Release: 1%{?dist}
40 License: MPL
41 Group: Productivity/Telephony/Servers
42 Packager: Joseph L. Casale <jcasale@activenetwerx.com>
43 URL: http://www.freeswitch.org
44 Source0: http://files.freeswitch.org/releases/sounds/%{name}-8000-%{version}.tar.gz
45 Source1: http://files.freeswitch.org/releases/sounds/%{name}-16000-%{version}.tar.gz
46 Source2: http://files.freeswitch.org/releases/sounds/%{name}-32000-%{version}.tar.gz
47 Source3: http://files.freeswitch.org/releases/sounds/%{name}-48000-%{version}.tar.gz
48 BuildArch: noarch
49 BuildRequires: bash
50 Requires: freeswitch
51 Requires: freeswitch-sounds-music-8000 = %{version}
52 Requires: freeswitch-sounds-music-16000 = %{version}
53 Requires: freeswitch-sounds-music-32000 = %{version}
54 Requires: freeswitch-sounds-music-48000 = %{version}
55 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
56
57 %description
58 FreeSWITCH Music On Hold soundfiles package that installs the 8KHz, 16KHz,
59 32KHz and 48KHz RPMs
60
61
62 %package -n freeswitch-sounds-music-8000
63 Summary: FreeSWITCH 8kHz Music On Hold soundfiles
64 Group: Productivity/Telephony/Servers
65 BuildArch: noarch
66 Requires: freeswitch
67
68 %description -n freeswitch-sounds-music-8000
69 FreeSWITCH 8kHz Music On Hold soundfiles
70
71
72 %package -n freeswitch-sounds-music-16000
73 Summary: FreeSWITCH 16kHz Music On Hold soundfiles
74 Group: Productivity/Telephony/Servers
75 BuildArch: noarch
76 Requires: freeswitch
77
78 %description -n freeswitch-sounds-music-16000
79 FreeSWITCH 16kHz Music On Hold soundfiles
80
81
82 %package -n freeswitch-sounds-music-32000
83 Summary: FreeSWITCH 32kHz Music On Hold soundfiles
84 Group: Productivity/Telephony/Servers
85 BuildArch: noarch
86 Requires: freeswitch
87
88 %description -n freeswitch-sounds-music-32000
89 FreeSWITCH 32kHz Music On Hold soundfiles
90
91
92 %package -n freeswitch-sounds-music-48000
93 Summary: FreeSWITCH 48kHz Music On Hold soundfiles
94 Group: Productivity/Telephony/Servers
95 BuildArch: noarch
96 Requires: freeswitch
97
98 %description -n freeswitch-sounds-music-48000
99 FreeSWITCH 48kHz Music On Hold soundfiles
100
101
102 %prep
103 %setup -n music
104 %setup -T -D -b 1 -n music
105 %setup -T -D -b 2 -n music
106 %setup -T -D -b 3 -n music
107
108
109 %build
110
111
112 %install
113 %{__rm} -rf %{buildroot}
114 %{__install} -d -m 0750 %{buildroot}/%{SOUNDSDIR}/music/{8000,16000,32000,48000}
115 %{__cp} -prv ./{8000,16000,32000,48000} %{buildroot}%{SOUNDSDIR}/music
116
117
118 %clean
119 %{__rm} -rf %{buildroot}
120
121
122 %post
123
124
125 %postun
126
127
128 %files
129
130
131 %files -n freeswitch-sounds-music-8000
132 %defattr(-,root,root,-)
133 %dir %{SOUNDSDIR}/music/8000
134 %{SOUNDSDIR}/music/8000/*.wav
135
136
137 %files -n freeswitch-sounds-music-16000
138 %defattr(-,root,root,-)
139 %dir %{SOUNDSDIR}/music/16000
140 %{SOUNDSDIR}/music/16000/*.wav
141
142
143 %files -n freeswitch-sounds-music-32000
144 %defattr(-,root,root,-)
145 %dir %{SOUNDSDIR}/music/32000
146 %{SOUNDSDIR}/music/32000/*.wav
147
148
149 %files -n freeswitch-sounds-music-48000
150 %defattr(-,root,root,-)
151 %dir %{SOUNDSDIR}/music/48000
152 %{SOUNDSDIR}/music/48000/*.wav
153
154
155 %changelog
156 * Fri Apr 19 2019 Andrey Volk <andrey@signalwire.com> - 1.0.52-1
157 - bump up version
158 * Sat Jul 16 2011 Joseph Casale <jcasale@activenetwerx.com> 1.0.8-2
159 - Fix up for FreeSWITCH FHS and AutoBuild System
160 * Sat Jul 16 2011 Joseph Casale <jcasale@activenetwerx.com> 1.0.8-1
161 - Initial release