]> git.ipfire.org Git - thirdparty/gcc.git/blobdiff - libiberty/configure.ac
configure: Implement --enable-host-pie
[thirdparty/gcc.git] / libiberty / configure.ac
index 28d996f9cf7b7c84247a81b0fbcb3a1ae6adcb9e..6747a7b5cffd389155eccddd4a8053be58f111f2 100644 (file)
@@ -233,8 +233,8 @@ case "${enable_shared}" in
   *) shared=yes ;;
 esac
 
-# ...unless --enable-host-shared was passed from top-level config:
-if [[ "${enable_host_shared}" = "yes" ]]; then
+# ...unless --enable-host-{shared,pie} was passed from top-level config:
+if [[ "${enable_host_shared}" = "yes" ]] || [[ "${enable_host_pie}" = "yes" ]]; then
   shared=yes
 fi