]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core-contrib.git/commitdiff
python3-ply: move from meta-python
authorTim Orling <tim.orling@konsulko.com>
Sat, 12 Mar 2022 21:53:06 +0000 (13:53 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Mar 2022 08:48:04 +0000 (08:48 +0000)
Dependency for python3-cryptography

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
meta/recipes-devtools/python/python3-ply_3.11.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python3-ply_3.11.bb b/meta/recipes-devtools/python/python3-ply_3.11.bb
new file mode 100644 (file)
index 0000000..99c037b
--- /dev/null
@@ -0,0 +1,18 @@
+SUMMARY = "Python Lex and Yacc"
+DESCRIPTION = "Python ply: PLY is yet another implementation of lex and yacc for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/ply"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://README.md;beginline=5;endline=32;md5=f5ee5c355c0e6719c787a71b8f0fa96c"
+
+SRC_URI[md5sum] = "6465f602e656455affcd7c5734c638f8"
+SRC_URI[sha256sum] = "00c7c1aaa88358b9c765b6d3000c6eec0ba42abca5351b095321aef446081da3"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN}:class-target += "\
+    ${PYTHON_PN}-netclient \
+    ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native"