]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core-contrib.git/commitdiff
python3-cryptography: mark test_create_certificate_with_extensions as expected to...
authorRoss Burton <ross.burton@arm.com>
Mon, 14 Mar 2022 13:56:54 +0000 (13:56 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Mar 2022 08:48:04 +0000 (08:48 +0000)
This test causes OpenSSL to leak some memory. Until this is resolved in
OpenSSL, mark the test as expected-to-fail.

Signed-off-by: Ross Burton <ross.burton@arm.com>
meta/recipes-devtools/python/python3-cryptography/skip-leaky-test.patch [new file with mode: 0644]
meta/recipes-devtools/python/python3-cryptography_36.0.1.bb

diff --git a/meta/recipes-devtools/python/python3-cryptography/skip-leaky-test.patch b/meta/recipes-devtools/python/python3-cryptography/skip-leaky-test.patch
new file mode 100644 (file)
index 0000000..64248d5
--- /dev/null
@@ -0,0 +1,19 @@
+Mark as test as expected-failure, OpenSSL is leaking memory.
+
+xfail not skip so we can remove this when OpenSSL doesn't leak anymore.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+diff --git a/tests/hazmat/backends/test_openssl_memleak.py b/tests/hazmat/backends/test_openssl_memleak.py
+index 835c9256..639f6ba2 100644
+--- a/tests/hazmat/backends/test_openssl_memleak.py
++++ b/tests/hazmat/backends/test_openssl_memleak.py
+@@ -466,6 +466,7 @@ class TestOpenSSLMemoryLeaks:
+             )
+         )
++    @pytest.mark.xfail(reason="has memory leaks")
+     def test_create_certificate_with_extensions(self):
+         assert_no_memory_leaks(
+             textwrap.dedent(
index 11466ecece6126f3ced0ceaca0dd0991060b1b74..69eeeb1e9683db4015d38d9587e0ad0f84c7c21e 100644 (file)
@@ -16,6 +16,7 @@ SRC_URI += " \
     file://check-memfree.py \
     file://0001-Cargo.toml-specify-pem-version.patch \
     file://0002-Cargo.toml-edition-2018-2021.patch \
+    file://skip-leaky-test.patch \
 "
 
 inherit pypi python_setuptools3_rust