]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core-contrib.git/commitdiff
classes/python_pep517: consolidate stub do_configure
authorRoss Burton <ross@burtonini.com>
Wed, 16 Mar 2022 18:32:43 +0000 (18:32 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 17 Mar 2022 16:43:04 +0000 (16:43 +0000)
As PEP517 doesn't have an explicit configure step, we can stub out the
do_configure task once instead of the calling classes doing it.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/python_flit_core.bbclass
meta/classes/python_pep517.bbclass
meta/classes/python_poetry_core.bbclass
meta/classes/setuptools_build_meta.bbclass

index eef361bb1bd2fbae05c143e8f47f63ce527f9276..96652aa2043af19844282177dd644a7d084656e1 100644 (file)
@@ -3,9 +3,3 @@ inherit python_pep517 python3native python3-dir setuptools3-base
 DEPENDS += "python3 python3-flit-core-native"
 
 PEP517_BUILD_API = "flit_core.buildapi"
-
-python_flit_core_do_configure () {
-    :
-}
-
-EXPORT_FUNCTIONS do_configure
index 73bcf9ba0760bb90d491a8cf1d2a385d33d9690e..34ffdc9c0dbe82a44dea89f7ff0dc39f559fc9ba 100644 (file)
@@ -22,6 +22,12 @@ PEP517_INSTALL_PYTHON:class-native = "nativepython3"
 # pypa/installer option to control the bytecode compilation
 INSTALL_WHEEL_COMPILE_BYTECODE ?= "--compile-bytecode=0"
 
+# PEP517 doesn't have a specific configure step, so set an empty do_configure to avoid
+# running base_do_configure.
+python_pep517_do_configure () {
+    :
+}
+
 # When we have Python 3.11 we can parse pyproject.toml to determine the build
 # API entry point directly
 python_pep517_do_compile () {
@@ -47,4 +53,4 @@ python_pep517_do_bootstrap_install () {
     unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PEP517_WHEEL_PATH}/*.whl
 }
 
-EXPORT_FUNCTIONS do_compile do_install
+EXPORT_FUNCTIONS do_configure do_compile do_install
index 3fecb6c6bb83af258d9dbcaac6c1f07e35099097..577663b8f17b91e1296805da717aec42c64d35f0 100644 (file)
@@ -3,9 +3,3 @@ inherit python_pep517 python3native setuptools3-base
 DEPENDS += "python3-poetry-core-native"
 
 PEP517_BUILD_API = "poetry.core.masonry.api"
-
-python_poetry_core_do_configure () {
-    :
-}
-
-EXPORT_FUNCTIONS do_configure
index 62b037363dfc4d4586da03f4620fccb9725697b8..b2bba35a0bc2d77e8849e1816099d0bcfefdb896 100644 (file)
@@ -3,9 +3,3 @@ inherit setuptools3-base python_pep517
 DEPENDS += "python3-setuptools-native python3-wheel-native"
 
 PEP517_BUILD_API = "setuptools.build_meta"
-
-setuptools_build_meta_do_configure () {
-    :
-}
-
-EXPORT_FUNCTIONS do_configure