]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
at-spi2-core: upgrade 2.50.1 -> 2.52.0
authorWang Mingyu <wangmy@fujitsu.com>
Tue, 26 Mar 2024 00:34:20 +0000 (08:34 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 16 Apr 2024 06:38:36 +0000 (07:38 +0100)
Changelog:
===========
* tests: Fix missing declaration for getpid().
* Back out code to generate mouse events on mutter. It had a couple of
  unwanted side effects. Also remove dependencies on libei and xkbcommon.
* atk-adaptor: Fix collection role matching.
* Have atspi_text_get_string_at_offset fall back to calling
  GetTextAtOffset if GetStringAtOffset is unimplemented.
* Don't use g_assert in the unit tests.
* Add an attribute-changed signal in atk, and update libatspi attribute cache.
* Add GetTextSelection and SetTextSelection to Document interface.
* Add atspi_device_generate_mouse_event, and implement for mutter.
* Have atspi_device_add_key_grab return 0 if XIGrabKeycode fails.
* xml: Add Embedded to the Socket interface
* Don't return uninitialized values if atspi_component_get_size/position fail.
* atk-adaptor: Fix critical when no table cell array is returned.
* accessible: Do not rename deprecated methods to the new names.
* Add HelpText property and corresponding functions in atk and libatspi.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/atk/at-spi2-core_2.52.0.bb [moved from meta/recipes-support/atk/at-spi2-core_2.50.1.bb with 95% similarity]

similarity index 95%
rename from meta/recipes-support/atk/at-spi2-core_2.50.1.bb
rename to meta/recipes-support/atk/at-spi2-core_2.52.0.bb
index 6996ebebcd62f0f71f61caa91c867dd9807b0ac5..cf221e0389271c99ff59bded15cc9c01cfc60dc8 100644 (file)
@@ -11,7 +11,7 @@ MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
 
 SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz"
 
-SRC_URI[sha256sum] = "5727b5c0687ac57ba8040e79bd6731b714a36b8fcf32190f236b8fb3698789e7"
+SRC_URI[sha256sum] = "0ac3fc8320c8d01fa147c272ba7fa03806389c6b03d3c406d0823e30e35ff5ab"
 
 DEPENDS = " \
        dbus \