]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
liberror-perl: move to meta-perl
authorTim Orling <tim.orling@konsulko.com>
Thu, 28 Mar 2024 16:22:21 +0000 (09:22 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 30 Mar 2024 22:18:39 +0000 (22:18 +0000)
The upstream maintainer for Error has deprecated it for quite some time [1].
The only dependency in oe-core was coreutils-ptest.

[YOCTO #15461]

[1] https://metacpan.org/pod/Error#WARNING

    Using the "Error" module is no longer recommended due to the black-magical
    nature of its syntactic sugar, which often tends to break. Its maintainers
    have stopped actively writing code that uses it, and discourage people from
    doing so. See the "SEE ALSO" section below for better recommendations [2].

[2] https://metacpan.org/pod/Error#SEE-ALSO

    SEE ALSO
    --------

    See Exception::Class for a different module providing Object-Oriented
    exception handling, along with a convenient syntax for declaring hierarchies
    for them. It doesn't provide Error's syntactic sugar of try { ... },
    catch { ... }, etc. which may be a good thing or a bad thing based on what
    you want. (Because Error's syntactic sugar tends to break.)

    Error::Exception aims to combine Error and Exception::Class "with correct
    stringification".

    TryCatch and Try::Tiny are similar in concept to Error.pm only providing a
    syntax that hopefully breaks less.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/distro/include/maintainers.inc
meta/conf/distro/include/ptest-packagelists.inc
meta/recipes-devtools/perl/liberror-perl_0.17029.bb [deleted file]

index 4ca5430a941d8fb47d5f5a7a69bff7355c2c6d48..2d1f9fdec5526e0f0e36fd3895421a37618670ce 100644 (file)
@@ -328,7 +328,6 @@ RECIPE_MAINTAINER:pn-libdrm = "Otavio Salvador <otavio.salvador@ossystems.com.br
 RECIPE_MAINTAINER:pn-libedit = "Khem Raj <raj.khem@gmail.com>"
 RECIPE_MAINTAINER:pn-libepoxy = "Anuj Mittal <anuj.mittal@intel.com>"
 RECIPE_MAINTAINER:pn-liberation-fonts = "Alexander Kanavin <alex.kanavin@gmail.com>"
-RECIPE_MAINTAINER:pn-liberror-perl = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-libevdev = "Anuj Mittal <anuj.mittal@intel.com>"
 RECIPE_MAINTAINER:pn-libevent = "Anuj Mittal <anuj.mittal@intel.com>"
 RECIPE_MAINTAINER:pn-libexif = "Alexander Kanavin <alex.kanavin@gmail.com>"
index 0192146dbd09eaab307f0ff0f28921e82aa8da80..84f67644437decc5904d31cc2589260c6b363ded 100644 (file)
@@ -28,7 +28,6 @@ PTESTS_FAST = "\
     json-c \
     json-glib \
     libconvert-asn1-perl \
-    liberror-perl \
     libgpg-error\
     libnl \
     libpcre \
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17029.bb b/meta/recipes-devtools/perl/liberror-perl_0.17029.bb
deleted file mode 100644 (file)
index e54bb11..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-SUMMARY = "Error - Error/exception handling in an OO-ish way"
-DESCRIPTION = "The Error package provides two interfaces. Firstly \
-Error provides a procedural interface to exception handling. \
-Secondly Error is a base class for errors/exceptions that can \
-either be thrown, for subsequent catch, or can simply be recorded."
-HOMEPAGE = "https://github.com/shlomif/perl-error.pm"
-SECTION = "libs"
-LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
-
-
-DEPENDS += "perl"
-
-RDEPENDS:${PN} += " \
-    perl-module-carp \
-    perl-module-exporter \
-    perl-module-scalar-util \
-    perl-module-overload \
-    perl-module-strict \
-    perl-module-vars \
-    perl-module-warnings \
-"
-
-RDEPENDS:${PN}-ptest += " \
-    perl-module-base \
-    perl-module-file-spec \
-    perl-module-io-handle \
-    perl-module-ipc-open3 \
-    perl-module-lib \
-    perl-module-test-more \
-"
-
-SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a"
-SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc"
-
-S = "${WORKDIR}/Error-${PV}"
-
-inherit cpan ptest-perl
-
-do_install:prepend() {
-       # test requires "-T" (taint) command line option
-       rm -rf ${B}/t/pod-coverage.t
-}
-
-BBCLASSEXTEND = "native"