]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
python-*: don't set PYPI_ARCHIVE_NAME and S when PYPI_PACKAGE is sufficient
authorRoss Burton <ross.burton@arm.com>
Fri, 15 Mar 2024 14:37:50 +0000 (14:37 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 22 Mar 2024 16:24:21 +0000 (16:24 +0000)
There's no need to explicitly set PYPI_ARCHIVE_NAME and S when
PYPI_PACKAGE is set correctly.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-jsonschema-specifications_2023.12.1.bb
meta/recipes-devtools/python/python3-poetry-core_1.9.0.bb
meta/recipes-devtools/python/python3-rpds-py_0.18.0.bb
meta/recipes-devtools/python/python3-sphinxcontrib-applehelp_1.0.8.bb
meta/recipes-devtools/python/python3-sphinxcontrib-devhelp_1.0.6.bb
meta/recipes-devtools/python/python3-sphinxcontrib-htmlhelp_2.0.5.bb
meta/recipes-devtools/python/python3-sphinxcontrib-qthelp_1.0.7.bb
meta/recipes-devtools/python/python3-sphinxcontrib-serializinghtml_1.1.10.bb

index bffd59a719eeb11aeb8ff3c3158e6947d6456ed3..eb63509fce43dde2399c36b9ef70fe82ff1ce8fd 100644 (file)
@@ -9,10 +9,8 @@ SRC_URI[sha256sum] = "48a76787b3e70f5ed53f1160d2b81f586e4ca6d1548c5de7085d168267
 
 inherit pypi python_hatchling
 
-DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
-
-S = "${WORKDIR}/jsonschema_specifications-${PV}"
+PYPI_PACKAGE = "jsonschema_specifications"
 
-PYPI_ARCHIVE_NAME = "jsonschema_specifications-${PV}.${PYPI_PACKAGE_EXT}"
+DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
 
 BBCLASSEXTEND = "native nativesdk"
index dfb29c4b86331480b6a6bb4e57f84436350124f3..540fdffaedacf6ca060d01bd92c016290c0e90c6 100644 (file)
@@ -18,8 +18,8 @@ LIC_FILES_CHKSUM = "\
 SRC_URI[sha256sum] = "fa7a4001eae8aa572ee84f35feb510b321bd652e5cf9293249d62853e1f935a2"
 
 inherit python_poetry_core pypi
-PYPI_ARCHIVE_NAME = "poetry_core-${PV}.${PYPI_PACKAGE_EXT}"
-S = "${WORKDIR}/poetry_core-${PV}"
+
+PYPI_PACKAGE = "poetry_core"
 
 RDEPENDS:${PN}:append:class-target = "\
     python3-compression \
index 01fb3d47ce7a6352bbda5ea9f9566e217b3d6530..cece2cb8ccd15d46c2ebaa4657c4965540dfcb07 100644 (file)
@@ -10,8 +10,6 @@ require ${BPN}-crates.inc
 
 inherit pypi cargo-update-recipe-crates python_maturin
 
-S = "${WORKDIR}/rpds_py-${PV}"
-
-PYPI_ARCHIVE_NAME = "rpds_py-${PV}.${PYPI_PACKAGE_EXT}"
+PYPI_PACKAGE = "rpds_py"
 
 BBCLASSEXTEND = "native nativesdk"
index 6ea7c516d50710f1d476d178230a0f8b7199ee72..67dd299b72b20175186993fa68b726f5e9ad3b72 100644 (file)
@@ -5,9 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c7715857042d4c8c0105999ca0c072c5"
 
 SRC_URI[sha256sum] = "c40a4f96f3776c4393d933412053962fac2b84f4c99a7982ba42e09576a70619"
 
-inherit pypi python_flit_core
+PYPI_PACKAGE = "sphinxcontrib_applehelp"
 
-PYPI_ARCHIVE_NAME = "sphinxcontrib_applehelp-${PV}.${PYPI_PACKAGE_EXT}"
-S = "${WORKDIR}/sphinxcontrib_applehelp-${PV}"
+inherit pypi python_flit_core
 
 BBCLASSEXTEND = "native nativesdk"
index dd7ba3dc956a02436b708d33f93e8a9de55af276..31f77a0a141e05340213e301a8afc5f1e5ce40f6 100644 (file)
@@ -5,11 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fd30d9972a142c857a80c9f312e92b93"
 
 SRC_URI[sha256sum] = "9893fd3f90506bc4b97bdb977ceb8fbd823989f4316b28c3841ec128544372d3"
 
-PYPI_PACKAGE = "sphinxcontrib-devhelp"
+PYPI_PACKAGE = "sphinxcontrib_devhelp"
 
 inherit pypi python_flit_core
 
-PYPI_ARCHIVE_NAME = "sphinxcontrib_devhelp-${PV}.${PYPI_PACKAGE_EXT}"
-S = "${WORKDIR}/sphinxcontrib_devhelp-${PV}"
-
 BBCLASSEXTEND = "native nativesdk"
index 532d1fc22aa897e7f37c57c80abc8b1f24191225..e30c61c3980a3391d452f1ca840f174db5694c3e 100644 (file)
@@ -5,11 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=24dce5ef6a13563241c24bc366f48886"
 
 SRC_URI[sha256sum] = "0dc87637d5de53dd5eec3a6a01753b1ccf99494bd756aafecd74b4fa9e729015"
 
-PYPI_PACKAGE = "sphinxcontrib-htmlhelp"
+PYPI_PACKAGE = "sphinxcontrib_htmlhelp"
 
 inherit pypi python_flit_core
 
-PYPI_ARCHIVE_NAME = "sphinxcontrib_htmlhelp-${PV}.${PYPI_PACKAGE_EXT}"
-S = "${WORKDIR}/sphinxcontrib_htmlhelp-${PV}"
-
 BBCLASSEXTEND = "native nativesdk"
index b24f7f8e6fe35d591404d393420649b86819519a..2225ec521e789a6b03b369a42f94855e511d185c 100644 (file)
@@ -5,11 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f7a83b72ea86d04827575ec0b63430eb"
 
 SRC_URI[sha256sum] = "053dedc38823a80a7209a80860b16b722e9e0209e32fea98c90e4e6624588ed6"
 
-PYPI_PACKAGE = "sphinxcontrib-qthelp"
+PYPI_PACKAGE = "sphinxcontrib_qthelp"
 
 inherit pypi python_flit_core
 
-PYPI_ARCHIVE_NAME = "sphinxcontrib_qthelp-${PV}.${PYPI_PACKAGE_EXT}"
-S = "${WORKDIR}/sphinxcontrib_qthelp-${PV}"
-
 BBCLASSEXTEND = "native nativesdk"
index b13bc829775fbbcf5bca27d09dd19c88187cc0c5..49be5200f0f42f982e5c1fb508f89c49422bbccf 100644 (file)
@@ -5,11 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=32a84ac5cd3bbd10c4d479233ad588b6"
 
 SRC_URI[sha256sum] = "93f3f5dc458b91b192fe10c397e324f262cf163d79f3282c158e8436a2c4511f"
 
-PYPI_PACKAGE = "sphinxcontrib-serializinghtml"
+PYPI_PACKAGE = "sphinxcontrib_serializinghtml"
 
 inherit pypi python_flit_core
 
-PYPI_ARCHIVE_NAME = "sphinxcontrib_serializinghtml-${PV}.${PYPI_PACKAGE_EXT}"
-S = "${WORKDIR}/sphinxcontrib_serializinghtml-${PV}"
-
 BBCLASSEXTEND = "native nativesdk"