]> git.ipfire.org Git - thirdparty/openssl.git/blame - openssl.spec
Don't require tag before ciphertext in AESGCM mode
[thirdparty/openssl.git] / openssl.spec
CommitLineData
15877618 1%define _unpackaged_files_terminate_build 0
71fca64d
DSH
2%define libmaj 1
3%define libmin 1
4%define librel 0
1d7fb4f0
RL
5#%define librev a
6Release: 1
775bcebd
RL
7
8%define openssldir /var/ssl
9
10Summary: Secure Sockets Layer and cryptography libraries and tools
11Name: openssl
71fca64d
DSH
12Version: %{libmaj}.%{libmin}.%{librel}
13#Version: %{libmaj}.%{libmin}.%{librel}%{librev}
775bcebd
RL
14Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
15Copyright: Freely distributable
16Group: System Environment/Libraries
17Provides: SSL
18URL: http://www.openssl.org/
19Packager: Damien Miller <djm@mindrot.org>
20BuildRoot: /var/tmp/%{name}-%{version}-root
21
22%description
23The OpenSSL Project is a collaborative effort to develop a robust,
24commercial-grade, fully featured, and Open Source toolkit implementing the
25Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
8c4ab6d5
UM
26protocols as well as a full-strength general purpose cryptography library.
27The project is managed by a worldwide community of volunteers that use the
28Internet to communicate, plan, and develop the OpenSSL tookit and its related
775bcebd
RL
29documentation.
30
31OpenSSL is based on the excellent SSLeay library developed from Eric A.
32Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
33Apache-style licence, which basically means that you are free to get and
34use it for commercial and non-commercial purposes.
35
36This package contains the base OpenSSL cryptography and SSL/TLS
37libraries and tools.
38
39%package devel
40Summary: Secure Sockets Layer and cryptography static libraries and headers
41Group: Development/Libraries
42Requires: openssl
43%description devel
44The OpenSSL Project is a collaborative effort to develop a robust,
45commercial-grade, fully featured, and Open Source toolkit implementing the
46Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
8c4ab6d5
UM
47protocols as well as a full-strength general purpose cryptography library.
48The project is managed by a worldwide community of volunteers that use the
49Internet to communicate, plan, and develop the OpenSSL tookit and its related
775bcebd
RL
50documentation.
51
52OpenSSL is based on the excellent SSLeay library developed from Eric A.
53Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
54Apache-style licence, which basically means that you are free to get and
55use it for commercial and non-commercial purposes.
56
57This package contains the the OpenSSL cryptography and SSL/TLS
58static libraries and header files required when developing applications.
59
60%package doc
61Summary: OpenSSL miscellaneous files
62Group: Documentation
63Requires: openssl
64%description doc
65The OpenSSL Project is a collaborative effort to develop a robust,
66commercial-grade, fully featured, and Open Source toolkit implementing the
67Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
8c4ab6d5
UM
68protocols as well as a full-strength general purpose cryptography library.
69The project is managed by a worldwide community of volunteers that use the
70Internet to communicate, plan, and develop the OpenSSL tookit and its related
775bcebd
RL
71documentation.
72
73OpenSSL is based on the excellent SSLeay library developed from Eric A.
74Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
75Apache-style licence, which basically means that you are free to get and
76use it for commercial and non-commercial purposes.
77
78This package contains the the OpenSSL cryptography and SSL/TLS extra
79documentation and POD files from which the man pages were produced.
80
81%prep
82
83%setup -q
84
85%build
86
9b2042fa 87%define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr --openssldir=%{openssldir}
775bcebd
RL
88
89perl util/perlpath.pl /usr/bin/perl
90
91%ifarch i386 i486 i586 i686
9b2042fa 92./Configure %{CONFIG_FLAGS} linux-elf shared
775bcebd
RL
93%endif
94%ifarch ppc
9b2042fa 95./Configure %{CONFIG_FLAGS} linux-ppc shared
775bcebd
RL
96%endif
97%ifarch alpha
9b2042fa 98./Configure %{CONFIG_FLAGS} linux-alpha shared
775bcebd 99%endif
15877618
DSH
100%ifarch x86_64
101./Configure %{CONFIG_FLAGS} linux-x86_64 shared
102%endif
775bcebd
RL
103LD_LIBRARY_PATH=`pwd` make
104LD_LIBRARY_PATH=`pwd` make rehash
105LD_LIBRARY_PATH=`pwd` make test
106
107%install
108rm -rf $RPM_BUILD_ROOT
1cc087fe 109make MANDIR=/usr/man MANSUFFIX=ssl INSTALL_PREFIX="$RPM_BUILD_ROOT" install
775bcebd 110
775bcebd 111# Make backwards-compatibility symlink to ssleay
501ebf16 112ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
775bcebd 113
775bcebd
RL
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%files
118%defattr(0644,root,root,0755)
119%doc CHANGES CHANGES.SSLeay LICENSE NEWS README
120
121%attr(0755,root,root) /usr/bin/*
122%attr(0755,root,root) /usr/lib/*.so*
123%attr(0755,root,root) %{openssldir}/misc/*
124%attr(0644,root,root) /usr/man/man[157]/*
125
126%config %attr(0644,root,root) %{openssldir}/openssl.cnf
127%dir %attr(0755,root,root) %{openssldir}/certs
775bcebd
RL
128%dir %attr(0755,root,root) %{openssldir}/misc
129%dir %attr(0750,root,root) %{openssldir}/private
130
131%files devel
501ebf16 132%defattr(0644,root,root,0755)
775bcebd
RL
133%doc CHANGES CHANGES.SSLeay LICENSE NEWS README
134
775bcebd 135%attr(0644,root,root) /usr/lib/*.a
9b2042fa 136%attr(0644,root,root) /usr/lib/pkgconfig/openssl.pc
775bcebd
RL
137%attr(0644,root,root) /usr/include/openssl/*
138%attr(0644,root,root) /usr/man/man[3]/*
139
140%files doc
501ebf16 141%defattr(0644,root,root,0755)
775bcebd
RL
142%doc CHANGES CHANGES.SSLeay LICENSE NEWS README
143%doc doc
144
145%post
146ldconfig
147
148%postun
149ldconfig
150
151%changelog
acd1c4b5
RL
152* Sun Jun 6 2005 Richard Levitte <richard@levitte.org>
153- Remove the incorrect installation of '%{openssldir}/lib'.
9b2042fa
RL
154* Wed May 7 2003 Richard Levitte <richard@levitte.org>
155- Add /usr/lib/pkgconfig/openssl.pc to the development section.
1d7fb4f0
RL
156* Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
157- Removed redundant subsection that re-installed libcrypto.a and libssl.a
158 as well. Also remove RSAref stuff completely, since it's not needed
159 any more.
160* Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
161- Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
162 libssl.so.0.9.6. As well as the subsection that created symlinks for
163 these. make install handles all this.
501ebf16
RL
164* Sat Oct 21 2000 Horms <horms@vergenet.net>
165- Make sure symlinks are created by using -f flag to ln.
166 Otherwise some .so libraries are copied rather than
167 linked in the resulting binary RPM. This causes the package
168 to be larger than neccessary and makes ldconfig complain.
169* Fri Oct 13 2000 Horms <horms@vergenet.net>
170- Make defattr is set for files in all packages so packages built as
171 non-root will still be installed with files owned by root.
775bcebd
RL
172* Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
173- Changed to adapt to the new (supported) way of making shared libraries
174- Installs all static libraries, not just libRSAglue.a
175- Extra documents now end up in a separate document package
176* Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
177- Merged patches to spec
178- Updated to 0.9.5beta2 (now with manpages)
179* Sat Feb 5 2000 Michal Jaegermann <michal@harddata.com>
180- added 'linux-alpha' to configuration
181- fixed nasty absolute links
182* Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
183- Added -DSSL_ALLOW_ADH, bumped Release to 4
184* Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
185- Set default permissions
186- Removed documentation from devel sub-package
187* Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
188- Added "make test" stage
189- GPG signed
190* Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
191- Updated to version 0.9.4
192* Tue May 25 1999 Damien Miller <damien@ibs.com.au>
193- Updated to version 0.9.3
194- Added attributes for all files
195- Paramatised openssl directory
196* Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
197- Added "official" bnrec patch and taking other out
198- making a link from ssleay to openssl binary
199- putting all changelog together on SPEC file
200* Fri Mar 5 1999 Henri Gomez <gomez@slib.fr>
201- Added bnrec patch
202* Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
203- minimum spec and patches changes for openssl
204- modified for openssl sources
205* Sat Aug 8 1998 Khimenko Victor <khim@sch57.msk.ru>
206- shared library creating process honours $RPM_OPT_FLAGS
207- shared libarry supports threads (as well as static library)
208* Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
209- building of shared library completely reworked
210* Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
211- RPM is BuildRoot'ed
212* Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
213- all stuff is moved out of /usr/local