]> git.ipfire.org Git - thirdparty/shairport-sync.git/blob - shairport-sync.spec
Update check_classic_mac_basic.yml
[thirdparty/shairport-sync.git] / shairport-sync.spec
1 Name: shairport-sync
2 Version: 3.3.8
3 Release: 1%{?dist}
4 Summary: AirTunes emulator. Multi-Room with Audio Synchronisation
5 # MIT licensed except for tinysvcmdns under BSD,
6 # FFTConvolver/ under GPLv3+ and audio_sndio.c
7 # under ISC
8 License: MIT and BSD and GPLv3+ and ISC
9 URL: https://github.com/mikebrady/shairport-sync
10 Source0: https://github.com/mikebrady/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
11
12 %{?systemd_requires}
13 BuildRequires: systemd
14 BuildRequires: pkgconfig(libconfig)
15 BuildRequires: pkgconfig(popt)
16 BuildRequires: pkgconfig(openssl)
17 BuildRequires: pkgconfig(avahi-core)
18 BuildRequires: pkgconfig(alsa)
19 BuildRequires: pkgconfig(soxr)
20 BuildRequires: autoconf
21 BuildRequires: automake
22
23 %description
24 Shairport Sync emulates an AirPort Express for the purpose of streaming audio
25 from iTunes, iPods, iPhones, iPads and AppleTVs. Audio played by a Shairport
26 Sync-powered device stays synchronised with the source and hence with similar
27 devices playing the same source. Thus, for example, synchronised multi-room
28 audio is possible without difficulty. (Hence the name Shairport Sync, BTW.)
29
30 Shairport Sync does not support AirPlay video or photo streaming.
31
32 %prep
33 %setup -q
34
35 %build
36 autoreconf -i -f
37 %configure --with-avahi --with-alsa --with-ssl=openssl --with-soxr
38 %make_build
39
40 %install
41 %make_install
42 rm %{buildroot}/etc/shairport-sync.conf.sample
43 install -p -m644 -D scripts/shairport-sync.service %{buildroot}%{_unitdir}/%{name}.service
44
45 %pre
46 getent group %{name} &>/dev/null || groupadd --system %{name} >/dev/null
47 getent passwd %{name} &> /dev/null || useradd --system -c "%{name} User" \
48 -d %{_localstatedir}/%{name} -m -g %{name} -s /sbin/nologin \
49 -G audio %{name} >/dev/null
50
51 %post
52 %systemd_post %{name}.service
53
54 %preun
55 %systemd_preun %{name}.service
56
57 %postun
58 %systemd_postun_with_restart %{name}.service
59
60 %files
61 %config(noreplace) /etc/shairport-sync.conf
62 /usr/bin/shairport-sync
63 /usr/share/man/man7/shairport-sync.7.gz
64 %{_unitdir}/%{name}.service
65 %doc README.md RELEASENOTES.md TROUBLESHOOTING.md
66 %license LICENSES
67
68 %changelog
69 * Mon Apr 26 2021 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.3.8
70 - Bug fixes and enhancements.
71 * Tue Nov 1 2020 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.3.7
72 - Jack resampling, bug fixes and additions to the pipe and stdout backends, to metadata and to the D-Bus and MPRIS interfaces.
73 * Thu Feb 20 2020 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.3.6
74 - Jack resampling, bug fixes and additions to the D-Bus and MPRIS interfaces.
75 * Wed Nov 13 2019 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.3.5
76 - Bug fixes and additions to the D-Bus interface.
77 * Mon Oct 28 2019 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.3.4
78 - Bug fixes and minor enhancements.
79 * Fri Jul 26 2019 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.3.2
80 - Minor bug fixes.
81 * Wed Jun 05 2019 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.3.1
82 - Bug fixes.
83 * Fri May 24 2019 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.3
84 - Audio enhancements, stability improvements, MQTT and Jack Audio interfaces.
85 * Sun Oct 14 2018 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.2.2
86 - Compatibility with iOS 12 and mac OS Mojave AirPlay latencies. Minor bug fix.
87 * Fri Jul 13 2018 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.2.1
88 - Stability improvements when soxr interpolation is chosen.
89 * Mon Jul 09 2018 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.2
90 - New D-Bus and MPRIS Interfaces, Bug Fixes and Enhancements.
91 * Thu Dec 21 2017 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.1.7
92 - Bug fix for unexpectedly resuming play at full volume from iOS 11.2 and macOS 10.3.2.
93 * Mon Dec 11 2017 Mike Brady <4265913+mikebrady@users.noreply.github.com> 3.1.5
94 - Bug fixes and better compatibility with iOS 11.2 and mac OS 10.13.2.
95 - Better AirPlay synchronisation.
96 * Wed Sep 13 2017 Bill Peck <bpeck@redhat.com> 3.1.2-1
97 - New upstream release
98 - The default value for the alsa setting mute_using_playback_switch has
99 been changed to "no" for compatibility with other audio players on the
100 same machine. Because of this you may need to unmute your audio device
101 if you are upgrading from an older release.
102 - Fixed bugs that made Shairport Sync drop out or become unavailable when
103 playing YouTube videos, SoundCloud streams etc. from the Mac.
104 * Sun Aug 20 2017 Bill Peck <bpeck@redhat.com> 3.1.1-1
105 - A bug in the sndio backend has been fixed that caused problems on some
106 versions of Linux.
107 - A change has been made to how Shairport Sync responds to a TEARDOWN request,
108 which should make it respond better to sequences of rapid termination and
109 restarting of play sessions. This can happen, for example, playing YouTube
110 videos in Safari or Chrome on a Mac.
111 - Choosing soxr interpolation in the configuration file will now cause
112 Shairport Sync to terminate with a message if Shairport Sync has not been
113 compiled with SoX support.
114 - Other small changes.
115 * Thu Aug 17 2017 Bill Peck <bpeck@redhat.com> 3.1-1
116 - new backend offering synchronised PulseAudio support.
117 - new optional loudness and convolution filters
118 - improvements in non-synchronised backends
119 - enhancements, stability improvements and bug fixes
120 * Fri Feb 24 2017 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.8.6
121 - Many changes including 8- 16- 24- and 32-bit output
122 * Fri Oct 21 2016 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.8.6
123 - Advertise self as ShairportSync rather than AirPort device 2.8.6
124 * Sun Sep 25 2016 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.8.5
125 - Bug fixes and small enhancements 2.8.5
126 * Sat May 28 2016 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.8.4
127 - Bug fixes and a few small enhancements 2.8.4
128 * Fri Apr 15 2016 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.8.2
129 - Stability improvements, bug fixes and a few special-purpose settings 2.8.2
130 * Wed Mar 02 2016 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.8.1
131 - Stability improvements and important bug fixes 2.8.1
132 * Sat Jan 30 2016 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.8.0
133 - Enhancements and bug fixes 2.8.0
134 * Sun Oct 18 2015 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.6
135 - Important enhancements and bug fixes 2.6
136 * Thu Aug 27 2015 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.4.1
137 - Minor bug fixes 2.4.1
138 * Thu Aug 27 2015 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.4
139 - Prepare for stable release 2.4
140 * Wed Aug 26 2015 Mike Brady <4265913+mikebrady@users.noreply.github.com> 2.3.13.1-1
141 - Harmonise release numbers
142 * Fri Jul 24 2015 Bill Peck <bill@pecknet.com> 2.3.7-1
143 - Initial spec file