]> git.ipfire.org Git - thirdparty/systemd.git/blobdiff - man/meson.build
travis: add more ASan options
[thirdparty/systemd.git] / man / meson.build
index 05197d6ef42285766f08aace0f08e567e59bba0c..f3992b28341698418be576efbaae07608be6174b 100644 (file)
@@ -198,12 +198,21 @@ if git.found()
         custom_target(
                 'update-man-rules',
                 output : 'update-man-rules',
-                # slightly strange syntax because of
-                # https://github.com/mesonbuild/meson/issues/1643
-                # and https://github.com/mesonbuild/meson/issues/1512
                 command : ['sh', '-c',
                            'cd @0@ && '.format(meson.build_root()) +
-                           'python3 @0@/tools/make-man-rules.py `git ls-files ":/man/*.xml"` >t && '.format(meson.source_root()) +
+                           'python3 @0@/tools/make-man-rules.py $(git ls-files ":/man/*.xml") >t && '.format(project_source_root) +
                            'mv t @0@/rules/meson.build'.format(meson.current_source_dir())],
                 depend_files : custom_entities_ent)
 endif
+
+############################################################
+
+configure_file(
+        input : 'man.in',
+        output : 'man',
+        configuration : substs)
+
+configure_file(
+        input : 'html.in',
+        output : 'html',
+        configuration : substs)