]> git.ipfire.org Git - thirdparty/e2fsprogs.git/blame - e2fsprogs.spec
fsck.c (parse_fstab_line, parse_escape): Add support for
[thirdparty/e2fsprogs.git] / e2fsprogs.spec
CommitLineData
8a31ffef 1Summary: Utilities for managing the second extended (ext2) filesystem.
24757fa0 2Name: e2fsprogs
38513011 3Version: 1.32
24757fa0
TT
4Release: 0
5Copyright: GPL
8a31ffef 6Group: System Environment/Base
f9e67064 7Buildroot: /var/tmp/%{name}-root
f5955dda 8Source: ftp://download.sourceforge.net/pub/sourceforge/e2fsprogs/e2fsprogs-%{version}.tar.gz
f9e67064 9Prereq: /sbin/ldconfig
24757fa0
TT
10
11%description
8a31ffef
TT
12The e2fsprogs package contains a number of utilities for creating,
13checking, modifying and correcting any inconsistencies in second
14extended (ext2) filesystems. E2fsprogs contains e2fsck (used to repair
15filesystem inconsistencies after an unclean shutdown), mke2fs (used to
16initialize a partition to contain an empty ext2 filesystem), debugfs
17(used to examine the internal structure of a filesystem, to manually
18repair a corrupted filesystem or to create test cases for e2fsck), tune2fs
7adb91d8
TT
19(used to modify filesystem parameters), resize2fs to grow and shrink
20unmounted ext2 filesystems, and most of the other core ext2fs filesystem
21utilities.
8a31ffef
TT
22
23You should install the e2fsprogs package if you are using any ext2
24filesystems (if you're not sure, you probably should install this
25package).
24757fa0
TT
26
27%package devel
8a31ffef 28Summary: Ext2 filesystem-specific static libraries and headers.
24757fa0 29Group: Development/Libraries
ca483f04 30Requires: e2fsprogs
24757fa0 31
f9e67064 32%description devel
8a31ffef
TT
33E2fsprogs-devel contains the libraries and header files needed to
34develop second extended (ext2) filesystem-specific programs.
35
36You should install e2fsprogs-devel if you want to develop ext2
f9e67064 37filesystem-specific programs. If you install e2fsprogs-devel, you'll
8a31ffef 38also need to install e2fsprogs.
24757fa0
TT
39
40%prep
41%setup
42
43%build
f5955dda
TT
44CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
45./configure --enable-elf-shlibs --mandir=%{_mandir} --infodir=%{_infodir}
24757fa0
TT
46
47make libs progs docs
48
49%install
f9e67064 50rm -rf $RPM_BUILD_ROOT
24757fa0 51export PATH=/sbin:$PATH
f9e67064 52make install install-libs DESTDIR="$RPM_BUILD_ROOT"
24757fa0 53
24757fa0
TT
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
58/sbin/ldconfig
ab146766
TT
59# Remove possibly old version
60/bin/rm -f /usr/sbin/resize2fs
24757fa0 61
f9e67064
TT
62%postun -p /sbin/ldconfig
63
64%post devel
65if [ -x /sbin/install-info ]; then
f5955dda 66 /sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir
f9e67064
TT
67fi
68
69%postun devel
70if [ $1 = 0 -a -x /sbin/install-info ]; then
f5955dda 71 /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir
f9e67064 72fi
24757fa0
TT
73
74%files
f9e67064
TT
75%defattr(-,root,root)
76%doc README RELEASE-NOTES
77
78/sbin/badblocks
79/sbin/debugfs
80/sbin/dumpe2fs
81/sbin/e2fsck
82/sbin/e2label
d5d9215f 83/sbin/e2image
f9e67064
TT
84/sbin/fsck
85/sbin/fsck.ext2
86/sbin/fsck.ext3
87/sbin/mke2fs
88/sbin/mkfs.ext2
0072f8de 89/sbin/mkfs.ext3
f9e67064
TT
90/sbin/tune2fs
91/sbin/resize2fs
92/usr/sbin/mklost+found
93
94/lib/libcom_err.so.*
95/lib/libe2p.so.*
96/lib/libext2fs.so.*
97/lib/libss.so.*
98/lib/libuuid.so.*
99
100/usr/bin/chattr
101/usr/bin/lsattr
102/usr/bin/uuidgen
16c1ce89
TT
103%{_mandir}/man1/chattr.1*
104%{_mandir}/man1/lsattr.1*
105%{_mandir}/man1/uuidgen.1*
106
107%{_mandir}/man8/badblocks.8*
108%{_mandir}/man8/debugfs.8*
109%{_mandir}/man8/dumpe2fs.8*
110%{_mandir}/man8/e2fsck.8*
111%{_mandir}/man8/e2label.8*
d5d9215f 112%{_mandir}/man8/e2image.8*
16c1ce89
TT
113%{_mandir}/man8/fsck.8*
114%{_mandir}/man8/mke2fs.8*
115%{_mandir}/man8/mklost+found.8*
116%{_mandir}/man8/resize2fs.8*
117%{_mandir}/man8/tune2fs.8*
24757fa0
TT
118
119%files devel
f9e67064 120%defattr(-,root,root)
f5955dda 121%{_infodir}/libext2fs.info*
f9e67064
TT
122/usr/bin/compile_et
123/usr/bin/mk_cmds
124
125/usr/lib/libcom_err.a
126/usr/lib/libcom_err.so
127/usr/lib/libe2p.a
128/usr/lib/libe2p.so
129/usr/lib/libext2fs.a
130/usr/lib/libext2fs.so
131/usr/lib/libss.a
132/usr/lib/libss.so
133/usr/lib/libuuid.a
134/usr/lib/libuuid.so
135
136/usr/share/et
137/usr/share/ss
138/usr/include/et
139/usr/include/ext2fs
140/usr/include/ss
141/usr/include/uuid
16c1ce89
TT
142%{_mandir}/man1/compile_et.1*
143%{_mandir}/man3/com_err.3*
4941fe80
AD
144%{_mandir}/man3/libuuid.3*
145%{_mandir}/man3/uuid*.3*