]> git.ipfire.org Git - thirdparty/e2fsprogs.git/blobdiff - debian/rules
debian: add Build-Depend-Package to the symbol files
[thirdparty/e2fsprogs.git] / debian / rules
index e44422c142ca2808bc3fb31f072599c628261e62..9bbdea492d3938a53771e64a12e852642b4389d5 100755 (executable)
@@ -56,7 +56,7 @@ dh_strip_args2 = -p$(1) --dbgsym-migration='$(2)-dbg (<= 1.43-1)'
 else
 dh_strip_args = -p$(1) --dbg-package=$(1)-dbg
 dh_strip_args2 = -p$(1) --dbg-package=$(2)-dbg
-DBG_PACKAGES += -pe2fsprogs-dbg -pe2fslibs-dbg -plibcomerr2-dbg -plibss2-dbg
+DBG_PACKAGES += -pe2fsprogs-dbg -plibext2fs-dbg -plibcom-err2-dbg -plibss2-dbg
 export DEB_BUILD_PROFILES += pkg.e2fsprogs.legacy-dbg
 endif
 
@@ -78,15 +78,15 @@ topdir              ?= $(shell pwd)
 debdir         ?= ${topdir}/debian
 tmpdir         ?= ${debdir}/tmp
 udebdir                ?= ${debdir}/e2fsprogs-udeb
-libcomerrdir   ?= ${debdir}/libcomerr${COMERR_SOVERSION}
+libcomerrdir   ?= ${debdir}/libcom-err${COMERR_SOVERSION}
 comerrdevdir   ?= ${debdir}/comerr-dev
-libcomerrdbgdir        ?= ${debdir}/libcomerr2-dbg
+libcomerrdbgdir        ?= ${debdir}/libcom-err2-dbg
 libssdir       ?= ${debdir}/libss${SS_SOVERSION}
 ssdevdir       ?= ${debdir}/ss-dev
 libssdbgdir    ?= ${debdir}/libss2-dbg
-libext2dir     ?= ${debdir}/e2fslibs
-libext2devdir  ?= ${debdir}/e2fslibs-dev
-libext2dbgdir  ?= ${debdir}/e2fslibs-dbg
+libext2dir     ?= ${debdir}/libext2fs2
+libext2devdir  ?= ${debdir}/libext2fs-dev
+libext2dbgdir  ?= ${debdir}/libext2fs2-dbg
 maindir                ?= ${debdir}/e2fsprogs
 e2fsckstaticdir        ?= ${debdir}/e2fsck-static
 debugdir       ?= ${debdir}/e2fsprogs-dbg
@@ -112,7 +112,7 @@ INSTALL_PROGRAM ?= $(INSTALL) -p -o root -g root -m 0755
 #endif
 
 ifneq (,$(findstring update-symbols,$(DEB_BUILD_OPTIONS)))
-SYMBOL_LIBS := e2fslibs libcomerr2 libss2
+SYMBOL_LIBS := libext2fs libcomerr2 libss2
 endif
 
 DEFAULT_CFLAGS ?= -g -O2
@@ -182,8 +182,18 @@ INSTALL_UDEB = install-udeb
 endif
 
 debian-files:
+ifneq ($(USE_DBGSYM),yes)
+       if test ! -f debian/control.save; then \
+               mv debian/control debian/control.save ; \
+               cat debian/control.save debian/control.legacy-dbg \
+                       >> debian/control ; \
+       fi
+endif
 
 mrproper: clean
+       if test -f debian/control.save; then \
+               mv debian/control.save debian/control ; \
+       fi
 
 ${CFGSTDSTAMP}:
        dh_testdir
@@ -269,6 +279,8 @@ endif
 
        ( cd ${stdbuilddir}/doc && $(MAKE) V=1 libext2fs.html )
        ( cd ${stdbuilddir}/lib/et && $(MAKE) V=1 com_err.info com_err.html )
+       cat $(shell /bin/ls -1 ./doc/RelNotes/*.txt | tac) | \
+               gzip -9n > ${stdbuilddir}/NEWS.gz
 
        touch ${BUILDSTDSTAMP}
 
@@ -318,6 +330,8 @@ ifeq ($(DEB_HOST_ARCH_OS), hurd)
        ${INSTALL} -m 0644 misc/mke2fs-hurd.conf ${tmpdir}/etc/mke2fs.conf
 endif
 
+       dh_install -p e2fsprogs --sourcedir=${stdbuilddir} NEWS.gz \
+               usr/share/doc/e2fsprogs
        dh_movefiles
        test -z "`find ${tmpdir} -type f`"
 
@@ -367,43 +381,40 @@ binary-arch: install $(INSTALL_UDEB)
 
        mkdir -p ${debdir}/libss${SS_SOVERSION}/usr/share/doc/libss${SS_SOVERSION}
        mkdir -p ${debdir}/ss-dev/usr/share/doc
-       ln -sf libss${SS_SOVERSION} ${debdir}/ss-dev/usr/share/doc/ss-dev
 
-       mkdir -p ${debdir}/libcomerr${COMERR_SOVERSION}/usr/share/doc/libcomerr${COMERR_SOVERSION}
+       mkdir -p ${debdir}/libcom-err${COMERR_SOVERSION}/usr/share/doc/libcom-err${COMERR_SOVERSION}
        mkdir -p ${debdir}/comerr-dev/usr/share/doc
-       ln -sf libcomerr${COMERR_SOVERSION} ${debdir}/comerr-dev/usr/share/doc/comerr-dev
 
-       mkdir -p ${debdir}/e2fslibs/usr/share/doc/e2fslibs
-       mkdir -p ${debdir}/e2fslibs-dev/usr/share/doc
-       ln -sf e2fslibs ${debdir}/e2fslibs-dev/usr/share/doc/e2fslibs-dev
+       mkdir -p ${debdir}/libext2fs2/usr/share/doc/libext2fs2
+       mkdir -p ${debdir}/libext2fs-dev/usr/share/doc
 
        dh_installdocs -a -Ne2fsprogs-udeb
 
   # HTML docs
-       $(INSTALL) -d ${debdir}/e2fslibs-dev/usr/share/doc/e2fslibs/html-info/
+       $(INSTALL) -d ${debdir}/libext2fs-dev/usr/share/doc/libext2fs2/html-info/
        $(INSTALL) -p -m 0644 ${stdbuilddir}/doc/*.html \
-          ${debdir}/e2fslibs-dev/usr/share/doc/e2fslibs/html-info/
-       $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/html-info/
+          ${debdir}/libext2fs-dev/usr/share/doc/libext2fs2/html-info/
+       $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/comerr-dev/html-info/
        $(INSTALL) -p -m 0644 ${stdbuilddir}/lib/et/*.html \
-          ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/html-info/
+          ${debdir}/comerr-dev/usr/share/doc/comerr-dev/html-info/
 
   # texinfo docs
-       mkdir -p ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}
+       mkdir -p ${debdir}/comerr-dev/usr/share/doc/comerr-dev
        $(INSTALL) -p -m 0644 ${topdir}/doc/libext2fs.texinfo \
-          ${debdir}/e2fslibs-dev/usr/share/doc/e2fslibs/libext2fs.texi
+          ${debdir}/libext2fs-dev/usr/share/doc/libext2fs2/libext2fs.texi
        $(INSTALL) -p -m 0644 ${topdir}/lib/et/com_err.texinfo \
-          ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/com_err.texi
+          ${debdir}/comerr-dev/usr/share/doc/comerr-dev/com_err.texi
 
-       $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/examples
+       $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/comerr-dev/examples
        $(INSTALL) -p -m 0644 lib/ss/ss_err.et \
                ${stdbuilddir}/lib/ext2fs/ext2_err.et \
-               ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/examples
-       $(INSTALL) -d ${debdir}/ss-dev/usr/share/doc/libss${SS_SOVERSION}/examples
+               ${debdir}/comerr-dev/usr/share/doc/comerr-dev/examples
+       $(INSTALL) -d ${debdir}/ss-dev/usr/share/doc/ss-dev/examples
        $(INSTALL) -p -m 0644 debugfs/debug_cmds.ct \
-               ${debdir}/ss-dev/usr/share/doc/libss${SS_SOVERSION}/examples
+               ${debdir}/ss-dev/usr/share/doc/ss-dev/examples
 
        dh_installinfo -pcomerr-dev ${stdbuilddir}/lib/et/com_err.info
-       dh_installinfo -pe2fslibs-dev ${stdbuilddir}/doc/libext2fs.info
+       dh_installinfo -plibext2fs-dev ${stdbuilddir}/doc/libext2fs.info
 
        dh_installchangelogs -a
        dh_fixperms -a
@@ -411,9 +422,9 @@ binary-arch: install $(INSTALL_UDEB)
 ifneq ($(SKIP_E2FSCK_STATIC),yes)
        dh_strip $(call dh_strip_args2,e2fsck-static,e2fsprogs)
 endif
-       dh_strip $(call dh_strip_args,e2fslibs)
+       dh_strip $(call dh_strip_args,libext2fs2)
        dh_strip $(call dh_strip_args,libss${SS_SOVERSION})
-       dh_strip $(call dh_strip_args,libcomerr${COMERR_SOVERSION})
+       dh_strip $(call dh_strip_args,libcom-err${COMERR_SOVERSION})
        dh_strip -a
 
        # dpkg symbol handling
@@ -430,6 +441,8 @@ endif
 
        dh_makeshlibs -a --add-udeb=e2fsprogs-udeb
 
+       $(INSTALL) -D -p -m644 debian/e2fsprogs-udeb.lintian-overrides \
+           debian/e2fsprogs-udeb/usr/share/lintian/overrides/e2fsprogs-udeb
        dh_installdeb -a
        dh_shlibdeps -a -l${stdbuilddir}/lib
        dh_shlibdeps -pe2fsprogs -l${stdbuilddir}/lib \