]> git.ipfire.org Git - thirdparty/e2fsprogs.git/blobdiff - debian/rules
Merge branch 'maint' into next
[thirdparty/e2fsprogs.git] / debian / rules
index 841715d90fc02f1bad693a16ec859b9540e7ee09..b05154e443d816aca670a11f4c74c0ec49f3488b 100755 (executable)
@@ -7,7 +7,9 @@
 # The `binary' target must be run as root, as it needs to install files with
 # specific ownerships.
 
--include debian/rules.custom
+.PHONY: binary binary-arch binary-indep build build-arch build-indep \
+       build-bf build-std install install-udeb \
+       clean checkroot mrproper debug_flags debian-files
 
 export DEB_BUILD_MAINT_OPTIONS ?= hardening=+all
 
@@ -31,8 +33,22 @@ ifeq ($(DEB_HOST_ARCH_OS), hurd)
 SKIP_FUSE2FS=yes
 endif
 
+ifneq ($(filter pkg.e2fsprogs.no-fuse2fs,$(DEB_BUILD_PROFILES)),)
+SKIP_FUSE2FS=yes
+endif
+
+ifneq ($(filter pkg.e2fsprogs.no-static-e2fsck,$(DEB_BUILD_PROFILES)),)
+SKIP_E2FSCK_STATIC=yes
+endif
+
+ifneq ($(filter noudeb,$(DEB_BUILD_PROFILES)),)
+SKIP_UDEB=yes
+endif
+
 DH_VERSION := $(shell dpkg-query -W -f '$${Version}' debhelper)
 
+USE_DH9 ?= $(shell if dpkg --compare-versions $(DH_VERSION) lt 11 ; then echo yes ; fi)
+
 # USE_DBGSYM :=
 USE_DBGSYM ?= $(shell if dpkg --compare-versions $(DH_VERSION) ">=" 9.20160114 ; then echo yes ; fi)
 
@@ -42,7 +58,10 @@ dh_strip_args2 = -p$(1) --dbgsym-migration='$(2)-dbg (<= 1.43-1)'
 else
 dh_strip_args = -p$(1) --dbg-package=$(1)-dbg
 dh_strip_args2 = -p$(1) --dbg-package=$(2)-dbg
+DBG_PACKAGES += -pe2fsprogs-dbg -plibext2fs-dbg -plibcom-err2-dbg -plibss2-dbg
+export DEB_BUILD_PROFILES += pkg.e2fsprogs.legacy-dbg
 endif
+
 # find the version for the main package, from changelog file
 MAIN_VERSION = $(shell head -n 1 debian/changelog | cut '-d ' -f 2 | sed 's/[()]//g')
 # find versions for libraries going into their own packages, from their Makefile.in's,
@@ -61,15 +80,15 @@ topdir              ?= $(shell pwd)
 debdir         ?= ${topdir}/debian
 tmpdir         ?= ${debdir}/tmp
 udebdir                ?= ${debdir}/e2fsprogs-udeb
-libcomerrdir   ?= ${debdir}/libcomerr${COMERR_SOVERSION}
+libcomerrdir   ?= ${debdir}/libcom-err${COMERR_SOVERSION}
 comerrdevdir   ?= ${debdir}/comerr-dev
-libcomerrdbgdir        ?= ${debdir}/libcomerr2-dbg
+libcomerrdbgdir        ?= ${debdir}/libcom-err2-dbg
 libssdir       ?= ${debdir}/libss${SS_SOVERSION}
 ssdevdir       ?= ${debdir}/ss-dev
 libssdbgdir    ?= ${debdir}/libss2-dbg
-libext2dir     ?= ${debdir}/e2fslibs
-libext2devdir  ?= ${debdir}/e2fslibs-dev
-libext2dbgdir  ?= ${debdir}/e2fslibs-dbg
+libext2dir     ?= ${debdir}/libext2fs2
+libext2devdir  ?= ${debdir}/libext2fs-dev
+libext2dbgdir  ?= ${debdir}/libext2fs2-dbg
 maindir                ?= ${debdir}/e2fsprogs
 e2fsckstaticdir        ?= ${debdir}/e2fsck-static
 debugdir       ?= ${debdir}/e2fsprogs-dbg
@@ -79,9 +98,10 @@ MANDIR               ?= /usr/share/man
 mandir         ?= ${tmpdir}${MANDIR}
 
 UDEB_NAME      ?= $(package)-udeb_$(MAIN_VERSION)_$(DEB_HOST_ARCH).udeb
-UDEB_PRIORITY  ?= $(shell grep '^Package: e2fsprogs-udeb' debian/control.in -A 10 | grep ^Priority: | cut -d ' ' -f 2)
+UDEB_PRIORITY  ?= $(shell grep '^Package: e2fsprogs-udeb' debian/control -A 10 | grep ^Priority: | cut -d ' ' -f 2)
 
 STAMPSDIR      ?= debian/stampdir
+CFGDH          ?= ${STAMPSDIR}/configure-dh
 CFGSTDSTAMP    ?= ${STAMPSDIR}/configure-std-stamp
 CFGBFSTAMP     ?= ${STAMPSDIR}/configure-bf-stamp
 BUILDSTDSTAMP  ?= ${STAMPSDIR}/build-std-stamp
@@ -95,7 +115,7 @@ INSTALL_PROGRAM ?= $(INSTALL) -p -o root -g root -m 0755
 #endif
 
 ifneq (,$(findstring update-symbols,$(DEB_BUILD_OPTIONS)))
-SYMBOL_LIBS := e2fslibs libcomerr2 libss2
+SYMBOL_LIBS := libext2fs libcomerr2 libss2
 endif
 
 DEFAULT_CFLAGS ?= -g -O2
@@ -147,7 +167,8 @@ endif
 
 BACKTRACE_CONF_FLAGS ?= $(shell if ${debdir}/scripts/test-backtrace ; then echo --disable-backtrace ; fi)
 
-COMMON_CONF_FLAGS = --disable-e2initrd-helper \
+COMMON_CONF_FLAGS = --enable-lto --disable-ubsan --disable-addrsan \
+       --disable-threadsan --disable-e2initrd-helper \
        --infodir=/usr/share/info  --enable-symlink-install \
        --with-multiarch=$(DEB_HOST_MULTIARCH) \
        $(BACKTRACE_CONF_FLAGS) $(UTIL_CONF_FLAGS)
@@ -158,38 +179,38 @@ BF_CONF_FLAGS ?= --enable-elf-shlibs --disable-nls --disable-imager \
        --disable-testio-debug --disable-uuidd --disable-tls \
        --disable-tdb --disable-debugfs
 
-M4_ARGS=
 DBG_PACKAGES=
 
-ifeq ($(USE_DBGSYM),yes)
-M4_ARGS+=-DUSE_DBGSYM
-else
-DBG_PACKAGES += -pe2fsprogs-dbg -pe2fslibs-dbg -plibcomerr2-dbg -plibss2-dbg
-M4_ARGS+=-UUSE_DBGSYM
-endif
-
-ifneq ($(BUILD_E2FSCK_STATIC),no)
-M4_ARGS+=-DE2FSCK_STATIC
-else
-M4_ARGS+=-UE2FSCK_STATIC
-endif
-
 ifeq ($(SKIP_UDEB),)
 INSTALL_UDEB = install-udeb
-M4_ARGS+=-DUDEB_PKGS
-else
-M4_ARGS+=-UUDEB_PKGS
 endif
 
-debian-files: debian/control
+debian-files:
+ifneq ($(USE_DBGSYM),yes)
+       if test ! -f debian/control.save; then \
+               mv debian/control debian/control.save ; \
+               cat debian/control.save debian/control.legacy-dbg \
+                       >> debian/control ; \
+       fi
+endif
 
 mrproper: clean
-       rm debian/control
+       if test -f debian/control.save; then \
+               mv debian/control.save debian/control ; \
+       fi
 
-debian/control: debian/control.in debian/rules
-       m4 $(M4_ARGS) < debian/control.in | grep -v ^REMOVE_ME$$ > $@
+${CFGDH}:
+ifeq ($(USE_DH9),yes)
+       mv debian/compat debian/compat.save
+       echo 9 > debian/compat
+       mv debian/e2fsprogs.postinst debian/e2fsprogs.postinst.save
+       cp debian/e2fsprogs.postinst.dh9 debian/e2fsprogs.postinst
+       cp debian/e2fsprogs.postrm.dh9 debian/e2fsprogs.postrm
+endif
+       mkdir -p ${STAMPSDIR}
+       touch ${CFGDH}
 
-${CFGSTDSTAMP}:
+${CFGSTDSTAMP}: ${CFGDH}
        dh_testdir
        if which dh_update_autotools_config > /dev/null 2>&1 ; then \
                dh_update_autotools_config ;\
@@ -222,7 +243,7 @@ endif
        mkdir -p ${STAMPSDIR}
        touch ${CFGSTDSTAMP}
 
-${CFGBFSTAMP}:
+${CFGBFSTAMP}: ${CFGDH}
        dh_testdir
        if which dh_update_autotools_config > /dev/null 2>&1 ; then \
                dh_update_autotools_config ;\
@@ -261,7 +282,7 @@ build-std: ${BUILDSTDSTAMP}
 ${BUILDSTDSTAMP}: ${CFGSTDSTAMP}
        dh_testdir
        $(MAKE) -C ${stdbuilddir} V=1 all
-ifneq ($(BUILD_E2FSCK_STATIC),no)
+ifneq ($(SKIP_E2FSCK_STATIC),yes)
        $(MAKE) -C ${stdbuilddir}/e2fsck V=1 e2fsck.static
 endif
        if ! test -d debian/orig-gmo ; then \
@@ -292,6 +313,15 @@ clean:
                mv debian/orig-gmo/* po ; \
                rmdir debian/orig-gmo ; \
        fi
+       if test -f debian/compat.save; then \
+               mv debian/compat.save debian/compat ; \
+       fi
+       if test -f debian/e2fsprogs.postinst.save; then \
+               mv debian/e2fsprogs.postinst.save debian/e2fsprogs.postinst ; \
+       fi
+       if test -f debian/e2fsprogs.postrm; then \
+               rm -f debian/e2fsprogs.postrm ; \
+       fi
        rm -rf ${STAMPSDIR}
        [ ! -f ${stdbuilddir}/Makefile ] || $(MAKE) -C ${stdbuilddir} V=1 distclean
        [ ! -f ${bfbuilddir}/Makefile ] || $(MAKE) -C ${bfbuilddir} V=1 distclean
@@ -300,20 +330,10 @@ clean:
        rm -f debian/*.substvars
        dh_clean
 
-install: cleanup install-std
-
-# This rule allows to factorize the dh_clean between the 2 install rules
-# This must be launched before install-* (if launching them by hand, for
-# example) or results are unpredictable
-cleanup:
+install: build
        dh_testdir
        dh_testroot
        dh_prep
-
-install-std: DH_OPTIONS=
-install-std: build
-       dh_testdir
-       dh_testroot
        dh_installdirs
 
        mkdir -p ${tmpdir}/sbin
@@ -322,7 +342,7 @@ install-std: build
   # static libs and .h files
        $(MAKE) -C ${stdbuilddir} V=1 install-libs DESTDIR=${tmpdir} LDCONFIG=true
 
-ifneq ($(BUILD_E2FSCK_STATIC),no)
+ifneq ($(SKIP_E2FSCK_STATIC),yes)
   # statically-linked fsck
        ${INSTALL_PROGRAM} $(E2FSCK_STATIC) ${tmpdir}/sbin
        cp ${mandir}/man8/e2fsck.8 ${mandir}/man8/e2fsck.static.8
@@ -335,7 +355,6 @@ endif
        dh_movefiles
        test -z "`find ${tmpdir} -type f`"
 
-install-udeb: DH_OPTIONS=
 install-udeb: build
        dh_testdir
        dh_testroot
@@ -363,6 +382,7 @@ binary-indep: install
        dh_testdir
        dh_testroot
        dh_lintian -i
+       dh_installdocs -i
        dh_installchangelogs -i
        dh_fixperms -i
        dh_compress -i
@@ -371,68 +391,61 @@ binary-indep: install
        dh_md5sums -i
        dh_builddeb -i
 
-# binary-arch builds a superset of binary-indep.  This is because
-# building e2fsprogs-l10n.deb unnecessarily takes less time than
-# running the install recipe twice.  At some point when we rototill
-# the rules file we can clean this up in a better way.
 binary-arch: install $(INSTALL_UDEB)
        dh_testdir
        dh_testroot
 
-       dh_lintian
+       dh_lintian -a
 
   # symlinks to prepare dh_installdocs run
 
        mkdir -p ${debdir}/libss${SS_SOVERSION}/usr/share/doc/libss${SS_SOVERSION}
        mkdir -p ${debdir}/ss-dev/usr/share/doc
-       ln -sf libss${SS_SOVERSION} ${debdir}/ss-dev/usr/share/doc/ss-dev
 
-       mkdir -p ${debdir}/libcomerr${COMERR_SOVERSION}/usr/share/doc/libcomerr${COMERR_SOVERSION}
+       mkdir -p ${debdir}/libcom-err${COMERR_SOVERSION}/usr/share/doc/libcom-err${COMERR_SOVERSION}
        mkdir -p ${debdir}/comerr-dev/usr/share/doc
-       ln -sf libcomerr${COMERR_SOVERSION} ${debdir}/comerr-dev/usr/share/doc/comerr-dev
 
-       mkdir -p ${debdir}/e2fslibs/usr/share/doc/e2fslibs
-       mkdir -p ${debdir}/e2fslibs-dev/usr/share/doc
-       ln -sf e2fslibs ${debdir}/e2fslibs-dev/usr/share/doc/e2fslibs-dev
+       mkdir -p ${debdir}/libext2fs2/usr/share/doc/libext2fs
+       mkdir -p ${debdir}/libext2fs-dev/usr/share/doc
 
-       dh_installdocs -Ne2fsprogs-udeb
+       dh_installdocs -a -Ne2fsprogs-udeb
 
   # HTML docs
-       $(INSTALL) -d ${debdir}/e2fslibs-dev/usr/share/doc/e2fslibs/html-info/
+       $(INSTALL) -d ${debdir}/libext2fs-dev/usr/share/doc/libext2fs/html-info/
        $(INSTALL) -p -m 0644 ${stdbuilddir}/doc/*.html \
-          ${debdir}/e2fslibs-dev/usr/share/doc/e2fslibs/html-info/
-       $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/html-info/
+          ${debdir}/libext2fs-dev/usr/share/doc/libext2fs/html-info/
+       $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/comerr-dev/html-info/
        $(INSTALL) -p -m 0644 ${stdbuilddir}/lib/et/*.html \
-          ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/html-info/
+          ${debdir}/comerr-dev/usr/share/doc/comerr-dev/html-info/
 
   # texinfo docs
-       mkdir -p ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}
+       mkdir -p ${debdir}/comerr-dev/usr/share/doc/comerr-dev
        $(INSTALL) -p -m 0644 ${topdir}/doc/libext2fs.texinfo \
-          ${debdir}/e2fslibs-dev/usr/share/doc/e2fslibs/libext2fs.texi
+          ${debdir}/libext2fs-dev/usr/share/doc/libext2fs/libext2fs.texi
        $(INSTALL) -p -m 0644 ${topdir}/lib/et/com_err.texinfo \
-          ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/com_err.texi
+          ${debdir}/comerr-dev/usr/share/doc/comerr-dev/com_err.texi
 
-       $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/examples
+       $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/comerr-dev/examples
        $(INSTALL) -p -m 0644 lib/ss/ss_err.et \
                ${stdbuilddir}/lib/ext2fs/ext2_err.et \
-               ${debdir}/comerr-dev/usr/share/doc/libcomerr${COMERR_SOVERSION}/examples
-       $(INSTALL) -d ${debdir}/ss-dev/usr/share/doc/libss${SS_SOVERSION}/examples
+               ${debdir}/comerr-dev/usr/share/doc/comerr-dev/examples
+       $(INSTALL) -d ${debdir}/ss-dev/usr/share/doc/ss-dev/examples
        $(INSTALL) -p -m 0644 debugfs/debug_cmds.ct \
-               ${debdir}/ss-dev/usr/share/doc/libss${SS_SOVERSION}/examples
+               ${debdir}/ss-dev/usr/share/doc/ss-dev/examples
 
        dh_installinfo -pcomerr-dev ${stdbuilddir}/lib/et/com_err.info
-       dh_installinfo -pe2fslibs-dev ${stdbuilddir}/doc/libext2fs.info
+       dh_installinfo -plibext2fs-dev ${stdbuilddir}/doc/libext2fs.info
 
-       dh_installchangelogs
-       dh_fixperms
+       dh_installchangelogs -a
+       dh_fixperms -a
        dh_strip $(call dh_strip_args,e2fsprogs)
-ifneq ($(BUILD_E2FSCK_STATIC),no)
+ifneq ($(SKIP_E2FSCK_STATIC),yes)
        dh_strip $(call dh_strip_args2,e2fsck-static,e2fsprogs)
 endif
-       dh_strip $(call dh_strip_args,e2fslibs)
+       dh_strip $(call dh_strip_args,libext2fs2)
        dh_strip $(call dh_strip_args,libss${SS_SOVERSION})
-       dh_strip $(call dh_strip_args,libcomerr${COMERR_SOVERSION})
-       dh_strip
+       dh_strip $(call dh_strip_args,libcom-err${COMERR_SOVERSION})
+       dh_strip -a
 
        # dpkg symbol handling
        for i in $(SYMBOL_LIBS); \
@@ -444,12 +457,16 @@ endif
                /bin/rm debian/$$i.tmp-patch; \
        done
 
-       dh_compress
-
-       dh_makeshlibs --add-udeb=e2fsprogs-udeb
+       dh_compress -a
 
-       dh_installdeb
-       dh_shlibdeps -l${stdbuilddir}/lib
+       dh_makeshlibs -a --add-udeb=e2fsprogs-udeb
+ifneq ($(USE_DH9),yes)
+       dh_installsystemd -p e2fsprogs
+endif
+       $(INSTALL) -D -p -m644 debian/e2fsprogs-udeb.lintian-overrides \
+           debian/e2fsprogs-udeb/usr/share/lintian/overrides/e2fsprogs-udeb
+       dh_installdeb -a
+       dh_shlibdeps -a -l${stdbuilddir}/lib
        dh_shlibdeps -pe2fsprogs -l${stdbuilddir}/lib \
                -u"-Ldebian/e2fsprogs.shlibs.local"
 ifeq ($(SKIP_UDEB),)
@@ -461,27 +478,22 @@ ifeq ($(SKIP_FUSE2FS),)
                -u"-Ldebian/e2fsprogs.shlibs.local"
 endif
 
-       dh_gencontrol -Ncomerr-dev -Nss-dev -Ne2fsprogs-udeb
-       DH_OPTIONS= dh_gencontrol -pcomerr-dev \
+       dh_gencontrol -a -Ncomerr-dev -Nss-dev -Ne2fsprogs-udeb
+       dh_gencontrol -pcomerr-dev \
          -u '-v${COMERR_VERSION}-${MAIN_VERSION} -VmainBinary=${MAIN_VERSION}'
-       DH_OPTIONS= dh_gencontrol -pss-dev \
+       dh_gencontrol -pss-dev \
          -u '-v${SS_VERSION}-${MAIN_VERSION} -VmainBinary=${MAIN_VERSION}'
 ifeq ($(SKIP_UDEB),)
-       dh_gencontrol   -pe2fsprogs-udeb -- -fdebian/files~
+       dh_gencontrol -pe2fsprogs-udeb -- -fdebian/files~
 endif
 
 ifeq ($(SKIP_UDEB),)
        dpkg-distaddfile $(UDEB_NAME) debian-installer $(UDEB_PRIORITY)
 endif
-       dh_md5sums
-       dh_builddeb
-
-# binary-arch builds a superset of binary-indep.  See the comment
-# before the binary-arch rule for more details.
-binary: binary-arch
+       dh_md5sums -a
+       dh_builddeb -a
 
-.PHONY: binary binary-arch binary-indep clean checkroot mrproper \
-       debug_flags debian-files
+binary: binary-indep binary-arch
 
 debug_flags:
        @echo CFLAGS is $(CFLAGS)