]> git.ipfire.org Git - location/libloc.git/blobdiff - debian/changelog
Bump version to 0.9.12
[location/libloc.git] / debian / changelog
index fcef2cb4ac994ad6bf1990c552dd81a2c8d26951..75244004c49c568fbe625c115d21e66c2ec4e86c 100644 (file)
@@ -1,4 +1,128 @@
-libloc (0.9.8-1) UNRELEASED; urgency=medium
+libloc (0.9.12-1) unstable; urgency=medium
+
+  [ Michael Tremer ]
+  * importer: Parse aggregated networks
+  * database: Return something when no filter criteria is configured
+  * importer: Correctly hande response codes from Bird
+  * importer: Silently ignore any table headers
+  * importer: Skip empty lines
+  * location: Fix output of list-* commands
+  * network: Move a couple of helper functions into headers
+  * network: Add function that counts the bit length of an addres
+  * network: Drop functions moved in an earlier commit
+  * network-list: Rewrite summarize algorithm
+  * network: Allow creating any valid networks
+  * network: Implement bit length function for IPv4
+  * addresses: Implement subtraction for IPv4
+  * bogons: Refactor algorithms
+  * network-list: Cap prefix length based on family
+  * address: Correctly subtract IPv4 addresses
+  * bogons: Reset after we have reached the end
+  * bogons: Don't consider a network legitimate without a country code
+  * Move all address convenience functions into their own header
+  * address: Rename in6_addr_cmp into loc_address_cmp
+  * address: Rename in6_addr_get_bit/in6_addr_set_bit to loc_address_*
+  * addresses: Use loc_address_family which is now available
+  * address: Rename increment/decrement functions and modify address in
+    place
+  * network: Pass prefix in native length
+  * strings: Statically allocate all address/network strings
+  * address: Initialize all bits of IP addresses
+  * address: Prevent under/overflow when incrementing/decrementing
+  * network-list: Simplify debugging output on summarize
+  * network-list: summarize: Break when we exhausted the network range
+  * network-list: Remove debugging line
+  * address: Simplify functions
+  * address: Fix decrementing IP addresses
+  * address: Fix buffer overwrite
+  * address: Add some simple tests
+  * bogons: Add gaps that are only one address wide
+  * bogons: Skip any subnets of former networks
+  * as-list: Grow faster to avoid too many re-allocations
+  * writer: Use AS list internally
+  * network-list: Grow just like the AS list
+  * country-list: Grow like AS list
+  * writer: Use country list internally
+  * importer: Improve performance of network export query
+  * writer: I forgot to initalize the country list
+  * Refactor parsing IP addresses
+  * address: Set default prefix if none is given
+
+ -- Michael Tremer <michael.tremer@ipfire.org>  Wed, 23 Mar 2022 20:11:29 +0000
+
+libloc (0.9.11-1) unstable; urgency=medium
+
+  [ Stefan Schantl ]
+  * export: Remove prefix when exporting countries.
+
+  [ Michael Tremer ]
+  * ipset: Optimise hash table size
+  * ipset: Fix hash type for IPv6
+  * ipset: Set maxelem to a fixed size
+  * export: Conditionally enable flattening
+  * location: Print proper error message for any uncaught exceptions
+  * export: Allow exporting to stdout
+  * ipset: The minimum hashsize is 64
+  * export: Fix filtering logic
+  * export: Sightly refactor export logic
+  * Bump release to 0.9.11
+
+  [ Peter Müller ]
+  * location-importer: Fix parsing LACNIC-flavoured inetnums
+
+ -- Michael Tremer <michael.tremer@ipfire.org>  Thu, 03 Mar 2022 10:44:44 +0000
+
+libloc (0.9.10-1) unstable; urgency=medium
+
+  [ Peter Müller ]
+  * Non-maintainer upload.
+  * location-importer: Set "is_drop" to "True" even in case of conflicts
+  * Process LACNIC geofeed as well
+  * location-importer: Improve regex for catching historic/orphaned data
+  * location-importer: Replace "UK" with "GB"
+  * location-importer.in: Add country code for AWS's "il-central-1" zone
+  * location-importer.in: Do not make things more complicated than they
+    are
+
+  [ Michael Tremer ]
+  * man: Add pages for top level functions
+  * man: Add man page for loc_database_new
+  * man: Add man pages for all loc_database_* functions
+  * export: Make ipset files easily reloadable
+
+ -- Michael Tremer <michael.tremer@ipfire.org>  Wed, 16 Feb 2022 08:53:48 +0000
+
+libloc (0.9.9-2) unstable; urgency=medium
+
+  * Fix broken Debian build
+
+ -- Michael Tremer <michael.tremer@ipfire.org>  Tue, 23 Nov 2021 11:07:22 +0000
+
+libloc (0.9.9-1) unstable; urgency=medium
+
+  [ Michael Tremer ]
+  * database: Make IP address const for lookup
+  * configure: Enable -fno-semantic-interposition by default
+  * network: Drop redundant loc_network_match_flag
+  * network: Drop useless loc_network_match_asn function
+  * stringpool: Make functions properly private
+  * Make loc_network_tree_* functions propertly private
+  * Remove LOC_EXPORT from
+    loc_network_to_database_v1/loc_network_new_from_database_v1
+  * country: Add function that returns flags for special country
+  * country: Make country codes beginning with X invalid
+  * network: Make loc_network_match_country_code match special countries
+  * network: Rename "match" functions to "matches"
+
+  [ Peter Müller ]
+  * location.txt: Improve manpage
+  * importer.py: Import JPNIC feed as well
+  * location-importer: Introduce auxiliary function to sanitise ASNs
+  * location-importer.in: Add Spamhaus DROP lists
+
+ -- Michael Tremer <michael.tremer@ipfire.org>  Sat, 20 Nov 2021 15:12:28 +0000
+
+libloc (0.9.8-1) unstable; urgency=medium
 
   [ Michael Tremer ]
   * importer: Do not try to initialise a column that cannot be NULL with