Load libata prior udev at installer because some SATA doesnt autoload it
authorArne Fitzenreiter <arne_f@ipfire.org>
Sat, 6 Sep 2008 19:09:44 +0000 (21:09 +0200)
committerArne Fitzenreiter <arne_f@ipfire.org>
Sat, 6 Sep 2008 19:09:44 +0000 (21:09 +0200)
Add countrycode for atheros wlan cards

config/install/rc
config/rootfiles/common/madwifi
doc/packages-list.txt
lfs/initrd
lfs/madwifi
src/install+setup/install/main.c
src/install+setup/install/probehw.sh

index 48d02bb..dd1fc1d 100644 (file)
@@ -32,6 +32,10 @@ ln -s /proc/kcore /dev/core
 echo "Starting syslogd"
 syslogd -O /dev/tty4
 
+echo "Loading scsi_mod & libata module"
+modprobe scsi_mod
+modprobe libata
+
 echo "Starting udev daemon"
 /sbin/udevd --daemon
 /sbin/udevtrigger
index d4bf0ea..692063a 100644 (file)
@@ -1,4 +1,5 @@
 etc/madwifi.conf
+etc/modprobe.d/madwifi
 usr/bin/80211debug
 usr/bin/80211stats
 usr/bin/ath_info
index 546077d..cd6a008 100644 (file)
 * psmisc-22.2
 * qemu-0.9.1
 * r8168-8.005.00
+* r8169-6.005.00
 * readline-5.1
 * reiser4progs-1.0.5
 * reiserfsprogs-3.6.19
index a98f375..b4d0e3b 100644 (file)
@@ -70,7 +70,7 @@ $(TARGET) :
        cp /opt/$(MACHINE)-uClibc/lib/libgcc_s.so.1 /install/initrd/lib/
 
        cd /install/initrd/lib/ && ln -sf libgcc_s.so.1 libgcc_s.so
-       
+
        -mkdir -p /install/{images,mnt}
        rm -rf /install/mnt/*
 
index 509013e..9f2f9c4 100644 (file)
@@ -81,4 +81,7 @@ ifeq "$(SMP)" ""
        cp $(DIR_SRC)/config/madwifi/madwifi.conf /etc/
        ln -s $(DIR_APP) $(DIR_SRC)/madwifi 
 endif
+       # Set Countrycode to germany because some cards
+       # are not detected without cc
+       echo options ath_pci countrycode=276 > /etc/modprobe.d/madwifi
        @$(POSTBUILD)
index 5e12811..0fe97a1 100644 (file)
@@ -107,7 +107,6 @@ int main(int argc, char *argv[])
        mysystem("/sbin/modprobe generic");
        mysystem("/sbin/modprobe ide-cd");
        mysystem("/sbin/modprobe ide-disk");
-       mysystem("/sbin/modprobe sata_via");
        mysystem("/sbin/modprobe uhci-hcd");
        mysystem("/sbin/modprobe ohci-hcd");
        mysystem("/sbin/modprobe ehci-hcd");
index 0872d25..c56462e 100644 (file)
@@ -55,7 +55,7 @@ for i in a b c d e f g; do
        fi
 done
 
-for MODULE in $(ls /lib/modules/*/kernel/drivers/scsi); do
+for MODULE in $(ls /lib/modules/*/kernel/drivers/ata && ls /lib/modules/*/kernel/drivers/scsi); do
        MODULE=`basename $MODULE | awk -F. '{ print $1 }'`
        
        echo -n "Probing for $MODULE"