]> git.ipfire.org Git - thirdparty/binutils-gdb.git/blobdiff - gprof/configure.in
top level:
[thirdparty/binutils-gdb.git] / gprof / configure.in
index 46c01ebed61384805041e6ee92809e87a6cffeb2..9cfe317f71313ec14a918fcbe23a5ea4fb0c67ec 100644 (file)
@@ -1,35 +1,81 @@
 dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.5)dnl
-AC_INIT(gprof.c)
+AC_PREREQ(2.59)
+AC_INIT
+AC_CONFIG_SRCDIR([gprof.c])
 
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET([])
+AC_ISC_POSIX
 
-AM_INIT_AUTOMAKE(gprof, 2.9.1)
+changequote(,)dnl
+BFD_VERSION=`sed -n -e 's/^.._INIT_AUTOMAKE.*,[        ]*\([^  ]*\)[   ]*).*/\1/p' < ${srcdir}/../bfd/configure.in`
+changequote([,])dnl
+AM_INIT_AUTOMAKE(gprof, ${BFD_VERSION})
 
 AM_PROG_LIBTOOL
 
+# Package version.  For an official FSF release, it is empty.
+AC_ARG_WITH(pkgversion,
+  AS_HELP_STRING([--with-pkgversion=PKG],
+                 [Add PKG to the version string]),
+  [case "$withval" in
+    yes) AC_MSG_ERROR([package version not specified]) ;;
+    no)  PKGVERSION= ;;
+    *)   PKGVERSION="($withval) " ;;
+   esac],
+  PKGVERSION=
+)
+AC_SUBST(PKGVERSION)
+
+# The location to which bugs should be reported.
+AC_ARG_WITH(bugurl,
+  AS_HELP_STRING([--with-bugurl=URL],
+                 [Direct users to URL to report a bug]),
+  [case "$withval" in
+    yes) AC_MSG_ERROR([bug URL not specified]) ;;
+    no)  REPORT_BUGS_TO="" ;;
+    *)   REPORT_BUGS_TO="<URL:$withval>" ;;
+   esac],
+   REPORT_BUGS_TO="<URL:http://www.sourceware.org/bugzilla/>"
+)
+AC_SUBST(REPORT_BUGS_TO)
+
 dnl For simplicity, we use the BFD configuration file for most
 dnl things.  However, we also need our own configuration file for
 dnl the automake PACKAGE and VERSION macros.  We don't name it
 dnl config.h, to avoid any possible confusion with the bfd config.h.
-AM_CONFIG_HEADER(gconfig.h:gconfig.in)
+AC_CONFIG_HEADERS([gconfig.h:gconfig.in])
 
 AC_PROG_CC
-AM_PROG_INSTALL
+AC_PROG_INSTALL
 
-AC_ISC_POSIX
+AC_CHECK_FUNCS(setmode)
 
-dnl We need to set BSD44_FORMAT on a host which uses the additional
-dnl header fields.  This is an attempt to do that.  I can't think of a
-dnl good feature test for this.
-case "${target}" in
-*-*-bsd4.4* | *-*-netbsd* | *-*-freebsd* | *-*-openbsd*)
-  AC_DEFINE(BSD44_FORMAT)
-  ;;
-esac
+ALL_LINGUAS="fr tr sv es id da pt_BR de vi rw ga ms"
+ZW_GNU_GETTEXT_SISTER_DIR
+AM_PO_SUBDIRS
 
 AM_MAINTAINER_MODE
-AM_CYGWIN32
-AM_EXEEXT
+AM_CONDITIONAL(GENINSRC_NEVER, false)
+AC_EXEEXT
+
+AC_CHECK_HEADERS(sys/gmon_out.h)
+
+AC_MSG_CHECKING(for a known getopt prototype in unistd.h)
+AC_CACHE_VAL(gprof_cv_decl_getopt_unistd_h,
+[AC_TRY_COMPILE([#include <unistd.h>], [extern int getopt (int, char *const*, const char *);],
+gprof_cv_decl_getopt_unistd_h=yes, gprof_cv_decl_getopt_unistd_h=no)])
+AC_MSG_RESULT($gprof_cv_decl_getopt_unistd_h)
+if test $gprof_cv_decl_getopt_unistd_h = yes; then
+  AC_DEFINE([HAVE_DECL_GETOPT], 1,
+           [Is the prototype for getopt in <unistd.h> in the expected format?])
+fi
+
+AM_BINUTILS_WARNINGS
+
+dnl Required by html and install-html
+AC_SUBST(datarootdir)
+AC_SUBST(docdir)
+AC_SUBST(htmldir)
 
-AC_OUTPUT(Makefile)
+AC_CONFIG_FILES([Makefile po/Makefile.in:po/Make-in])
+AC_OUTPUT