]> git.ipfire.org Git - thirdparty/binutils-gdb.git/blobdiff - gprof/configure.in
top level:
[thirdparty/binutils-gdb.git] / gprof / configure.in
index 95c2b8640c23608fd14648c6789f4b469fba1de8..9cfe317f71313ec14a918fcbe23a5ea4fb0c67ec 100644 (file)
@@ -13,6 +13,32 @@ AM_INIT_AUTOMAKE(gprof, ${BFD_VERSION})
 
 AM_PROG_LIBTOOL
 
+# Package version.  For an official FSF release, it is empty.
+AC_ARG_WITH(pkgversion,
+  AS_HELP_STRING([--with-pkgversion=PKG],
+                 [Add PKG to the version string]),
+  [case "$withval" in
+    yes) AC_MSG_ERROR([package version not specified]) ;;
+    no)  PKGVERSION= ;;
+    *)   PKGVERSION="($withval) " ;;
+   esac],
+  PKGVERSION=
+)
+AC_SUBST(PKGVERSION)
+
+# The location to which bugs should be reported.
+AC_ARG_WITH(bugurl,
+  AS_HELP_STRING([--with-bugurl=URL],
+                 [Direct users to URL to report a bug]),
+  [case "$withval" in
+    yes) AC_MSG_ERROR([bug URL not specified]) ;;
+    no)  REPORT_BUGS_TO="" ;;
+    *)   REPORT_BUGS_TO="<URL:$withval>" ;;
+   esac],
+   REPORT_BUGS_TO="<URL:http://www.sourceware.org/bugzilla/>"
+)
+AC_SUBST(REPORT_BUGS_TO)
+
 dnl For simplicity, we use the BFD configuration file for most
 dnl things.  However, we also need our own configuration file for
 dnl the automake PACKAGE and VERSION macros.  We don't name it