]> git.ipfire.org Git - thirdparty/e2fsprogs.git/blob - e2fsprogs.spec
Update for 1.25 release.
[thirdparty/e2fsprogs.git] / e2fsprogs.spec
1 Summary: Utilities for managing the second extended (ext2) filesystem.
2 Name: e2fsprogs
3 Version: 1.25
4 Release: 0
5 Copyright: GPL
6 Group: System Environment/Base
7 Buildroot: /var/tmp/%{name}-root
8 Source: ftp://download.sourceforge.net/pub/sourceforge/e2fsprogs/e2fsprogs-%{version}.tar.gz
9 Prereq: /sbin/ldconfig
10
11 %description
12 The e2fsprogs package contains a number of utilities for creating,
13 checking, modifying and correcting any inconsistencies in second
14 extended (ext2) filesystems. E2fsprogs contains e2fsck (used to repair
15 filesystem inconsistencies after an unclean shutdown), mke2fs (used to
16 initialize a partition to contain an empty ext2 filesystem), debugfs
17 (used to examine the internal structure of a filesystem, to manually
18 repair a corrupted filesystem or to create test cases for e2fsck), tune2fs
19 (used to modify filesystem parameters), resize2fs to grow and shrink
20 unmounted ext2 filesystems, and most of the other core ext2fs filesystem
21 utilities.
22
23 You should install the e2fsprogs package if you are using any ext2
24 filesystems (if you're not sure, you probably should install this
25 package).
26
27 %package devel
28 Summary: Ext2 filesystem-specific static libraries and headers.
29 Group: Development/Libraries
30 Requires: e2fsprogs
31
32 %description devel
33 E2fsprogs-devel contains the libraries and header files needed to
34 develop second extended (ext2) filesystem-specific programs.
35
36 You should install e2fsprogs-devel if you want to develop ext2
37 filesystem-specific programs. If you install e2fsprogs-devel, you'll
38 also need to install e2fsprogs.
39
40 %prep
41 %setup
42
43 %build
44 CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
45 ./configure --enable-elf-shlibs --mandir=%{_mandir} --infodir=%{_infodir}
46
47 make libs progs docs
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 export PATH=/sbin:$PATH
52 make install install-libs DESTDIR="$RPM_BUILD_ROOT"
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 /sbin/ldconfig
59 # Remove possibly old version
60 /bin/rm -f /usr/sbin/resize2fs
61
62 %postun -p /sbin/ldconfig
63
64 %post devel
65 if [ -x /sbin/install-info ]; then
66 /sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir
67 fi
68
69 %postun devel
70 if [ $1 = 0 -a -x /sbin/install-info ]; then
71 /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir
72 fi
73
74 %files
75 %defattr(-,root,root)
76 %doc README RELEASE-NOTES
77
78 /sbin/badblocks
79 /sbin/debugfs
80 /sbin/dumpe2fs
81 /sbin/e2fsck
82 /sbin/e2label
83 /sbin/e2image
84 /sbin/fsck
85 /sbin/fsck.ext2
86 /sbin/fsck.ext3
87 /sbin/mke2fs
88 /sbin/mkfs.ext2
89 /sbin/tune2fs
90 /sbin/resize2fs
91 /usr/sbin/mklost+found
92
93 /lib/libcom_err.so.*
94 /lib/libe2p.so.*
95 /lib/libext2fs.so.*
96 /lib/libss.so.*
97 /lib/libuuid.so.*
98
99 /usr/bin/chattr
100 /usr/bin/lsattr
101 /usr/bin/uuidgen
102 %{_mandir}/man1/chattr.1*
103 %{_mandir}/man1/lsattr.1*
104 %{_mandir}/man1/uuidgen.1*
105
106 %{_mandir}/man8/badblocks.8*
107 %{_mandir}/man8/debugfs.8*
108 %{_mandir}/man8/dumpe2fs.8*
109 %{_mandir}/man8/e2fsck.8*
110 %{_mandir}/man8/e2label.8*
111 %{_mandir}/man8/e2image.8*
112 %{_mandir}/man8/fsck.8*
113 %{_mandir}/man8/mke2fs.8*
114 %{_mandir}/man8/mklost+found.8*
115 %{_mandir}/man8/resize2fs.8*
116 %{_mandir}/man8/tune2fs.8*
117
118 %files devel
119 %defattr(-,root,root)
120 %{_infodir}/libext2fs.info*
121 /usr/bin/compile_et
122 /usr/bin/mk_cmds
123
124 /usr/lib/libcom_err.a
125 /usr/lib/libcom_err.so
126 /usr/lib/libe2p.a
127 /usr/lib/libe2p.so
128 /usr/lib/libext2fs.a
129 /usr/lib/libext2fs.so
130 /usr/lib/libss.a
131 /usr/lib/libss.so
132 /usr/lib/libuuid.a
133 /usr/lib/libuuid.so
134
135 /usr/share/et
136 /usr/share/ss
137 /usr/include/et
138 /usr/include/ext2fs
139 /usr/include/ss
140 /usr/include/uuid
141 %{_mandir}/man1/compile_et.1*
142 %{_mandir}/man3/com_err.3*
143