]> git.ipfire.org Git - thirdparty/e2fsprogs.git/blob - e2fsprogs.spec
configure.in:
[thirdparty/e2fsprogs.git] / e2fsprogs.spec
1 Summary: Utilities for managing the second extended (ext2) filesystem.
2 Name: e2fsprogs
3 Version: 1.19
4 Release: 0
5 Copyright: GPL
6 Group: System Environment/Base
7 Buildroot: /var/tmp/%{name}-root
8 Source: ftp://download.sourceforge.net/pub/sourceforge/e2fsprogs/e2fsprogs-1.19.tar.gz
9 Prereq: /sbin/ldconfig
10
11 %description
12 The e2fsprogs package contains a number of utilities for creating,
13 checking, modifying and correcting any inconsistencies in second
14 extended (ext2) filesystems. E2fsprogs contains e2fsck (used to repair
15 filesystem inconsistencies after an unclean shutdown), mke2fs (used to
16 initialize a partition to contain an empty ext2 filesystem), debugfs
17 (used to examine the internal structure of a filesystem, to manually
18 repair a corrupted filesystem or to create test cases for e2fsck), tune2fs
19 (used to modify filesystem parameters) and most of the other core ext2fs
20 filesystem utilities.
21
22 You should install the e2fsprogs package if you are using any ext2
23 filesystems (if you're not sure, you probably should install this
24 package).
25
26 %package devel
27 Summary: Ext2 filesystem-specific static libraries and headers.
28 Group: Development/Libraries
29 Requires: e2fsprogs
30
31 %description devel
32 E2fsprogs-devel contains the libraries and header files needed to
33 develop second extended (ext2) filesystem-specific programs.
34
35 You should install e2fsprogs-devel if you want to develop ext2
36 filesystem-specific programs. If you install e2fsprogs-devel, you'll
37 also need to install e2fsprogs.
38
39 %prep
40 %setup
41
42 %build
43 CFLAGS="$RPM_OPT_FLAGS" ./configure --enable-elf-shlibs
44
45 make libs progs docs
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 export PATH=/sbin:$PATH
50 make install install-libs DESTDIR="$RPM_BUILD_ROOT"
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 /sbin/ldconfig
57 # Remove possibly old version
58 /bin/rm -f /usr/sbin/resize2fs
59
60 %postun -p /sbin/ldconfig
61
62 %post devel
63 if [ -x /sbin/install-info ]; then
64 /sbin/install-info /usr/info/libext2fs.info.gz /usr/info/dir
65 fi
66
67 %postun devel
68 if [ $1 = 0 -a -x /sbin/install-info ]; then
69 /sbin/install-info --delete /usr/info/libext2fs.info.gz /usr/info/dir
70 fi
71
72 %files
73 %defattr(-,root,root)
74 %doc README RELEASE-NOTES
75
76 /sbin/badblocks
77 /sbin/debugfs
78 /sbin/dumpe2fs
79 /sbin/e2fsck
80 /sbin/e2label
81 /sbin/fsck
82 /sbin/fsck.ext2
83 /sbin/fsck.ext3
84 /sbin/mke2fs
85 /sbin/mkfs.ext2
86 /sbin/tune2fs
87 /sbin/resize2fs
88 /usr/sbin/mklost+found
89
90 /lib/libcom_err.so.*
91 /lib/libe2p.so.*
92 /lib/libext2fs.so.*
93 /lib/libss.so.*
94 /lib/libuuid.so.*
95
96 /usr/bin/chattr
97 /usr/bin/lsattr
98 /usr/bin/uuidgen
99 /usr/man/man1/chattr.1*
100 /usr/man/man1/lsattr.1*
101 /usr/man/man1/uuidgen.1*
102
103 /usr/man/man8/badblocks.8*
104 /usr/man/man8/debugfs.8*
105 /usr/man/man8/dumpe2fs.8*
106 /usr/man/man8/e2fsck.8*
107 /usr/man/man8/e2label.8*
108 /usr/man/man8/fsck.8*
109 /usr/man/man8/mke2fs.8*
110 /usr/man/man8/mklost+found.8*
111 /usr/man/man8/resize2fs.8*
112 /usr/man/man8/tune2fs.8*
113
114 %files devel
115 %defattr(-,root,root)
116 /usr/info/libext2fs.info*
117 /usr/bin/compile_et
118 /usr/bin/mk_cmds
119
120 /usr/lib/libcom_err.a
121 /usr/lib/libcom_err.so
122 /usr/lib/libe2p.a
123 /usr/lib/libe2p.so
124 /usr/lib/libext2fs.a
125 /usr/lib/libext2fs.so
126 /usr/lib/libss.a
127 /usr/lib/libss.so
128 /usr/lib/libuuid.a
129 /usr/lib/libuuid.so
130
131 /usr/share/et
132 /usr/share/ss
133 /usr/include/et
134 /usr/include/ext2fs
135 /usr/include/ss
136 /usr/include/uuid
137 /usr/man/man1/compile_et.1*
138 /usr/man/man3/com_err.3*
139